------------------------------------------------------------------------ r12179 | smatz | 2008-02-18 18:35:36 +0000 (Mon, 18 Feb 2008) | 1 line -Codechange: use GetCrossingRailTrack() and GetCrossingRailAxis() to improve code readability ------------------------------------------------------------------------ r12178 | smatz | 2008-02-18 16:35:38 +0000 (Mon, 18 Feb 2008) | 1 line -Codechange: use the 'side' parameter in TrainController and TrainCheckIfLineEnds to simplify the code ------------------------------------------------------------------------ r12177 | smatz | 2008-02-18 16:11:31 +0000 (Mon, 18 Feb 2008) | 1 line -Codechange: use 'side' parameter in GetTileTrackStatus so there can be less checks in pathfinders for depots/stations/tunnels/bridges ------------------------------------------------------------------------ r12176 | smatz | 2008-02-18 14:59:30 +0000 (Mon, 18 Feb 2008) | 1 line -Codechange: one division less when playing sounds (patch by Dominik) ------------------------------------------------------------------------ r12175 | peter1138 | 2008-02-18 13:19:57 +0000 (Mon, 18 Feb 2008) | 2 lines -Fix (r12174): Ensure the patches window is centred properly. ------------------------------------------------------------------------ r12174 | peter1138 | 2008-02-18 12:36:10 +0000 (Mon, 18 Feb 2008) | 2 lines -Codechange: Make the patches window dynamically resize to the largest patch tab, so adding patch options is simply a case of adding to the lists. ------------------------------------------------------------------------ r12173 | peter1138 | 2008-02-18 11:47:53 +0000 (Mon, 18 Feb 2008) | 2 lines -Cleanup: Minor codestyle fixes. ------------------------------------------------------------------------ r12172 | peter1138 | 2008-02-18 09:16:02 +0000 (Mon, 18 Feb 2008) | 2 lines -Codechange: Allow buttons to resize in NewGRF settings window ------------------------------------------------------------------------ r12171 | smatz | 2008-02-18 01:42:21 +0000 (Mon, 18 Feb 2008) | 2 lines -Fix [FS#609]: return correct bridge price for AI when DC_QUERY_COST is set (patch by Raimar Falke) It never happens in current code, but it is better to be ready for it ------------------------------------------------------------------------ r12170 | smatz | 2008-02-17 21:27:44 +0000 (Sun, 17 Feb 2008) | 1 line -Fix: do not draw trees along road and street lights under low bridges (spotted by _minime_) ------------------------------------------------------------------------ r12169 | smatz | 2008-02-17 20:15:20 +0000 (Sun, 17 Feb 2008) | 2 lines -Change [FS#1696]: play sounds when there is only small part of tile/vehicle visible too (original idea by Dominik) It improves the game appearance when playing with very small screen resolution ------------------------------------------------------------------------ r12168 | smatz | 2008-02-17 18:19:33 +0000 (Sun, 17 Feb 2008) | 1 line -Fix: behave a bit better when 'R' is pressed during rail station dragging ------------------------------------------------------------------------ r12167 | smatz | 2008-02-17 17:00:43 +0000 (Sun, 17 Feb 2008) | 1 line -Feature(tte): change colour of autorail and autoroad selection when Ctrl is pressed ------------------------------------------------------------------------ r12166 | smatz | 2008-02-17 12:21:05 +0000 (Sun, 17 Feb 2008) | 1 line -Fix [FS#337]: when drag&drop mode was cancelled by keyboard input, depot/group window wasn't updated (original patch by GrimRC) ------------------------------------------------------------------------ r12165 | glx | 2008-02-17 00:47:39 +0000 (Sun, 17 Feb 2008) | 1 line -Fix [FS#1652, FS#1773]: buffer overflow when drawing scrolling news ------------------------------------------------------------------------ r12164 | peter1138 | 2008-02-16 23:09:33 +0000 (Sat, 16 Feb 2008) | 2 lines -Fix (r12137, FS#1775]: Variable scope bug crept in ------------------------------------------------------------------------ r12163 | smatz | 2008-02-16 22:29:30 +0000 (Sat, 16 Feb 2008) | 1 line -Fix [FS#1705]: if a train is 'stopping' when entering a depot, do not let it leave again ------------------------------------------------------------------------ r12162 | smatz | 2008-02-16 17:54:29 +0000 (Sat, 16 Feb 2008) | 1 line -Fix [FS#1757]: towns shouldn't build over houses owned by another town ------------------------------------------------------------------------ r12161 | smatz | 2008-02-16 17:10:14 +0000 (Sat, 16 Feb 2008) | 1 line -Fix: towns will no longer build houses > 1x1 there where should be road (with 2x2, 3x3 grid town layouts) ------------------------------------------------------------------------ r12160 | smatz | 2008-02-16 16:40:47 +0000 (Sat, 16 Feb 2008) | 1 line -Fix [FS#1744]: remove the arbitrary limit of 64 waypoints per town, so weird things won't happen anymore ------------------------------------------------------------------------ r12159 | belugas | 2008-02-16 03:12:57 +0000 (Sat, 16 Feb 2008) | 2 lines -Codechange: Enumify some widget magical numbers -Cleanup: apply a bit of code style. Mostly re-indenting switch cases ------------------------------------------------------------------------ r12158 | belugas | 2008-02-16 03:01:05 +0000 (Sat, 16 Feb 2008) | 2 lines -Codechange: merge all the sprite recolouring mapping under a single function -Fix: Handle the bridge recolouring mapping as the other features. Although not specified by the specs, it seems to be implicit. ------------------------------------------------------------------------ r12157 | belugas | 2008-02-16 02:37:31 +0000 (Sat, 16 Feb 2008) | 2 lines -Codechange: Remove a structure definition and replace it with another one closely matching -Codechange: Replace two magic numbers with according sprite names ------------------------------------------------------------------------ r12156 | smatz | 2008-02-16 00:46:38 +0000 (Sat, 16 Feb 2008) | 1 line -Fix (r11454): Chance16I was now biased towards zero - round to nearest now ------------------------------------------------------------------------ r12155 | glx | 2008-02-16 00:10:03 +0000 (Sat, 16 Feb 2008) | 1 line -Fix (r12154): some warnings (always compile before commit) ------------------------------------------------------------------------ r12154 | glx | 2008-02-15 23:57:03 +0000 (Fri, 15 Feb 2008) | 1 line -Codechange: removed a magic number ------------------------------------------------------------------------ r12150 | smatz | 2008-02-15 21:05:46 +0000 (Fri, 15 Feb 2008) | 1 line -Fix (r12143): compiler warnings - possible use of uninitialised variable ------------------------------------------------------------------------ r12149 | frosch | 2008-02-15 18:40:42 +0000 (Fri, 15 Feb 2008) | 1 line -Codechange: Merge 'ground_sprite' and 'ground_pal' of DrawTileSprites into one PalSpriteID ------------------------------------------------------------------------ r12148 | frosch | 2008-02-15 18:34:26 +0000 (Fri, 15 Feb 2008) | 1 line -Codechange: Merge 'image' and 'pal' of DrawTileSeqStruct into one PalSpriteID ------------------------------------------------------------------------ r12147 | frosch | 2008-02-15 18:21:04 +0000 (Fri, 15 Feb 2008) | 1 line -Codechange: Use macros to build DrawTileSprites-tables in station_land and unmovable_land. ------------------------------------------------------------------------ r12146 | frosch | 2008-02-15 18:00:30 +0000 (Fri, 15 Feb 2008) | 1 line -Codechange: Use macros to build DrawTileSeqStruct-tables in station_land and unmovable_land. ------------------------------------------------------------------------ r12145 | belugas | 2008-02-15 17:38:18 +0000 (Fri, 15 Feb 2008) | 2 lines -Codechange: includes should be at the top of the source file -Codechange: undefine a defined macro once work is finished, just in case ------------------------------------------------------------------------ r12144 | peter1138 | 2008-02-15 13:28:13 +0000 (Fri, 15 Feb 2008) | 5 lines -Codechange: Adjust aircraft slowing algorithm so that very fast aircraft slow down more rapidly than slower aircraft. This prevents them from reaching the end of the runway at high speed, and also stops slow aircraft from slowing down too much at the start of the runway. ------------------------------------------------------------------------ r12143 | peter1138 | 2008-02-15 11:02:50 +0000 (Fri, 15 Feb 2008) | 2 lines -Fix (r8038): Engine::preview_player does not contain a Player ID. Rename this to preview_player_rank and change back to a uint8 to avoid confusion. ------------------------------------------------------------------------ r12142 | frosch | 2008-02-15 10:52:10 +0000 (Fri, 15 Feb 2008) | 1 line -Fix [FS#1766]: Callback 0x3D always gets a cargobit in var 0x18, independent of grf version. ------------------------------------------------------------------------ r12141 | frosch | 2008-02-14 15:59:16 +0000 (Thu, 14 Feb 2008) | 1 line -Codechange: Introduce IsNormalRoad[Tile](), IsRoadDepot[Tile]() and HasTileRoadType(); and use them. ------------------------------------------------------------------------ r12140 | belugas | 2008-02-14 15:13:36 +0000 (Thu, 14 Feb 2008) | 1 line -Codechange: A bit of code style fixes(Geektoo). ------------------------------------------------------------------------ r12139 | peter1138 | 2008-02-14 11:58:36 +0000 (Thu, 14 Feb 2008) | 2 lines -Fix (r12124): The global variable value should be returned, not the variable. ------------------------------------------------------------------------ r12138 | smatz | 2008-02-14 10:19:16 +0000 (Thu, 14 Feb 2008) | 1 line -Fix: do not allow adding tram to rail-road crossing when there is a vehicle on it ------------------------------------------------------------------------ r12137 | peter1138 | 2008-02-14 07:25:24 +0000 (Thu, 14 Feb 2008) | 2 lines -Fix [FS#1769]: Show cargo capacity for articulated vehicles correctly in the purchase list. Multiple cargo types can also now been shown. ------------------------------------------------------------------------ r12136 | belugas | 2008-02-14 03:10:22 +0000 (Thu, 14 Feb 2008) | 1 line -Fix(r12135): Code style compliance and... code style as such ------------------------------------------------------------------------ r12135 | belugas | 2008-02-14 02:57:38 +0000 (Thu, 14 Feb 2008) | 2 lines -Codechange: Road and rail bridge selection windows were identical apart the caption. So remove one window definition and set manually the caption accordingly. -Codechange: prepare the "type" of bridge parameter only once, at the beginning of the selection process. Makes less magic around. ------------------------------------------------------------------------ r12134 | smatz | 2008-02-13 19:24:40 +0000 (Wed, 13 Feb 2008) | 2 lines -Change: count the number of ticks a vehicle was running this day to calculate running cost -Fix [FS#1739]: vehicle profit is now counted with 8bit fract, so it is now shown properly in the vehicle details window ------------------------------------------------------------------------ r12133 | peter1138 | 2008-02-13 18:11:19 +0000 (Wed, 13 Feb 2008) | 2 lines -Fix: Vehicle sorting by max speed did not work properly for trains. Instead of trying to work it out again, just use the cached values... ------------------------------------------------------------------------ r12132 | smatz | 2008-02-13 17:54:11 +0000 (Wed, 13 Feb 2008) | 1 line -Cleanup: convert pathfinder selection from if/else to switch/case at many places ------------------------------------------------------------------------ r12131 | smatz | 2008-02-13 16:49:25 +0000 (Wed, 13 Feb 2008) | 1 line -Fix (r3374): with mammoth trains disabled, maximum train length was limited to 9 ------------------------------------------------------------------------ r12130 | smatz | 2008-02-13 14:31:13 +0000 (Wed, 13 Feb 2008) | 1 line -Cleanup (r12129): remove now unused strings from all language files ------------------------------------------------------------------------ r12129 | smatz | 2008-02-13 14:21:36 +0000 (Wed, 13 Feb 2008) | 1 line -Change [FS#1759]: simplified patch settings for pathfinders (Yorick) ------------------------------------------------------------------------ r12128 | peter1138 | 2008-02-13 09:34:56 +0000 (Wed, 13 Feb 2008) | 2 lines -Codechange: Replace last use of TrainPlayLeaveStationSound(v) with v->PlayLeaveStationSound(), and remove wrapper function. ------------------------------------------------------------------------ r12127 | belugas | 2008-02-13 03:21:19 +0000 (Wed, 13 Feb 2008) | 1 line -Codechange: Use a variable instead of calling the same function a few times. Again. Just a different value. ------------------------------------------------------------------------ r12126 | belugas | 2008-02-13 03:02:02 +0000 (Wed, 13 Feb 2008) | 1 line -Codechange: Use a variable instead of calling the same function a few times ------------------------------------------------------------------------ r12125 | peter1138 | 2008-02-12 20:14:14 +0000 (Tue, 12 Feb 2008) | 2 lines -Codechange: Remove redundant signal lookup table, and document why normal electric signals are handled specially. ------------------------------------------------------------------------ r12124 | frosch | 2008-02-12 15:43:10 +0000 (Tue, 12 Feb 2008) | 2 lines -Codechange: Move newgrf-variables that are common to VarAction2 and Action7/9/D to their own function. -Fix: Add some variables that were missing in one or both cases. ------------------------------------------------------------------------ r12123 | glx | 2008-02-12 14:20:55 +0000 (Tue, 12 Feb 2008) | 1 line -Add: generate.vbs script to allow project files generation for users unable to run generate bash script ------------------------------------------------------------------------ r12122 | peter1138 | 2008-02-12 13:23:57 +0000 (Tue, 12 Feb 2008) | 2 lines -Codechange: Add framework for generic feature callbacks, along with some parts for AI use. ------------------------------------------------------------------------ r12121 | peter1138 | 2008-02-12 12:54:51 +0000 (Tue, 12 Feb 2008) | 2 lines -Fix [FS#1764]: Drop down item indexes are now an int instead of a byte (Yexo) ------------------------------------------------------------------------ r12120 | peter1138 | 2008-02-12 11:46:29 +0000 (Tue, 12 Feb 2008) | 2 lines -Cleanup: const-ify parameters when checking for same cargopacket source. ------------------------------------------------------------------------ r12119 | peter1138 | 2008-02-12 11:08:47 +0000 (Tue, 12 Feb 2008) | 2 lines -Codechange: Rename grfspec_feature to match code style, and expose in header for use elsewhere. ------------------------------------------------------------------------ r12118 | belugas | 2008-02-12 03:05:27 +0000 (Tue, 12 Feb 2008) | 1 line -Codechange: Put the two descriptions of bridges in an array instead of two single variables, following the transport type it represents ------------------------------------------------------------------------ r12117 | glx | 2008-02-12 02:39:22 +0000 (Tue, 12 Feb 2008) | 1 line -Fix (r12115): strgen compilation was broken ------------------------------------------------------------------------ r12116 | glx | 2008-02-11 21:01:43 +0000 (Mon, 11 Feb 2008) | 1 line -Fix (r12083): little typos in source.list ------------------------------------------------------------------------ r12115 | smatz | 2008-02-11 20:23:38 +0000 (Mon, 11 Feb 2008) | 1 line -Codechange: move malloc/realloc error messages to separate file to spare 4-8kB of binary size ------------------------------------------------------------------------ r12114 | peter1138 | 2008-02-11 19:10:33 +0000 (Mon, 11 Feb 2008) | 2 lines -Fix (r12111): missed one Bridge -> BridgeSpec ------------------------------------------------------------------------