------------------------------------------------------------------------ r3857 | tron | 2006-03-14 12:00:11 +0000 (Tue, 14 Mar 2006) | 3 lines Add and use GetBridgeRampDirection() Note: This slightly changes the behavior of GetAnyRoadBits() to only return a road piece for the start of the bridge ramp instead of a full ROAD_[XY] ------------------------------------------------------------------------ r3856 | tron | 2006-03-14 09:00:10 +0000 (Tue, 14 Mar 2006) | 1 line Distinct between bridge ramps and bridge middle parts ------------------------------------------------------------------------ r3854 | Darkvater | 2006-03-13 23:20:24 +0000 (Mon, 13 Mar 2006) | 1 line - Fix restart_game_date to default to zero and allow a value of 0 which got screwed up during the patch-rewrite. Thanks peter1138 ------------------------------------------------------------------------ r3853 | Darkvater | 2006-03-13 23:13:21 +0000 (Mon, 13 Mar 2006) | 1 line - Fix a change of SetDParam64 to SetDParam in r3713 that caused slightly vibrating text when pressing the cheat-button. Thanks to peter1138 for noticing. ------------------------------------------------------------------------ r3852 | Darkvater | 2006-03-13 23:10:02 +0000 (Mon, 13 Mar 2006) | 1 line - Revert r3733 which fixed the default value loading for char, but broke loading a set value. Added a better fix which needs a char value to be a string (eg enclosed in double-quotes) ------------------------------------------------------------------------ r3851 | tron | 2006-03-13 20:12:35 +0000 (Mon, 13 Mar 2006) | 1 line Rail depots only have an entrance at one side, therefore use UpdateSignalsOnSegment() instead of SetSignalsOnBothDir() ------------------------------------------------------------------------ r3849 | tron | 2006-03-13 15:38:52 +0000 (Mon, 13 Mar 2006) | 1 line Fix bug in r3846 ------------------------------------------------------------------------ r3846 | tron | 2006-03-13 12:55:20 +0000 (Mon, 13 Mar 2006) | 2 lines Add functions to set the type of stuff (clear, water, rail, road) under bridges ------------------------------------------------------------------------ r3838 | tron | 2006-03-13 07:12:49 +0000 (Mon, 13 Mar 2006) | 1 line Demystify building bridge middle parts a bit by removing some magic numbers and generic names ------------------------------------------------------------------------ r3837 | tron | 2006-03-12 20:59:56 +0000 (Sun, 12 Mar 2006) | 3 lines Partially unmagicfy restoring the tiles when deleting a bridge Existing bug: When restoring a road piece which belongs to a town the town index unconditionally gets set to 0 ------------------------------------------------------------------------ r3832 | tron | 2006-03-12 17:42:04 +0000 (Sun, 12 Mar 2006) | 1 line Replace some magic numbers by (Diag)Direction enums ------------------------------------------------------------------------ r3831 | tron | 2006-03-12 16:13:16 +0000 (Sun, 12 Mar 2006) | 1 line Add and use GetRailDepotDirection() ------------------------------------------------------------------------ r3830 | tron | 2006-03-12 15:04:03 +0000 (Sun, 12 Mar 2006) | 1 line Move IsTunnelTile() from tile.h to tunnel_map.h and add IsTunnel(), which just checks for a tunnel, but not the tile type as IsTunnelTile() does ------------------------------------------------------------------------ r3829 | tron | 2006-03-12 12:19:25 +0000 (Sun, 12 Mar 2006) | 1 line Reduce the use of _error_message by directly returning error codes instead of using this global variable ------------------------------------------------------------------------ r3827 | tron | 2006-03-12 10:15:36 +0000 (Sun, 12 Mar 2006) | 1 line Remove the global variable _error_message_2, it's only used as local variable ------------------------------------------------------------------------ r3823 | tron | 2006-03-12 08:47:18 +0000 (Sun, 12 Mar 2006) | 1 line Remove dead code: A value for 'image' gets calculated and overwritten just a few lines later without being used in between ------------------------------------------------------------------------ r3820 | tron | 2006-03-11 17:06:16 +0000 (Sat, 11 Mar 2006) | 1 line Be a bit more strict with types: use special types instead of generic byte and don't fill arbitrary data into inappropriate types ------------------------------------------------------------------------ r3816 | tron | 2006-03-11 09:10:46 +0000 (Sat, 11 Mar 2006) | 1 line Use existing accessors ------------------------------------------------------------------------ r3814 | tron | 2006-03-10 17:01:51 +0000 (Fri, 10 Mar 2006) | 1 line Remove another call to FindLandscapeHeight() ------------------------------------------------------------------------ r3813 | tron | 2006-03-10 12:57:42 +0000 (Fri, 10 Mar 2006) | 1 line Simplify strange control flow ------------------------------------------------------------------------ r3812 | tron | 2006-03-10 11:27:52 +0000 (Fri, 10 Mar 2006) | 1 line Remove a pointless goto ------------------------------------------------------------------------ r3811 | bjarni | 2006-03-10 10:01:56 +0000 (Fri, 10 Mar 2006) | 1 line -Fix: [autoreplace]: (FS#67) autoreplacing trains now keep their tile length instead of their pixel length ------------------------------------------------------------------------ r3809 | peter1138 | 2006-03-10 09:20:28 +0000 (Fri, 10 Mar 2006) | 2 lines - Add map accessor files to MS VS 2003 project file ------------------------------------------------------------------------ r3805 | peter1138 | 2006-03-09 20:37:51 +0000 (Thu, 09 Mar 2006) | 2 lines - [FS#62] Fix doxygen comments to refer to the correct parameter. (sulai) ------------------------------------------------------------------------ r3803 | tron | 2006-03-09 12:32:25 +0000 (Thu, 09 Mar 2006) | 1 line Change the second parameter of UpdateSignalsOnSegment() from Direction to DiagDirection as that's what it really operates on ------------------------------------------------------------------------ r3802 | matthijs | 2006-03-08 23:21:32 +0000 (Wed, 08 Mar 2006) | 2 lines * Add a dummy file in the scenario dir to make the makefile stop complaining on make install (temporary hack). ------------------------------------------------------------------------ r3801 | matthijs | 2006-03-08 23:12:38 +0000 (Wed, 08 Mar 2006) | 3 lines * Update debian packaging files to the ones used for releasing 0.4.5 (see os/debian/changelog for details). * Fix a small debconf issue which was in the 0.4.5 release. ------------------------------------------------------------------------ r3798 | tron | 2006-03-08 20:25:28 +0000 (Wed, 08 Mar 2006) | 1 line Fix typo in r3795 ------------------------------------------------------------------------ r3796 | tron | 2006-03-08 19:47:18 +0000 (Wed, 08 Mar 2006) | 1 line When unmagicfying code, do it Right(tm) and also give the variables sensible names. I flipped a 'b' and a 'd' in r3785 ------------------------------------------------------------------------ r3795 | tron | 2006-03-08 15:29:23 +0000 (Wed, 08 Mar 2006) | 1 line Add a function to request the orientation of a depot ------------------------------------------------------------------------ r3794 | tron | 2006-03-08 15:28:38 +0000 (Wed, 08 Mar 2006) | 1 line Use already available accessor functions instead of GB() ------------------------------------------------------------------------ r3792 | tron | 2006-03-08 13:03:29 +0000 (Wed, 08 Mar 2006) | 1 line -Fix: Mark the right tile as dirty. It's just a graphical glitch which happend in r1592 ------------------------------------------------------------------------ r3791 | tron | 2006-03-08 12:26:56 +0000 (Wed, 08 Mar 2006) | 1 line Replace home grown direction handling for placing lighthouses by standard DiagDir ------------------------------------------------------------------------ r3789 | tron | 2006-03-08 08:51:26 +0000 (Wed, 08 Mar 2006) | 1 line Add an enum and function to handle DiagDirection changes ------------------------------------------------------------------------ r3788 | tron | 2006-03-08 08:36:00 +0000 (Wed, 08 Mar 2006) | 1 line Fix (harmless) typo in r3784 ------------------------------------------------------------------------ r3787 | tron | 2006-03-08 08:28:48 +0000 (Wed, 08 Mar 2006) | 1 line Use DirToDiagDir() instead of >> 1 ------------------------------------------------------------------------ r3786 | tron | 2006-03-08 08:16:31 +0000 (Wed, 08 Mar 2006) | 1 line More work for DirDiff ------------------------------------------------------------------------ r3785 | tron | 2006-03-08 07:50:26 +0000 (Wed, 08 Mar 2006) | 1 line Replace some if-magic to determine the turning direction for road vehicles with the new DirDiff stuff ------------------------------------------------------------------------ r3784 | tron | 2006-03-08 07:48:56 +0000 (Wed, 08 Mar 2006) | 2 lines Add a type and functions to handle direction changes ------------------------------------------------------------------------ r3783 | tron | 2006-03-08 06:55:33 +0000 (Wed, 08 Mar 2006) | 1 line Replace further ints and magic numbers by Direction, DiagDirection and friends ------------------------------------------------------------------------