------------------------------------------------------------------------ r3820 | tron | 2006-03-11 17:06:16 +0000 (Sat, 11 Mar 2006) | 1 line Be a bit more strict with types: use special types instead of generic byte and don't fill arbitrary data into inappropriate types ------------------------------------------------------------------------ r3816 | tron | 2006-03-11 09:10:46 +0000 (Sat, 11 Mar 2006) | 1 line Use existing accessors ------------------------------------------------------------------------ r3814 | tron | 2006-03-10 17:01:51 +0000 (Fri, 10 Mar 2006) | 1 line Remove another call to FindLandscapeHeight() ------------------------------------------------------------------------ r3813 | tron | 2006-03-10 12:57:42 +0000 (Fri, 10 Mar 2006) | 1 line Simplify strange control flow ------------------------------------------------------------------------ r3812 | tron | 2006-03-10 11:27:52 +0000 (Fri, 10 Mar 2006) | 1 line Remove a pointless goto ------------------------------------------------------------------------ r3811 | bjarni | 2006-03-10 10:01:56 +0000 (Fri, 10 Mar 2006) | 1 line -Fix: [autoreplace]: (FS#67) autoreplacing trains now keep their tile length instead of their pixel length ------------------------------------------------------------------------ r3809 | peter1138 | 2006-03-10 09:20:28 +0000 (Fri, 10 Mar 2006) | 2 lines - Add map accessor files to MS VS 2003 project file ------------------------------------------------------------------------ r3805 | peter1138 | 2006-03-09 20:37:51 +0000 (Thu, 09 Mar 2006) | 2 lines - [FS#62] Fix doxygen comments to refer to the correct parameter. (sulai) ------------------------------------------------------------------------ r3803 | tron | 2006-03-09 12:32:25 +0000 (Thu, 09 Mar 2006) | 1 line Change the second parameter of UpdateSignalsOnSegment() from Direction to DiagDirection as that's what it really operates on ------------------------------------------------------------------------ r3802 | matthijs | 2006-03-08 23:21:32 +0000 (Wed, 08 Mar 2006) | 2 lines * Add a dummy file in the scenario dir to make the makefile stop complaining on make install (temporary hack). ------------------------------------------------------------------------ r3801 | matthijs | 2006-03-08 23:12:38 +0000 (Wed, 08 Mar 2006) | 3 lines * Update debian packaging files to the ones used for releasing 0.4.5 (see os/debian/changelog for details). * Fix a small debconf issue which was in the 0.4.5 release. ------------------------------------------------------------------------ r3798 | tron | 2006-03-08 20:25:28 +0000 (Wed, 08 Mar 2006) | 1 line Fix typo in r3795 ------------------------------------------------------------------------ r3796 | tron | 2006-03-08 19:47:18 +0000 (Wed, 08 Mar 2006) | 1 line When unmagicfying code, do it Right(tm) and also give the variables sensible names. I flipped a 'b' and a 'd' in r3785 ------------------------------------------------------------------------ r3795 | tron | 2006-03-08 15:29:23 +0000 (Wed, 08 Mar 2006) | 1 line Add a function to request the orientation of a depot ------------------------------------------------------------------------ r3794 | tron | 2006-03-08 15:28:38 +0000 (Wed, 08 Mar 2006) | 1 line Use already available accessor functions instead of GB() ------------------------------------------------------------------------ r3792 | tron | 2006-03-08 13:03:29 +0000 (Wed, 08 Mar 2006) | 1 line -Fix: Mark the right tile as dirty. It's just a graphical glitch which happend in r1592 ------------------------------------------------------------------------ r3791 | tron | 2006-03-08 12:26:56 +0000 (Wed, 08 Mar 2006) | 1 line Replace home grown direction handling for placing lighthouses by standard DiagDir ------------------------------------------------------------------------ r3789 | tron | 2006-03-08 08:51:26 +0000 (Wed, 08 Mar 2006) | 1 line Add an enum and function to handle DiagDirection changes ------------------------------------------------------------------------ r3788 | tron | 2006-03-08 08:36:00 +0000 (Wed, 08 Mar 2006) | 1 line Fix (harmless) typo in r3784 ------------------------------------------------------------------------ r3787 | tron | 2006-03-08 08:28:48 +0000 (Wed, 08 Mar 2006) | 1 line Use DirToDiagDir() instead of >> 1 ------------------------------------------------------------------------ r3786 | tron | 2006-03-08 08:16:31 +0000 (Wed, 08 Mar 2006) | 1 line More work for DirDiff ------------------------------------------------------------------------ r3785 | tron | 2006-03-08 07:50:26 +0000 (Wed, 08 Mar 2006) | 1 line Replace some if-magic to determine the turning direction for road vehicles with the new DirDiff stuff ------------------------------------------------------------------------ r3784 | tron | 2006-03-08 07:48:56 +0000 (Wed, 08 Mar 2006) | 2 lines Add a type and functions to handle direction changes ------------------------------------------------------------------------ r3783 | tron | 2006-03-08 06:55:33 +0000 (Wed, 08 Mar 2006) | 1 line Replace further ints and magic numbers by Direction, DiagDirection and friends ------------------------------------------------------------------------ r3779 | tron | 2006-03-07 07:51:05 +0000 (Tue, 07 Mar 2006) | 1 line Move CheckTunnelInWay() to a more appropriate place, invert its result and give it a less ambiguous name (IsTunnelInWay) ------------------------------------------------------------------------ r3778 | peter1138 | 2006-03-06 23:01:35 +0000 (Mon, 06 Mar 2006) | 1 line - Fix crash when resizing news history window. ------------------------------------------------------------------------ r3777 | tron | 2006-03-06 20:55:24 +0000 (Mon, 06 Mar 2006) | 1 line Add some functions to handle tunnels ------------------------------------------------------------------------ r3776 | tron | 2006-03-06 20:28:28 +0000 (Mon, 06 Mar 2006) | 2 lines Replace many ints and magic numbers by Direction, DiagDirection and friends ------------------------------------------------------------------------ r3775 | peter1138 | 2006-03-06 19:23:26 +0000 (Mon, 06 Mar 2006) | 2 lines Fix loading of server_port from config file, introduced in Darkvater's unified configuration changes (r3719+) ------------------------------------------------------------------------ r3774 | tron | 2006-03-06 13:29:27 +0000 (Mon, 06 Mar 2006) | 1 line Remove some more magic numbers and types ------------------------------------------------------------------------ r3773 | tron | 2006-03-06 13:11:08 +0000 (Mon, 06 Mar 2006) | 2 lines Shove some semantics down ottd's throat by replacing ints and magic numbers by enums and some related changes ------------------------------------------------------------------------ r3770 | tron | 2006-03-05 17:24:04 +0000 (Sun, 05 Mar 2006) | 1 line Remove the _road_special_gettrackstatus hack. Egladil and me deem it unnecessary ------------------------------------------------------------------------ r3769 | tron | 2006-03-05 12:54:22 +0000 (Sun, 05 Mar 2006) | 1 line Add a cast to make KUDr's C++ compiler happy ------------------------------------------------------------------------ r3767 | tron | 2006-03-05 12:34:55 +0000 (Sun, 05 Mar 2006) | 1 line Move all direction related enums and functions to a separate header ------------------------------------------------------------------------ r3766 | tron | 2006-03-05 12:22:20 +0000 (Sun, 05 Mar 2006) | 1 line Add a function to get the RoadBits from an arbitrary tile ------------------------------------------------------------------------ r3765 | tron | 2006-03-05 11:18:34 +0000 (Sun, 05 Mar 2006) | 1 line Fix some naming glitches in r3763 and add missing svn properties ------------------------------------------------------------------------ r3763 | tron | 2006-03-05 10:19:33 +0000 (Sun, 05 Mar 2006) | 1 line Adapt to the new 'map accessors go in foo_map.h'-scheme ------------------------------------------------------------------------