------------------------------------------------------------------------ r3803 | tron | 2006-03-09 12:32:25 +0000 (Thu, 09 Mar 2006) | 1 line Change the second parameter of UpdateSignalsOnSegment() from Direction to DiagDirection as that's what it really operates on ------------------------------------------------------------------------ r3802 | matthijs | 2006-03-08 23:21:32 +0000 (Wed, 08 Mar 2006) | 2 lines * Add a dummy file in the scenario dir to make the makefile stop complaining on make install (temporary hack). ------------------------------------------------------------------------ r3801 | matthijs | 2006-03-08 23:12:38 +0000 (Wed, 08 Mar 2006) | 3 lines * Update debian packaging files to the ones used for releasing 0.4.5 (see os/debian/changelog for details). * Fix a small debconf issue which was in the 0.4.5 release. ------------------------------------------------------------------------ r3798 | tron | 2006-03-08 20:25:28 +0000 (Wed, 08 Mar 2006) | 1 line Fix typo in r3795 ------------------------------------------------------------------------ r3796 | tron | 2006-03-08 19:47:18 +0000 (Wed, 08 Mar 2006) | 1 line When unmagicfying code, do it Right(tm) and also give the variables sensible names. I flipped a 'b' and a 'd' in r3785 ------------------------------------------------------------------------ r3795 | tron | 2006-03-08 15:29:23 +0000 (Wed, 08 Mar 2006) | 1 line Add a function to request the orientation of a depot ------------------------------------------------------------------------ r3794 | tron | 2006-03-08 15:28:38 +0000 (Wed, 08 Mar 2006) | 1 line Use already available accessor functions instead of GB() ------------------------------------------------------------------------ r3792 | tron | 2006-03-08 13:03:29 +0000 (Wed, 08 Mar 2006) | 1 line -Fix: Mark the right tile as dirty. It's just a graphical glitch which happend in r1592 ------------------------------------------------------------------------ r3791 | tron | 2006-03-08 12:26:56 +0000 (Wed, 08 Mar 2006) | 1 line Replace home grown direction handling for placing lighthouses by standard DiagDir ------------------------------------------------------------------------ r3789 | tron | 2006-03-08 08:51:26 +0000 (Wed, 08 Mar 2006) | 1 line Add an enum and function to handle DiagDirection changes ------------------------------------------------------------------------ r3788 | tron | 2006-03-08 08:36:00 +0000 (Wed, 08 Mar 2006) | 1 line Fix (harmless) typo in r3784 ------------------------------------------------------------------------ r3787 | tron | 2006-03-08 08:28:48 +0000 (Wed, 08 Mar 2006) | 1 line Use DirToDiagDir() instead of >> 1 ------------------------------------------------------------------------ r3786 | tron | 2006-03-08 08:16:31 +0000 (Wed, 08 Mar 2006) | 1 line More work for DirDiff ------------------------------------------------------------------------ r3785 | tron | 2006-03-08 07:50:26 +0000 (Wed, 08 Mar 2006) | 1 line Replace some if-magic to determine the turning direction for road vehicles with the new DirDiff stuff ------------------------------------------------------------------------ r3784 | tron | 2006-03-08 07:48:56 +0000 (Wed, 08 Mar 2006) | 2 lines Add a type and functions to handle direction changes ------------------------------------------------------------------------ r3783 | tron | 2006-03-08 06:55:33 +0000 (Wed, 08 Mar 2006) | 1 line Replace further ints and magic numbers by Direction, DiagDirection and friends ------------------------------------------------------------------------ r3779 | tron | 2006-03-07 07:51:05 +0000 (Tue, 07 Mar 2006) | 1 line Move CheckTunnelInWay() to a more appropriate place, invert its result and give it a less ambiguous name (IsTunnelInWay) ------------------------------------------------------------------------ r3778 | peter1138 | 2006-03-06 23:01:35 +0000 (Mon, 06 Mar 2006) | 1 line - Fix crash when resizing news history window. ------------------------------------------------------------------------ r3777 | tron | 2006-03-06 20:55:24 +0000 (Mon, 06 Mar 2006) | 1 line Add some functions to handle tunnels ------------------------------------------------------------------------ r3776 | tron | 2006-03-06 20:28:28 +0000 (Mon, 06 Mar 2006) | 2 lines Replace many ints and magic numbers by Direction, DiagDirection and friends ------------------------------------------------------------------------ r3775 | peter1138 | 2006-03-06 19:23:26 +0000 (Mon, 06 Mar 2006) | 2 lines Fix loading of server_port from config file, introduced in Darkvater's unified configuration changes (r3719+) ------------------------------------------------------------------------ r3774 | tron | 2006-03-06 13:29:27 +0000 (Mon, 06 Mar 2006) | 1 line Remove some more magic numbers and types ------------------------------------------------------------------------ r3773 | tron | 2006-03-06 13:11:08 +0000 (Mon, 06 Mar 2006) | 2 lines Shove some semantics down ottd's throat by replacing ints and magic numbers by enums and some related changes ------------------------------------------------------------------------ r3770 | tron | 2006-03-05 17:24:04 +0000 (Sun, 05 Mar 2006) | 1 line Remove the _road_special_gettrackstatus hack. Egladil and me deem it unnecessary ------------------------------------------------------------------------ r3769 | tron | 2006-03-05 12:54:22 +0000 (Sun, 05 Mar 2006) | 1 line Add a cast to make KUDr's C++ compiler happy ------------------------------------------------------------------------ r3767 | tron | 2006-03-05 12:34:55 +0000 (Sun, 05 Mar 2006) | 1 line Move all direction related enums and functions to a separate header ------------------------------------------------------------------------ r3766 | tron | 2006-03-05 12:22:20 +0000 (Sun, 05 Mar 2006) | 1 line Add a function to get the RoadBits from an arbitrary tile ------------------------------------------------------------------------ r3765 | tron | 2006-03-05 11:18:34 +0000 (Sun, 05 Mar 2006) | 1 line Fix some naming glitches in r3763 and add missing svn properties ------------------------------------------------------------------------ r3763 | tron | 2006-03-05 10:19:33 +0000 (Sun, 05 Mar 2006) | 1 line Adapt to the new 'map accessors go in foo_map.h'-scheme ------------------------------------------------------------------------ r3761 | tron | 2006-03-04 17:18:13 +0000 (Sat, 04 Mar 2006) | 2 lines Fix two bugs in r3757 ------------------------------------------------------------------------ r3760 | tron | 2006-03-04 13:52:52 +0000 (Sat, 04 Mar 2006) | 1 line Replace some magic numbers for checking for a suitable slope for a level crossing by some less magic numbers. Quite similar to r3699, though this time for placing the rails ------------------------------------------------------------------------ r3759 | bjarni | 2006-03-04 12:09:10 +0000 (Sat, 04 Mar 2006) | 1 line -Fix: [OSX] don't set CC_HOST to i686 gcc when compiling universal binaries on PPC without any Makefile.config. Introduced in 3674 (before that i686 used PPC as CC_HOST, but nobody noticed that) ------------------------------------------------------------------------ r3758 | tron | 2006-03-04 11:15:44 +0000 (Sat, 04 Mar 2006) | 2 lines Remove the news validation callback. It is superseded by r3757. ------------------------------------------------------------------------ r3757 | tron | 2006-03-04 11:01:35 +0000 (Sat, 04 Mar 2006) | 6 lines -Feature: Delete news items about vehicles, when they get stale This is used to delete - all news about a vehicle, when it gets deleted - "vehicle has stopped in depot" news, when it gets started - "vehicle has invalid orders" news, when the orders get changed ------------------------------------------------------------------------ r3754 | tron | 2006-03-03 22:21:29 +0000 (Fri, 03 Mar 2006) | 1 line Miscellaneous changes: indentation, reduce variable scope, constness, avoid some more function pointer casts ------------------------------------------------------------------------ r3752 | tron | 2006-03-03 21:29:13 +0000 (Fri, 03 Mar 2006) | 1 line FYOS avoid to cast function pointers ------------------------------------------------------------------------ r3751 | tron | 2006-03-03 21:18:19 +0000 (Fri, 03 Mar 2006) | 1 line -Fix: Correctly implement minimum search, so road vehicles head twoards the closest station, not the last one in the list ------------------------------------------------------------------------ r3750 | tron | 2006-03-03 20:54:54 +0000 (Fri, 03 Mar 2006) | 1 line Use INVALID_STATION instead of -1 in NPF ------------------------------------------------------------------------ r3749 | tron | 2006-03-03 20:48:03 +0000 (Fri, 03 Mar 2006) | 1 line -Fix: [FS#61] The tooltips for raising and lowering land buttons in the scenario editor are interchanged (Reported and fixed by lc) ------------------------------------------------------------------------ r3748 | tron | 2006-03-03 20:43:54 +0000 (Fri, 03 Mar 2006) | 1 line Remove bubblesort(), it's unused ------------------------------------------------------------------------ r3747 | tron | 2006-03-03 19:42:09 +0000 (Fri, 03 Mar 2006) | 1 line Change HASBIT() to return 0/1 instead of 0/value of tested bit, because the name suggests it does the former and current behavior broke in some places in very subtle ways (for example HASBIT(x, 0) != HASBIT(y, 1) doesn't work, returning a bool after HASBIT(x, 9) neither) ------------------------------------------------------------------------ r3746 | Darkvater | 2006-03-03 11:27:18 +0000 (Fri, 03 Mar 2006) | 2 lines - [7/7] Moving the callback functions for the setting-changes from settings_gui.c to settings.c. Also enable the callback functionality through the console. - Fix a nasty bug with improper counter addition. (*i)++ and NOT *i++ when setting a patch value through the console. ------------------------------------------------------------------------ r3745 | tron | 2006-03-03 07:51:41 +0000 (Fri, 03 Mar 2006) | 2 lines Fix two buffer overflows, one case of undefined behavior (the destination buffer of sprintf() may not alias with one of its arguments) and some other minor stuff introduced in r3740 ------------------------------------------------------------------------ r3742 | bjarni | 2006-03-02 22:21:27 +0000 (Thu, 02 Mar 2006) | 1 line -codechange: [OSX] changed an assert to use the new error window and added another two to show if the screen buffer fails for some reason in cocoa driver (instead of just crashing) ------------------------------------------------------------------------ r3741 | bjarni | 2006-03-02 22:00:57 +0000 (Thu, 02 Mar 2006) | 3 lines -Fix: [i686 OSX] reverted the change in rev 3670 for non PowerPC (done with #ifdef) since it appeared to crash intel based macs This fix is not a good solution and might not work, but if it works, it's better than nothing until we get the real solution ------------------------------------------------------------------------ r3740 | bjarni | 2006-03-02 21:43:09 +0000 (Thu, 02 Mar 2006) | 4 lines -Feature: [OSX] added OS version, CPU type and newGRF settings to assert window and a message to tell people to add that to a bug report It also adds a new error window, which can be used just like assert, but it is also active when asserts are turned off This is useful for places where it's really important to check even if assert is turned off. It's not used in the code yet ------------------------------------------------------------------------ r3739 | bjarni | 2006-03-02 21:27:20 +0000 (Thu, 02 Mar 2006) | 2 lines -Fix: [Big endian CPUs] fixed bug introduced in rev 3720 where BE computers would read insane map sizes and crash as a result ------------------------------------------------------------------------