------------------------------------------------------------------------ r3606 | peter1138 | 2006-02-15 12:53:36 +0000 (Wed, 15 Feb 2006) | 2 lines - NewGRF: Convert from TTDP railtype values to our own railtypes. (These are currently the same, but won't be forever...) ------------------------------------------------------------------------ r3605 | peter1138 | 2006-02-14 09:31:05 +0000 (Tue, 14 Feb 2006) | 2 lines - Remove silly macro and fix indenting in DrawVehicleRefitWindow() ------------------------------------------------------------------------ r3604 | tron | 2006-02-14 07:32:45 +0000 (Tue, 14 Feb 2006) | 1 line Remove two unnecessary local variables ------------------------------------------------------------------------ r3603 | peter1138 | 2006-02-13 22:19:23 +0000 (Mon, 13 Feb 2006) | 1 line - NewGRF: Support loading of AI rank data ------------------------------------------------------------------------ r3602 | peter1138 | 2006-02-13 22:13:02 +0000 (Mon, 13 Feb 2006) | 1 line - Move _railveh_score data to _rail_vehicle_info->ai_rank and remove global variable to return data as we can now access this directly. ------------------------------------------------------------------------ r3601 | truelight | 2006-02-13 22:11:03 +0000 (Mon, 13 Feb 2006) | 2 lines -Codechange: special for Tron, and he was absolutely correct in thisone: added a comment for last commit ------------------------------------------------------------------------ r3600 | truelight | 2006-02-13 22:06:02 +0000 (Mon, 13 Feb 2006) | 1 line -Fix: suppress error on 64bit targets ------------------------------------------------------------------------ r3599 | truelight | 2006-02-13 21:56:49 +0000 (Mon, 13 Feb 2006) | 1 line -Fix: added some casts to suppress some more warnings ------------------------------------------------------------------------ r3598 | truelight | 2006-02-13 21:47:02 +0000 (Mon, 13 Feb 2006) | 2 lines -Fix: suppress invalid warning by assigning value to variable ------------------------------------------------------------------------ r3597 | tron | 2006-02-13 21:15:00 +0000 (Mon, 13 Feb 2006) | 1 line Miscellaneous (I like that word) changes: Fix some indentation, add consts, reduce indentation level by short-circuit logic, convert if cascades to switch, whitespace, bracing, plus some minor stuff ------------------------------------------------------------------------ r3596 | bjarni | 2006-02-12 14:31:33 +0000 (Sun, 12 Feb 2006) | 6 lines -Codechange: [OSX] changed to use Apple's macros instead of OTTD macros for endian conversion This increases the execution speed a lot since GCC can't detect the OTTD macro as an endian conversion while Apple's code uses the instruction to convert endian instead of a series of instructions to produce the same result Since we don't have that many endian conversions in the game, overall performance should not increase noteworthy ------------------------------------------------------------------------ r3595 | tron | 2006-02-12 10:44:52 +0000 (Sun, 12 Feb 2006) | 1 line Several small cleanups, the only notable are some additional symbolic names for a few ISO8859 characters ------------------------------------------------------------------------ r3594 | peter1138 | 2006-02-12 10:35:51 +0000 (Sun, 12 Feb 2006) | 1 line - NewGRF: Add support for some vehicle specific properties and a give a debug message for unknown variables. ------------------------------------------------------------------------ r3593 | peter1138 | 2006-02-11 21:41:49 +0000 (Sat, 11 Feb 2006) | 1 line Fix typo in r3591 ------------------------------------------------------------------------ r3592 | tron | 2006-02-11 15:05:56 +0000 (Sat, 11 Feb 2006) | 1 line Miscellaneous smaller changes, most notably replacing sizeof(type) by sizeof(*variable) ------------------------------------------------------------------------ r3591 | Darkvater | 2006-02-11 14:10:28 +0000 (Sat, 11 Feb 2006) | 1 line - Fix: validate the setting of max_companies/spectators through the console. ------------------------------------------------------------------------ r3590 | tron | 2006-02-11 11:43:06 +0000 (Sat, 11 Feb 2006) | 1 line Fix a bug where sizeof(struct) was allocated instead of sizeof(pointer to struct). This was non-fatal, because more memory than necessary got allocated ------------------------------------------------------------------------ r3589 | peter1138 | 2006-02-11 10:45:20 +0000 (Sat, 11 Feb 2006) | 1 line - Rename u.road.unk2 to u.road.blocked_ctr ------------------------------------------------------------------------ r3588 | peter1138 | 2006-02-11 09:24:51 +0000 (Sat, 11 Feb 2006) | 1 line - Refit: Use only one global to return the refit capacity rather than one per vehicle type. ------------------------------------------------------------------------ r3587 | peter1138 | 2006-02-11 09:17:16 +0000 (Sat, 11 Feb 2006) | 1 line - NewGRF: Rename Callback IDs to include their "class" ------------------------------------------------------------------------ r3586 | peter1138 | 2006-02-11 07:34:05 +0000 (Sat, 11 Feb 2006) | 1 line - NewGRF: Load callback masks for all vehicle types. ------------------------------------------------------------------------ r3585 | tron | 2006-02-10 06:33:56 +0000 (Fri, 10 Feb 2006) | 1 line Similar changes to the order handlers of the other vehicle types like r3584 ------------------------------------------------------------------------ r3584 | tron | 2006-02-10 06:03:51 +0000 (Fri, 10 Feb 2006) | 1 line Replace the rather obscure control flow for handling road vehicle orders by something remotly comprehensible ------------------------------------------------------------------------