------------------------------------------------------------------------ r3596 | bjarni | 2006-02-12 14:31:33 +0000 (Sun, 12 Feb 2006) | 6 lines -Codechange: [OSX] changed to use Apple's macros instead of OTTD macros for endian conversion This increases the execution speed a lot since GCC can't detect the OTTD macro as an endian conversion while Apple's code uses the instruction to convert endian instead of a series of instructions to produce the same result Since we don't have that many endian conversions in the game, overall performance should not increase noteworthy ------------------------------------------------------------------------ r3595 | tron | 2006-02-12 10:44:52 +0000 (Sun, 12 Feb 2006) | 1 line Several small cleanups, the only notable are some additional symbolic names for a few ISO8859 characters ------------------------------------------------------------------------ r3594 | peter1138 | 2006-02-12 10:35:51 +0000 (Sun, 12 Feb 2006) | 1 line - NewGRF: Add support for some vehicle specific properties and a give a debug message for unknown variables. ------------------------------------------------------------------------ r3593 | peter1138 | 2006-02-11 21:41:49 +0000 (Sat, 11 Feb 2006) | 1 line Fix typo in r3591 ------------------------------------------------------------------------ r3592 | tron | 2006-02-11 15:05:56 +0000 (Sat, 11 Feb 2006) | 1 line Miscellaneous smaller changes, most notably replacing sizeof(type) by sizeof(*variable) ------------------------------------------------------------------------ r3591 | Darkvater | 2006-02-11 14:10:28 +0000 (Sat, 11 Feb 2006) | 1 line - Fix: validate the setting of max_companies/spectators through the console. ------------------------------------------------------------------------ r3590 | tron | 2006-02-11 11:43:06 +0000 (Sat, 11 Feb 2006) | 1 line Fix a bug where sizeof(struct) was allocated instead of sizeof(pointer to struct). This was non-fatal, because more memory than necessary got allocated ------------------------------------------------------------------------ r3589 | peter1138 | 2006-02-11 10:45:20 +0000 (Sat, 11 Feb 2006) | 1 line - Rename u.road.unk2 to u.road.blocked_ctr ------------------------------------------------------------------------ r3588 | peter1138 | 2006-02-11 09:24:51 +0000 (Sat, 11 Feb 2006) | 1 line - Refit: Use only one global to return the refit capacity rather than one per vehicle type. ------------------------------------------------------------------------ r3587 | peter1138 | 2006-02-11 09:17:16 +0000 (Sat, 11 Feb 2006) | 1 line - NewGRF: Rename Callback IDs to include their "class" ------------------------------------------------------------------------ r3586 | peter1138 | 2006-02-11 07:34:05 +0000 (Sat, 11 Feb 2006) | 1 line - NewGRF: Load callback masks for all vehicle types. ------------------------------------------------------------------------ r3585 | tron | 2006-02-10 06:33:56 +0000 (Fri, 10 Feb 2006) | 1 line Similar changes to the order handlers of the other vehicle types like r3584 ------------------------------------------------------------------------ r3584 | tron | 2006-02-10 06:03:51 +0000 (Fri, 10 Feb 2006) | 1 line Replace the rather obscure control flow for handling road vehicle orders by something remotly comprehensible ------------------------------------------------------------------------ r3583 | tron | 2006-02-09 07:34:37 +0000 (Thu, 09 Feb 2006) | 1 line Fix 2 glitches in r3556 ------------------------------------------------------------------------ r3582 | tron | 2006-02-09 06:33:37 +0000 (Thu, 09 Feb 2006) | 1 line Restructure MoveGoodsToStation() to avoid double bookkeeping of StationIDs and station pointers ------------------------------------------------------------------------ r3581 | tron | 2006-02-09 06:24:53 +0000 (Thu, 09 Feb 2006) | 1 line Just noticed the indentation was totally off, fix it ------------------------------------------------------------------------ r3580 | tron | 2006-02-09 06:15:12 +0000 (Thu, 09 Feb 2006) | 1 line Some small cleanups before the real change, especially reduce the indentation by one by using continue ------------------------------------------------------------------------ r3579 | peter1138 | 2006-02-08 19:06:46 +0000 (Wed, 08 Feb 2006) | 2 lines v->u.rail.first_engine holds an engine type, not a vehicle index, so use INVALID_ENGINE. ------------------------------------------------------------------------ r3576 | peter1138 | 2006-02-08 08:18:29 +0000 (Wed, 08 Feb 2006) | 2 lines - Allow unused wagons have their ->first set. This fixes the faulty cache warning message, and noticably speeds up depot operations in large games. ------------------------------------------------------------------------ r3574 | Darkvater | 2006-02-07 19:34:22 +0000 (Tue, 07 Feb 2006) | 1 line - [Merge] [GPMI] -Fix: finally OTTD doesn't compile if you do a 'make mrproper' (TrueLight) ------------------------------------------------------------------------ r3573 | peter1138 | 2006-02-07 19:11:51 +0000 (Tue, 07 Feb 2006) | 2 lines - Replace assert(0) with NOT_REACHED(). This commit sponsored by "giving Darkvater credit for the last three". ------------------------------------------------------------------------ r3572 | peter1138 | 2006-02-07 19:01:01 +0000 (Tue, 07 Feb 2006) | 2 lines - Rewrite GetFreeUnitNumber() so that only one loop of vehicles is required. Instead a list of used/unused numbers is created and the first unused number is chosen. This significantly improves performance in large games. ------------------------------------------------------------------------ r3571 | peter1138 | 2006-02-07 18:57:16 +0000 (Tue, 07 Feb 2006) | 2 lines - When loading a game, call TrainConsistChanged() for each train head separately before updating images, as v->first is used extensively in GetTrainImage() for custom graphics. This gives a significant speed improvement on loading a game. ------------------------------------------------------------------------ r3570 | peter1138 | 2006-02-07 18:55:06 +0000 (Tue, 07 Feb 2006) | 2 lines - Explicitly update v->first in TrainConsistChanged() if necessary, as this is far faster than brute forcing it later. ------------------------------------------------------------------------ r3568 | Darkvater | 2006-02-06 23:28:07 +0000 (Mon, 06 Feb 2006) | 1 line - Fix: constantizing side-effect of qsort in r3563. Ugly? Yes. Makes MSVC happy? Yes. ------------------------------------------------------------------------ r3567 | truelight | 2006-02-06 22:30:43 +0000 (Mon, 06 Feb 2006) | 4 lines -Fix: for once and for all, use 'unsigned long' if you want to cast something from int-like to void *... we fixed that not too long ago, and the code below this changed line clearly tells you do to that :p ------------------------------------------------------------------------