------------------------------------------------------------------------ r3592 | tron | 2006-02-11 15:05:56 +0000 (Sat, 11 Feb 2006) | 1 line Miscellaneous smaller changes, most notably replacing sizeof(type) by sizeof(*variable) ------------------------------------------------------------------------ r3591 | Darkvater | 2006-02-11 14:10:28 +0000 (Sat, 11 Feb 2006) | 1 line - Fix: validate the setting of max_companies/spectators through the console. ------------------------------------------------------------------------ r3590 | tron | 2006-02-11 11:43:06 +0000 (Sat, 11 Feb 2006) | 1 line Fix a bug where sizeof(struct) was allocated instead of sizeof(pointer to struct). This was non-fatal, because more memory than necessary got allocated ------------------------------------------------------------------------ r3589 | peter1138 | 2006-02-11 10:45:20 +0000 (Sat, 11 Feb 2006) | 1 line - Rename u.road.unk2 to u.road.blocked_ctr ------------------------------------------------------------------------ r3588 | peter1138 | 2006-02-11 09:24:51 +0000 (Sat, 11 Feb 2006) | 1 line - Refit: Use only one global to return the refit capacity rather than one per vehicle type. ------------------------------------------------------------------------ r3587 | peter1138 | 2006-02-11 09:17:16 +0000 (Sat, 11 Feb 2006) | 1 line - NewGRF: Rename Callback IDs to include their "class" ------------------------------------------------------------------------ r3586 | peter1138 | 2006-02-11 07:34:05 +0000 (Sat, 11 Feb 2006) | 1 line - NewGRF: Load callback masks for all vehicle types. ------------------------------------------------------------------------ r3585 | tron | 2006-02-10 06:33:56 +0000 (Fri, 10 Feb 2006) | 1 line Similar changes to the order handlers of the other vehicle types like r3584 ------------------------------------------------------------------------ r3584 | tron | 2006-02-10 06:03:51 +0000 (Fri, 10 Feb 2006) | 1 line Replace the rather obscure control flow for handling road vehicle orders by something remotly comprehensible ------------------------------------------------------------------------ r3583 | tron | 2006-02-09 07:34:37 +0000 (Thu, 09 Feb 2006) | 1 line Fix 2 glitches in r3556 ------------------------------------------------------------------------ r3582 | tron | 2006-02-09 06:33:37 +0000 (Thu, 09 Feb 2006) | 1 line Restructure MoveGoodsToStation() to avoid double bookkeeping of StationIDs and station pointers ------------------------------------------------------------------------ r3581 | tron | 2006-02-09 06:24:53 +0000 (Thu, 09 Feb 2006) | 1 line Just noticed the indentation was totally off, fix it ------------------------------------------------------------------------ r3580 | tron | 2006-02-09 06:15:12 +0000 (Thu, 09 Feb 2006) | 1 line Some small cleanups before the real change, especially reduce the indentation by one by using continue ------------------------------------------------------------------------ r3579 | peter1138 | 2006-02-08 19:06:46 +0000 (Wed, 08 Feb 2006) | 2 lines v->u.rail.first_engine holds an engine type, not a vehicle index, so use INVALID_ENGINE. ------------------------------------------------------------------------ r3576 | peter1138 | 2006-02-08 08:18:29 +0000 (Wed, 08 Feb 2006) | 2 lines - Allow unused wagons have their ->first set. This fixes the faulty cache warning message, and noticably speeds up depot operations in large games. ------------------------------------------------------------------------ r3574 | Darkvater | 2006-02-07 19:34:22 +0000 (Tue, 07 Feb 2006) | 1 line - [Merge] [GPMI] -Fix: finally OTTD doesn't compile if you do a 'make mrproper' (TrueLight) ------------------------------------------------------------------------ r3573 | peter1138 | 2006-02-07 19:11:51 +0000 (Tue, 07 Feb 2006) | 2 lines - Replace assert(0) with NOT_REACHED(). This commit sponsored by "giving Darkvater credit for the last three". ------------------------------------------------------------------------ r3572 | peter1138 | 2006-02-07 19:01:01 +0000 (Tue, 07 Feb 2006) | 2 lines - Rewrite GetFreeUnitNumber() so that only one loop of vehicles is required. Instead a list of used/unused numbers is created and the first unused number is chosen. This significantly improves performance in large games. ------------------------------------------------------------------------ r3571 | peter1138 | 2006-02-07 18:57:16 +0000 (Tue, 07 Feb 2006) | 2 lines - When loading a game, call TrainConsistChanged() for each train head separately before updating images, as v->first is used extensively in GetTrainImage() for custom graphics. This gives a significant speed improvement on loading a game. ------------------------------------------------------------------------ r3570 | peter1138 | 2006-02-07 18:55:06 +0000 (Tue, 07 Feb 2006) | 2 lines - Explicitly update v->first in TrainConsistChanged() if necessary, as this is far faster than brute forcing it later. ------------------------------------------------------------------------ r3568 | Darkvater | 2006-02-06 23:28:07 +0000 (Mon, 06 Feb 2006) | 1 line - Fix: constantizing side-effect of qsort in r3563. Ugly? Yes. Makes MSVC happy? Yes. ------------------------------------------------------------------------ r3567 | truelight | 2006-02-06 22:30:43 +0000 (Mon, 06 Feb 2006) | 4 lines -Fix: for once and for all, use 'unsigned long' if you want to cast something from int-like to void *... we fixed that not too long ago, and the code below this changed line clearly tells you do to that :p ------------------------------------------------------------------------ r3565 | peter1138 | 2006-02-06 10:05:41 +0000 (Mon, 06 Feb 2006) | 2 lines - Fix: On loading a game, GetPlayerRailtypes() didn't account for the fact that vehicles are introduced a year after their introduction date. This will also relieve possible (rare) network desyncs. ------------------------------------------------------------------------ r3564 | tron | 2006-02-06 09:18:04 +0000 (Mon, 06 Feb 2006) | 9 lines Several smaller changes: - Don't treat non-booleans as booleans - Reduce variable scope - Bracing - Use DeMorgan's law to make conditionals easier to read - if cascade -> switch - Replace some magic numbers by symbolic names - Avoid assignments within other statements ------------------------------------------------------------------------ r3563 | tron | 2006-02-06 08:43:05 +0000 (Mon, 06 Feb 2006) | 1 line Simplify the code for calculating the highscore table in network games and saving of old ecenomy data ------------------------------------------------------------------------ r3562 | tron | 2006-02-06 08:28:31 +0000 (Mon, 06 Feb 2006) | 1 line Remove pointless buffer copies ------------------------------------------------------------------------ r3561 | tron | 2006-02-06 08:15:30 +0000 (Mon, 06 Feb 2006) | 1 line Don't use FindLandscapeHeightByTile() when it's overkill. Also use a sprite enum instead of a magic number. ------------------------------------------------------------------------ r3560 | tron | 2006-02-06 07:38:05 +0000 (Mon, 06 Feb 2006) | 4 lines Restore plural forms of cargo types for several languages. I extracted the info from 2614:2615. If you speak one of the languages, please check if the changes are correct. ------------------------------------------------------------------------ r3559 | Darkvater | 2006-02-05 23:12:23 +0000 (Sun, 05 Feb 2006) | 1 line - CodeChange: simplify MKCOLOR(x) macro for smallmap_gui.c by adding a TO_LE32X() macro next to TO_BE32X(). The 'X' signifies them as macros and not-inline functions so they can be used in variable declarations. ------------------------------------------------------------------------ r3558 | peter1138 | 2006-02-05 20:36:36 +0000 (Sun, 05 Feb 2006) | 2 lines Add newgrf_callbacks.h to VS project files ------------------------------------------------------------------------ r3557 | peter1138 | 2006-02-05 19:46:20 +0000 (Sun, 05 Feb 2006) | 2 lines - NewGRF: move callback enums to a new file as more than just engines will use them ------------------------------------------------------------------------ r3556 | tron | 2006-02-05 14:47:15 +0000 (Sun, 05 Feb 2006) | 3 lines Add accessors for handling tree tiles See tree.h for details ------------------------------------------------------------------------ r3555 | bjarni | 2006-02-05 14:18:28 +0000 (Sun, 05 Feb 2006) | 7 lines -Codechange: [Big Endian] removed defining OTTD_ALIGNMENT by default on Big Endian CPUs this increased speed when reading unaligned data (like strings) test showed this to increase speed by 5,6% when drawing the mini map on PPC OSX the tradeoff is that now it will crash if a Big Endian computer don't support unaligned reading but it should easily fixable in stdafx.h if it turns out to be a problem ------------------------------------------------------------------------ r3554 | tron | 2006-02-05 11:54:25 +0000 (Sun, 05 Feb 2006) | 1 line Add accessors for the field type and fences of clear tiles ------------------------------------------------------------------------ r3553 | Darkvater | 2006-02-05 11:10:31 +0000 (Sun, 05 Feb 2006) | 1 line - Revert r3549 "Change the behaviour of OTTD_ALIGNMENT". Some tests showed that forcing aligned reads slowed down the code (drawing smallmap) by 14%. Change back to the old behaviour. ------------------------------------------------------------------------ r3552 | tron | 2006-02-05 09:56:04 +0000 (Sun, 05 Feb 2006) | 1 line Remove the global variable _mixer ------------------------------------------------------------------------ r3551 | peter1138 | 2006-02-05 09:28:06 +0000 (Sun, 05 Feb 2006) | 2 lines Add directives to allow Visual Studio 2005 compilation. ------------------------------------------------------------------------ r3550 | Darkvater | 2006-02-04 23:09:33 +0000 (Sat, 04 Feb 2006) | 1 line - [Patches]: fix GCC warning, sorry ------------------------------------------------------------------------ r3549 | Darkvater | 2006-02-04 23:03:35 +0000 (Sat, 04 Feb 2006) | 1 line - Change the behaviour of OTTD_ALIGNMENT. Force aligned reading as default, undefine it if unwanted/unneeded for some reason. I undeffed windows and watcom for now as they were like this. ------------------------------------------------------------------------ r3548 | Darkvater | 2006-02-04 22:52:30 +0000 (Sat, 04 Feb 2006) | 1 line - [Patches]: rework two loops in make_oneofmany() and make_manyofmany() ------------------------------------------------------------------------ r3547 | Darkvater | 2006-02-04 22:48:57 +0000 (Sat, 04 Feb 2006) | 1 line - [Patches]: do some general cleanup, commentarization before starting actual work. This patch contains no functional changes (I hope). It might break GPMI-builds though when trying to join a trunk/ network game or vice versa. To solve, you can change the order of the first 8 enums in SettingDescType. I think that'll work. ------------------------------------------------------------------------ r3546 | peter1138 | 2006-02-04 21:48:46 +0000 (Sat, 04 Feb 2006) | 1 line - NewGRF feature: Implement rail vehicle 'property' 0x1A: allows shuffling order of rail vehicle purchase list (and replace vehicle list) ------------------------------------------------------------------------