------------------------------------------------------------------------ r3211 | tron | 2005-11-16 16:16:18 +0000 (Wed, 16 Nov 2005) | 1 line Fix typo in r3181 ------------------------------------------------------------------------ r3210 | truelight | 2005-11-16 14:41:01 +0000 (Wed, 16 Nov 2005) | 3 lines -Codechange: use IsRailWaypoint where possible (instead of magicnumbers) -Codechange: IsRailWaypoint should take 'tile', not 'm5' ------------------------------------------------------------------------ r3209 | peter1138 | 2005-11-16 14:30:24 +0000 (Wed, 16 Nov 2005) | 2 lines In TileLoop_Track(), use names based on function rather than their place in the map array. ------------------------------------------------------------------------ r3208 | tron | 2005-11-16 14:07:34 +0000 (Wed, 16 Nov 2005) | 1 line Don't explicitly pass the engine type to look for to GetRearEngine(), because it's the engine type of the vehicle which gets passed as first parameter ------------------------------------------------------------------------ r3207 | tron | 2005-11-16 13:45:42 +0000 (Wed, 16 Nov 2005) | 1 line Typo in last revision ------------------------------------------------------------------------ r3206 | tron | 2005-11-16 13:45:04 +0000 (Wed, 16 Nov 2005) | 1 line Wrap all instances of _dbg_screen_rect in #ifdef _DEBUG ------------------------------------------------------------------------ r3205 | tron | 2005-11-16 13:11:28 +0000 (Wed, 16 Nov 2005) | 1 line Some more uses for GB/SB ------------------------------------------------------------------------ r3204 | tron | 2005-11-16 12:52:01 +0000 (Wed, 16 Nov 2005) | 1 line Make handling of clicking on vehicles a bit less ugly by avoiding function declarations in .c files and unnecessary indirection ------------------------------------------------------------------------ r3203 | tron | 2005-11-16 12:37:22 +0000 (Wed, 16 Nov 2005) | 1 line Directly use the currency symbols for pounds and yen in the language files like it's already done for dollar and euro ------------------------------------------------------------------------ r3202 | tron | 2005-11-16 12:29:37 +0000 (Wed, 16 Nov 2005) | 1 line If cascade -> switch ------------------------------------------------------------------------ r3201 | tron | 2005-11-16 12:25:33 +0000 (Wed, 16 Nov 2005) | 1 line -Fix: Allow bribing up to the maximum rating for bribing, don't disable this option at some arbitrary value early ------------------------------------------------------------------------ r3200 | tron | 2005-11-16 12:21:04 +0000 (Wed, 16 Nov 2005) | 1 line Remove the unused function GfxScalePalette() and the unused struct WorldSprite ------------------------------------------------------------------------ r3199 | tron | 2005-11-16 12:20:15 +0000 (Wed, 16 Nov 2005) | 1 line -Fix: There are only 2 possible directions for ship depots, not 4 ------------------------------------------------------------------------ r3198 | tron | 2005-11-16 12:10:45 +0000 (Wed, 16 Nov 2005) | 1 line Rewrite the company league drawing routine for better readability ------------------------------------------------------------------------ r3197 | tron | 2005-11-16 12:04:34 +0000 (Wed, 16 Nov 2005) | 1 line Use a better bias so you can directly see the date range a disaster can happen in ------------------------------------------------------------------------ r3196 | tron | 2005-11-16 12:01:46 +0000 (Wed, 16 Nov 2005) | 1 line Use structs instead of magic offsets into arrays ------------------------------------------------------------------------ r3195 | tron | 2005-11-16 11:55:06 +0000 (Wed, 16 Nov 2005) | 1 line Use bitfields instead of explicit shifting/masking ------------------------------------------------------------------------ r3194 | tron | 2005-11-16 11:52:21 +0000 (Wed, 16 Nov 2005) | 1 line Don't use FindLandscapeHeightByTile() when it's overkill ------------------------------------------------------------------------ r3193 | tron | 2005-11-16 11:50:40 +0000 (Wed, 16 Nov 2005) | 1 line Staticise the vehicle position hash ------------------------------------------------------------------------ r3192 | tron | 2005-11-16 11:17:52 +0000 (Wed, 16 Nov 2005) | 1 line Split the surname list into two lists (non-toyland/toyland) and use lengthof() to get the number of names instead of using magic numbers ------------------------------------------------------------------------ r3191 | tron | 2005-11-16 08:35:26 +0000 (Wed, 16 Nov 2005) | 1 line Move declaration and definition of _dbg_screen_rect to a place where it somewhat makes sense and wrap them in #ifdef _DEBUG ------------------------------------------------------------------------ r3190 | tron | 2005-11-15 11:46:49 +0000 (Tue, 15 Nov 2005) | 1 line Turn some loops into canonical for loop form ------------------------------------------------------------------------ r3189 | tron | 2005-11-15 11:08:10 +0000 (Tue, 15 Nov 2005) | 1 line There's a dedicated function to check if it's a hangar tile, so use it ------------------------------------------------------------------------ r3188 | tron | 2005-11-15 10:50:43 +0000 (Tue, 15 Nov 2005) | 1 line Use CmdFailed() to check, if a command failed, don't compare with CMD_ERROR ------------------------------------------------------------------------ r3187 | tron | 2005-11-15 09:47:25 +0000 (Tue, 15 Nov 2005) | 1 line Simplify overly complicated ifs, especially if (foo) return false; else return true; is confusing ------------------------------------------------------------------------ r3186 | tron | 2005-11-15 09:05:16 +0000 (Tue, 15 Nov 2005) | 1 line Unnecessary casts and truncation ------------------------------------------------------------------------ r3185 | tron | 2005-11-15 09:00:02 +0000 (Tue, 15 Nov 2005) | 1 line const ------------------------------------------------------------------------ r3184 | tron | 2005-11-15 08:49:46 +0000 (Tue, 15 Nov 2005) | 1 line GB/SB ------------------------------------------------------------------------ r3183 | tron | 2005-11-15 08:40:45 +0000 (Tue, 15 Nov 2005) | 1 line Remove an unused declaration and properly declare CheckExternalFiles() in a header ------------------------------------------------------------------------ r3182 | tron | 2005-11-14 20:20:24 +0000 (Mon, 14 Nov 2005) | 1 line Fix braino in r3181 ------------------------------------------------------------------------ r3181 | tron | 2005-11-14 19:48:04 +0000 (Mon, 14 Nov 2005) | 11 lines -Bracing -Indentation -Whitespace -DeMorgan's Law -Test with NULL or 0 for non-booleans -'\0' instead of 0 for chars -Remove redundantly redundant comments (like DoFoo(); // Do foo) -Join multiple short lines with a single statement -Split single lines with multiple statements -Avoid assignments in if ------------------------------------------------------------------------ r3180 | tron | 2005-11-14 15:22:12 +0000 (Mon, 14 Nov 2005) | 1 line Replace some magic numbers by symbolic names ------------------------------------------------------------------------ r3179 | tron | 2005-11-14 09:21:05 +0000 (Mon, 14 Nov 2005) | 3 lines - RandomRange() and RandomTile() instead of home brewed versions - CHANCE*() instead of mumbling strange numbers ------------------------------------------------------------------------ r3178 | peter1138 | 2005-11-14 08:42:45 +0000 (Mon, 14 Nov 2005) | 2 lines - Codechange: move static _dropdown_* vars into the window custom data, giving var1 and var2 more meaningful names. ------------------------------------------------------------------------ r3177 | tron | 2005-11-14 08:09:57 +0000 (Mon, 14 Nov 2005) | 1 line GB, CLRBIT, HASBIT, TOGGLEBIT ------------------------------------------------------------------------ r3176 | tron | 2005-11-13 21:16:34 +0000 (Sun, 13 Nov 2005) | 1 line Use proper types, not some variants of int ------------------------------------------------------------------------ r3175 | orudge | 2005-11-13 18:07:45 +0000 (Sun, 13 Nov 2005) | 1 line - Updated OS/2 project file to include station_newgrf.c ------------------------------------------------------------------------ r3174 | Darkvater | 2005-11-13 16:30:04 +0000 (Sun, 13 Nov 2005) | 1 line - Fix: fix compilation for VS.NET2003 and VS6 (missing sourcefile(s) from project) ------------------------------------------------------------------------ r3173 | tron | 2005-11-13 14:54:09 +0000 (Sun, 13 Nov 2005) | 3 lines Use the trinary operator and switch to improve readability Also align short cases nicely ------------------------------------------------------------------------ r3172 | tron | 2005-11-13 13:43:55 +0000 (Sun, 13 Nov 2005) | 1 line static, const ------------------------------------------------------------------------ r3171 | peter1138 | 2005-11-12 11:10:12 +0000 (Sat, 12 Nov 2005) | 2 lines - Codechange: remove static _dropdown_disabled/_dropdown_hidden variables, as a window already contains this information. ------------------------------------------------------------------------ r3170 | peter1138 | 2005-11-12 09:30:52 +0000 (Sat, 12 Nov 2005) | 2 lines - NewGRF: make ttdpatch flags to reflect patch option status, and added some more values. ------------------------------------------------------------------------ r3169 | peter1138 | 2005-11-12 08:51:46 +0000 (Sat, 12 Nov 2005) | 2 lines Little bit of coding style fixing, and change from value to lengthof() ------------------------------------------------------------------------ r3168 | peter1138 | 2005-11-12 00:29:13 +0000 (Sat, 12 Nov 2005) | 2 lines - NewGRF: Fix "typo" in waypoint drawer :/ ------------------------------------------------------------------------ r3167 | peter1138 | 2005-11-12 00:19:34 +0000 (Sat, 12 Nov 2005) | 5 lines - NewGRF: Start moving custom station code to separate files. Rewrite handling of station classes. Allow for more than 8 station tile layouts. Start of code to unload custom stations. ------------------------------------------------------------------------ r3166 | peter1138 | 2005-11-11 20:34:16 +0000 (Fri, 11 Nov 2005) | 2 lines Constify read-only accesses of custom stations ------------------------------------------------------------------------ r3163 | tron | 2005-11-10 17:21:05 +0000 (Thu, 10 Nov 2005) | 1 line Include header for toupper() ------------------------------------------------------------------------ r3162 | truelight | 2005-11-10 15:23:55 +0000 (Thu, 10 Nov 2005) | 3 lines -Fix: renamed 'Message' to 'WindowMessage', a struct named 'Message' already exists on MorphOS ------------------------------------------------------------------------