------------------------------------------------------------------------ r2458 | truelight | 2005-06-18 15:08:35 +0000 (Sat, 18 Jun 2005) | 1 line -Fix: Quickfix to make dedicated-server compile again. We need a more ellegant way to fix this... ------------------------------------------------------------------------ r2457 | truelight | 2005-06-18 10:02:47 +0000 (Sat, 18 Jun 2005) | 1 line -Fix: typo in Makefile for OSX builds ------------------------------------------------------------------------ r2456 | matthijs | 2005-06-17 17:11:05 +0000 (Fri, 17 Jun 2005) | 3 lines * Prettyfied npf.c using enums and wrappers from rail.h. * Moved GetTileRailType() from npf.c to rail.[ch]. ------------------------------------------------------------------------ r2455 | miham | 2005-06-17 13:39:59 +0000 (Fri, 17 Jun 2005) | 1 line [Translations] Updated to 2005-06-17 (100+ strs / 10+ langs) ------------------------------------------------------------------------ r2454 | matthijs | 2005-06-17 11:30:50 +0000 (Fri, 17 Jun 2005) | 4 lines * Codechange: Move #include "stdafx.h" and "openttd.h" from rail.h to rail.c * Codechange: Move declaration of lookup arrays into the functions that need them. This doesn't pollute the global namespace with the array names. * Add: rail.h to the openttd.vcproj and openttd.dsp for MSVC. ------------------------------------------------------------------------ r2453 | matthijs | 2005-06-17 09:53:22 +0000 (Fri, 17 Jun 2005) | 2 lines * CodeChange: Declared the lookup arrays in rail.h as extern, so the linker will complain if they are not defined (ie when rail.c is not included). ------------------------------------------------------------------------ r2452 | tron | 2005-06-17 07:35:10 +0000 (Fri, 17 Jun 2005) | 1 line Fix defect in r2448 which caused building tracks unexpectedly fail or succeed ------------------------------------------------------------------------ r2451 | matthijs | 2005-06-17 00:46:33 +0000 (Fri, 17 Jun 2005) | 2 lines * Fix: Assertion caused by passing a trackdir where a track was expected. ------------------------------------------------------------------------ r2450 | matthijs | 2005-06-17 00:22:46 +0000 (Fri, 17 Jun 2005) | 6 lines * Codechange: Replaced all uses of the arrays in tile.h with calls to the associated wrapper functions. * Codechange: Made npf.c use some map array accessing wrappers instead of direct access. * Codechange/Fix: Named every enum in tile.h. Fixes a nasty bug on MSVC where arrays would be initialised with zeroes (tnx Asterix_) * Removed magic numbers from tables in tile.c. * Added some explicit casts in tile.h. ------------------------------------------------------------------------ r2449 | matthijs | 2005-06-16 20:54:37 +0000 (Thu, 16 Jun 2005) | 2 lines * Added an extra warning to the stopall command, "For debugging only!". ------------------------------------------------------------------------ r2448 | matthijs | 2005-06-16 18:04:02 +0000 (Thu, 16 Jun 2005) | 18 lines General cleanup of rail related code, more to follow. * Add: rail.[ch] for rail-related enums and wrapper functions. * Codechange: Removed dozens of magic numbers with below enums. * Codechange: Rewrote CheckTrackCombination(). * Add: TILE_SIZE, TILE_PIXELS and TILE_HEIGHT constants. * Add: enums RailTileType, RailTileSubtype, SignalType to mask against the map arrays. * Add: enums Track, TrackBits, Trackdir, TrackdirBits for railway track data. (Note that the old RAIL_BIT constants are replaced by TRACK_BIT ones). * Add: enums Direction and DiagDirection * Codechange: Moved a bunch of track(dir) related lookup arrays from npf.[ch] to rail.[ch]. * Codechange: move RailType enum from tile.h to rail.h. * Add: Wrapper functions for masking signal status in the map arrays: SignalAlongTrackdir, SignalAgainstTrackdir and SignalOnTrack. * Add: Wrapper functions to access rail tiles, using above enums * Add: Wrapper functions to modify tracks, trackdirs, directions, etc. * Add: Wrapper functions for all lookup arrays in rail.[ch] (Arrays are still used in parts of the code) * Codechange: Renamed some variables and arguments to better represent what they contain (railbit -> track, bits -> trackdirbits, etc.). * Codechange: Don't use FindLandscapeHeight() in CmdRemoveSingleRail(), since it returns way too much info. Use GetTileSlope() instead. * Codechange: [NPF] Removed some unused globals and code from npf.c. ------------------------------------------------------------------------ r2447 | matthijs | 2005-06-16 17:53:40 +0000 (Thu, 16 Jun 2005) | 2 lines * Add: [NPF] Penalty for road vehicles making turns. ------------------------------------------------------------------------ r2446 | matthijs | 2005-06-16 01:25:01 +0000 (Thu, 16 Jun 2005) | 2 lines * Made os/debian/rules executable. ------------------------------------------------------------------------ r2445 | matthijs | 2005-06-16 00:54:19 +0000 (Thu, 16 Jun 2005) | 2 lines * Add: "stopall" console command, which forcibly stops all vehicles (useful for debugging). ------------------------------------------------------------------------ r2444 | hackykid | 2005-06-15 17:27:14 +0000 (Wed, 15 Jun 2005) | 2 lines - CodeChange: Add an enum for demagicifying the values of the 'flags' parameter of DrawFrameRect(). (_Abraxa_) ------------------------------------------------------------------------ r2443 | celestar | 2005-06-15 17:18:32 +0000 (Wed, 15 Jun 2005) | 1 line -Fix: somehow I delete one line too many :( ------------------------------------------------------------------------ r2442 | miham | 2005-06-15 17:09:24 +0000 (Wed, 15 Jun 2005) | 2 lines [Translations] Updated to 2005-06-15 #2. (27+X strs / all lang) [Translations] 10 strings got added, 8 strings got changed in english.txt, lots of work ahead ------------------------------------------------------------------------ r2441 | celestar | 2005-06-15 16:58:15 +0000 (Wed, 15 Jun 2005) | 1 line -Feature: You can now give transfer order to set up feeder systems ------------------------------------------------------------------------ r2440 | hackykid | 2005-06-15 14:04:48 +0000 (Wed, 15 Jun 2005) | 3 lines - Fix: [newgrf] Fix the spritesorter to handle overlapping sprites properly, this fixes display problems with really short wagons. (algorithm by patchman, ported by therax) - Fix: [newgrf] Too short wagons could break the 'follow next vehicle' code used in the traincontroller. Clamp better to prevent this. ------------------------------------------------------------------------ r2439 | miham | 2005-06-15 09:28:02 +0000 (Wed, 15 Jun 2005) | 1 line [Translations] Updated to 2005-06-15 (6 strs / 3 lang) ------------------------------------------------------------------------ r2438 | hackykid | 2005-06-14 10:59:05 +0000 (Tue, 14 Jun 2005) | 2 lines - Feature: New display option, 'transparent station signs', makes station signs transparent instead of using a solid bar to draw text on (peter1138) ------------------------------------------------------------------------