------------------------------------------------------------------------ r16743 | translators | 2009-07-04 17:45:07 +0000 (Sat, 04 Jul 2009) | 3 lines -Update from WebTranslator v3.0: german - 18 changes by planetmaker ------------------------------------------------------------------------ r16740 | alberth | 2009-07-04 15:35:36 +0000 (Sat, 04 Jul 2009) | 1 line -Codechange: Self-sizing widgets in intro screen, town directory, and found town windows. ------------------------------------------------------------------------ r16739 | alberth | 2009-07-04 14:13:23 +0000 (Sat, 04 Jul 2009) | 1 line -Codechange: Initialize internal data before computing the widgets. ------------------------------------------------------------------------ r16738 | alberth | 2009-07-04 13:55:28 +0000 (Sat, 04 Jul 2009) | 1 line -Codechange: Remove casting away constness by changing the text before storing. ------------------------------------------------------------------------ r16737 | frosch | 2009-07-04 12:20:42 +0000 (Sat, 04 Jul 2009) | 1 line -Fix (r15645): When loading a savegame Engine::grffile might be left NULL in certain cases. (dynamic_engines enabled, articulated vehicle with only wagon-override action3s) ------------------------------------------------------------------------ r16736 | rubidium | 2009-07-04 11:26:57 +0000 (Sat, 04 Jul 2009) | 2 lines -Codechange: give some station enums a name and use that instead of 'byte'. ------------------------------------------------------------------------ r16735 | rubidium | 2009-07-04 11:24:25 +0000 (Sat, 04 Jul 2009) | 2 lines -Codechange: had_vehicle_of_type only stored 7 bits, all less that bit 7... but it was a word wasting space etc. ------------------------------------------------------------------------ r16734 | alberth | 2009-07-03 22:25:59 +0000 (Fri, 03 Jul 2009) | 1 line -Codechange: Prepare intro, town directory, and found town windows for more flexible widget contents. ------------------------------------------------------------------------ r16733 | alberth | 2009-07-03 21:38:41 +0000 (Fri, 03 Jul 2009) | 1 line -Codechange: Move rebuilding and sorting the town list out of TownDirectoryWindow::OnPaint. ------------------------------------------------------------------------ r16732 | rubidium | 2009-07-03 21:08:18 +0000 (Fri, 03 Jul 2009) | 2 lines -Fix [FS#2991]: show Close instead of Cancel when there's nothing to canel in the content downloading window. ------------------------------------------------------------------------ r16731 | yexo | 2009-07-03 19:55:07 +0000 (Fri, 03 Jul 2009) | 1 line -Fix [NoAI]: AIDepotList contained wrong tiles for hangars when st->xy != st->airport_tile. ------------------------------------------------------------------------ r16730 | alberth | 2009-07-03 19:34:28 +0000 (Fri, 03 Jul 2009) | 1 line -Doc: Added some missing docs (most notably the class/struct docs) to GUIList template. ------------------------------------------------------------------------ r16729 | translators | 2009-07-03 17:45:22 +0000 (Fri, 03 Jul 2009) | 8 lines -Update from WebTranslator v3.0: german - 7 changes by planetmaker hebrew - 2 changes by yitzc indonesian - 28 changes by fanioz korean - 1 changes by darkttd brazilian_portuguese - 85 changes by Tucalipe turkish - 23 changes by niw3 ------------------------------------------------------------------------ r16728 | smatz | 2009-07-03 13:33:00 +0000 (Fri, 03 Jul 2009) | 1 line -Fix (r14919): the Join station window didn't show all stations nearby in some cases ------------------------------------------------------------------------ r16727 | alberth | 2009-07-02 21:18:22 +0000 (Thu, 02 Jul 2009) | 1 line -Codechange: Introducing WD_SORTBUTTON_ARROW_WIDTH constant. ------------------------------------------------------------------------ r16726 | translators | 2009-07-02 17:45:16 +0000 (Thu, 02 Jul 2009) | 6 lines -Update from WebTranslator v3.0: indonesian - 26 changes by fanioz italian - 8 changes by lorenzodv korean - 29 changes by darkttd swedish - 74 changes by daishan ------------------------------------------------------------------------ r16725 | frosch | 2009-07-02 17:08:54 +0000 (Thu, 02 Jul 2009) | 1 line -Documentation: raw_industry_cost_multiplier ------------------------------------------------------------------------ r16724 | smatz | 2009-07-02 12:47:52 +0000 (Thu, 02 Jul 2009) | 1 line -Fix (r16714): MSVC 64bit warnings (Rubidium) ------------------------------------------------------------------------ r16723 | smatz | 2009-07-02 12:10:39 +0000 (Thu, 02 Jul 2009) | 1 line -Codechange: make GetNextArticPart(), GetLastEnginePart(), GetNextVehicle(), GetPrevVehicle(), GetNextUnit(), GetPrevUnit() members of Train ------------------------------------------------------------------------ r16722 | rubidium | 2009-07-02 09:06:15 +0000 (Thu, 02 Jul 2009) | 2 lines -Codechange: unify the naming of the Is/Set/HasArticulatedPart functions ------------------------------------------------------------------------ r16721 | rubidium | 2009-07-02 08:59:27 +0000 (Thu, 02 Jul 2009) | 2 lines -Codechange: make Is/SetRoadVehicleFront, Is/Set/HasArticulatedPart member of RoadVehicle. ------------------------------------------------------------------------ r16720 | smatz | 2009-07-02 00:17:27 +0000 (Thu, 02 Jul 2009) | 1 line -Codechange: make Set/ClearFrontEngine(), Set/ClearArticulatedPart(), Set/ClearWagon(), Set/ClearEngine(), Set/ClearFreeWagon() and Set/ClearMultiheaded() members of Train ------------------------------------------------------------------------ r16719 | smatz | 2009-07-01 23:57:20 +0000 (Wed, 01 Jul 2009) | 1 line -Codechange: make IsArticulatedPart(), IsTrainEngine(), IsTrainWagon(), IsMultiheaded(), EngineHasArticPart() and IsRearDualheaded() members of Train ------------------------------------------------------------------------ r16718 | smatz | 2009-07-01 23:49:13 +0000 (Wed, 01 Jul 2009) | 1 line -Codechange: make IsFreeWagon() member of Train ------------------------------------------------------------------------ r16717 | smatz | 2009-07-01 22:22:01 +0000 (Wed, 01 Jul 2009) | 1 line -Codechange: make IsFrontEngine() member of Train ------------------------------------------------------------------------ r16716 | smatz | 2009-07-01 21:33:06 +0000 (Wed, 01 Jul 2009) | 1 line -Codechange: reduce code duplication in DrawCompanyVehiclesAmount() ------------------------------------------------------------------------ r16715 | smatz | 2009-07-01 21:29:03 +0000 (Wed, 01 Jul 2009) | 1 line -Codechange: add attribute to assert_compile(), so it doesn't warn when used inside function ------------------------------------------------------------------------ r16714 | smatz | 2009-07-01 18:45:05 +0000 (Wed, 01 Jul 2009) | 1 line -Codechange: use pool-like accessors for Subsidy ------------------------------------------------------------------------ r16713 | smatz | 2009-07-01 18:18:12 +0000 (Wed, 01 Jul 2009) | 1 line -Doc: document the Subsidy struct ------------------------------------------------------------------------ r16712 | translators | 2009-07-01 17:45:22 +0000 (Wed, 01 Jul 2009) | 9 lines -Update from WebTranslator v3.0: afrikaans - 23 changes by burgerd dutch - 8 changes by Yexo french - 8 changes by glx german - 29 changes by dihedral, planetmaker indonesian - 14 changes by fanioz italian - 43 changes by lorenzodv malay - 55 changes by Syed ------------------------------------------------------------------------ r16711 | smatz | 2009-07-01 17:43:26 +0000 (Wed, 01 Jul 2009) | 1 line -Codechange: use FOR_ALL_SUBSIDIES macro when iterating over all subsidies ------------------------------------------------------------------------ r16710 | smatz | 2009-07-01 15:08:43 +0000 (Wed, 01 Jul 2009) | 1 line -Fix: invalidate subsidies with invalid source or destination when converting older savegames ------------------------------------------------------------------------ r16709 | rubidium | 2009-07-01 14:51:05 +0000 (Wed, 01 Jul 2009) | 2 lines -Fix [FS#2994]: the list of animated tiles could have duplicates (only for old savegames) and tiles that weren't animated ------------------------------------------------------------------------ r16708 | rubidium | 2009-07-01 09:53:54 +0000 (Wed, 01 Jul 2009) | 2 lines -Cleanup: do not try to indent strings using spaces, especially strings that span multiple lines; it will not get the effect you want. Also do not indent at different levels in different strings that will be shown on the same place. ------------------------------------------------------------------------ r16707 | rubidium | 2009-07-01 09:50:52 +0000 (Wed, 01 Jul 2009) | 2 lines -Fix [FS#3007] (r16693): under some circumstances vehicles would skip loading as they thought nothing could be unloaded or loaded. ------------------------------------------------------------------------ r16706 | rubidium | 2009-07-01 09:45:30 +0000 (Wed, 01 Jul 2009) | 2 lines -Fix (r16694): acquiring a subsidy resulted in an assertion. ------------------------------------------------------------------------ r16703 | translators | 2009-06-30 17:45:27 +0000 (Tue, 30 Jun 2009) | 11 lines -Update from WebTranslator v3.0: catalan - 1 changes by arnaullv traditional_chinese - 7 changes by elleryq danish - 3 changes by silentStatic dutch - 4 changes by Excel20 estonian - 34 changes by kristjans german - 7 changes by dihedral greek - 24 changes by Gonik malay - 30 changes by Syed romanian - 68 changes by kneekoo ------------------------------------------------------------------------ r16702 | rubidium | 2009-06-30 16:20:16 +0000 (Tue, 30 Jun 2009) | 2 lines -Change: don't implicitly fall back to the null/dedicated (video) drivers, but show an error message that no driver could be found. You can still explicitly start the null drivers thought. ------------------------------------------------------------------------ r16701 | rubidium | 2009-06-30 12:42:43 +0000 (Tue, 30 Jun 2009) | 2 lines -Fix [FS#3001]: limit the screen's resolution to 65535x65535 so the dirty pixels stay within bounds of a 32 bits integer ------------------------------------------------------------------------ r16700 | rubidium | 2009-06-30 12:38:18 +0000 (Tue, 30 Jun 2009) | 2 lines -Fix: if allegro fails to start or fails open a window or sound card fall back to another driver ------------------------------------------------------------------------ r16699 | rubidium | 2009-06-30 12:36:24 +0000 (Tue, 30 Jun 2009) | 2 lines -Fix [FS#3001]: if SDL fails to allocate a surface due to it being too large (and SDL doesn't crash!) fall back to another video driver. ------------------------------------------------------------------------ r16698 | rubidium | 2009-06-30 10:26:28 +0000 (Tue, 30 Jun 2009) | 2 lines -Document: update documentation pointing to the old translator tool. ------------------------------------------------------------------------ r16697 | translators | 2009-06-30 10:19:14 +0000 (Tue, 30 Jun 2009) | 2 lines -Fix (r16696): don't silently introduce old ##case for some languages ------------------------------------------------------------------------ r16696 | translators | 2009-06-30 10:14:17 +0000 (Tue, 30 Jun 2009) | 3 lines -Change: make order of pragmas identical for all languages (and to what strgen defines it to be) -Change: make order of cases identical to what the case-pragma indicates ------------------------------------------------------------------------ r16695 | translators | 2009-06-30 10:01:05 +0000 (Tue, 30 Jun 2009) | 7 lines -Update: WebTranslator2 update to 2009-06-30 10:00:57 japanese - 6 fixed by nex259 (6) norwegian_bokmal - 8 fixed by jankmi (8) portuguese - 9 fixed by SnowFlake (9) serbian - 111 fixed by etran (111) spanish - 1 fixed by erregerre (1) ------------------------------------------------------------------------ r16694 | rubidium | 2009-06-29 19:55:36 +0000 (Mon, 29 Jun 2009) | 6 lines -Fix [FS#2995] (rgradual loading, rnewindustries): only pay for whatever has been actually unloaded and perform the payment when unloading has finished. This fixes, amongst others: * cheating by starting to unload and after getting paid rushing to the depot to get sold (or unloading, loading and getting paid again for the remainder) * cargo being dropped onto a station at the moment a stockpiling industry doesn't accept it anymore * industries getting cargo that has not been unloaded yet and subsequently dumping it back on the station in one go Note: you will now get paid after the unloading has finished, so you'll have to wait a bit longer for 'your' money. ------------------------------------------------------------------------ r16693 | rubidium | 2009-06-29 19:17:23 +0000 (Mon, 29 Jun 2009) | 2 lines -Fix [FS#3004] (r16883): cargo income was not added to the vehicle's profit. ------------------------------------------------------------------------ r16692 | translators | 2009-06-29 17:45:07 +0000 (Mon, 29 Jun 2009) | 3 lines -Update from WebTranslator v3.0: ukrainian - 3 changes by Madvin ------------------------------------------------------------------------ r16691 | rubidium | 2009-06-29 09:32:58 +0000 (Mon, 29 Jun 2009) | 2 lines -Codechange: what's the point of getting the fifth dparam and then using that as the second dparam later on? Especially when the fifth dparam is never set and the second dparam is never used. ------------------------------------------------------------------------ r16690 | michi_cc | 2009-06-28 22:42:19 +0000 (Sun, 28 Jun 2009) | 1 line -Fix [FS#3002]: Missing debug string for ESRB_SAFE_TILE in YAPF debugging helper. ------------------------------------------------------------------------ r16689 | alberth | 2009-06-28 22:23:26 +0000 (Sun, 28 Jun 2009) | 1 line -Codechange: Allow for rendering of parameterized text of nested widgets in Window::DrawWidget, adapt intro and town directory windows. ------------------------------------------------------------------------ r16688 | alberth | 2009-06-28 21:23:37 +0000 (Sun, 28 Jun 2009) | 1 line -Codechange: Some cleanup of intro screen and town directory. ------------------------------------------------------------------------ r16687 | alberth | 2009-06-28 20:09:40 +0000 (Sun, 28 Jun 2009) | 1 line -Codechange: Perform re-initialization of windows with nested widgets after a language change. ------------------------------------------------------------------------ r16686 | translators | 2009-06-28 17:45:07 +0000 (Sun, 28 Jun 2009) | 3 lines -Update from WebTranslator v3.0: german - 4 changes by planetmaker ------------------------------------------------------------------------ r16685 | translators | 2009-06-28 17:40:14 +0000 (Sun, 28 Jun 2009) | 3 lines -Update: WebTranslator2 update to 2009-06-28 17:40:12 korean - 3 fixed, 28 changed by leejaeuk5 (31) ------------------------------------------------------------------------ r16684 | alberth | 2009-06-28 15:16:57 +0000 (Sun, 28 Jun 2009) | 1 line -Codechange: Add maxdim function for Dimension struct. ------------------------------------------------------------------------ r16683 | rubidium | 2009-06-28 15:12:59 +0000 (Sun, 28 Jun 2009) | 2 lines -Codechange: move the cargo payment handling to a seperate class. Based on ideas of fonso/fonsinchen. ------------------------------------------------------------------------ r16682 | rubidium | 2009-06-28 14:36:25 +0000 (Sun, 28 Jun 2009) | 2 lines -Codechange: make (static) industry list used to trigger the industries' production compile unit static instead of passing it around as pointer ------------------------------------------------------------------------ r16681 | rubidium | 2009-06-28 14:33:10 +0000 (Sun, 28 Jun 2009) | 2 lines -Codechange: only resolve the company once for vehicle payment instead of each time a cargo packet is delivered ------------------------------------------------------------------------ r16680 | rubidium | 2009-06-28 14:29:58 +0000 (Sun, 28 Jun 2009) | 2 lines -Codechange: don't go through all the station unloading stuff when there is no vehicle at the station ------------------------------------------------------------------------ r16679 | frosch | 2009-06-27 21:36:04 +0000 (Sat, 27 Jun 2009) | 1 line -Codechange: Let GetCapacityOfArticulatedParts() return a CargoArray instead of a pointer to a static array. ------------------------------------------------------------------------ r16678 | frosch | 2009-06-27 21:06:58 +0000 (Sat, 27 Jun 2009) | 1 line -Codechange: Turn CargoArray into a class, so one does not have to deal with sizeof() wrt. typedef-ed arrays. ------------------------------------------------------------------------ r16677 | alberth | 2009-06-27 20:53:45 +0000 (Sat, 27 Jun 2009) | 1 line -Codechange: Dimension width and height are unsigned. ------------------------------------------------------------------------ r16676 | frosch | 2009-06-27 18:26:50 +0000 (Sat, 27 Jun 2009) | 1 line -Codechange: Rename AcceptedCargo to CargoArray and its instances to more meaningful names. ------------------------------------------------------------------------ r16675 | translators | 2009-06-27 17:45:10 +0000 (Sat, 27 Jun 2009) | 4 lines -Update from WebTranslator v3.0: german - 19 changes by planetmaker ukrainian - 21 changes by Madvin ------------------------------------------------------------------------ r16674 | translators | 2009-06-27 17:32:18 +0000 (Sat, 27 Jun 2009) | 5 lines -Update: WebTranslator2 update to 2009-06-27 17:32:13 estonian - 1 fixed by kristjans (1) slovak - 38 fixed by James (38) traditional_chinese - 9 fixed, 15 changed by josesun (24) ------------------------------------------------------------------------