------------------------------------------------------------------------ r16692 | translators | 2009-06-29 17:45:07 +0000 (Mon, 29 Jun 2009) | 3 lines -Update from WebTranslator v3.0: ukrainian - 3 changes by Madvin ------------------------------------------------------------------------ r16691 | rubidium | 2009-06-29 09:32:58 +0000 (Mon, 29 Jun 2009) | 2 lines -Codechange: what's the point of getting the fifth dparam and then using that as the second dparam later on? Especially when the fifth dparam is never set and the second dparam is never used. ------------------------------------------------------------------------ r16690 | michi_cc | 2009-06-28 22:42:19 +0000 (Sun, 28 Jun 2009) | 1 line -Fix [FS#3002]: Missing debug string for ESRB_SAFE_TILE in YAPF debugging helper. ------------------------------------------------------------------------ r16689 | alberth | 2009-06-28 22:23:26 +0000 (Sun, 28 Jun 2009) | 1 line -Codechange: Allow for rendering of parameterized text of nested widgets in Window::DrawWidget, adapt intro and town directory windows. ------------------------------------------------------------------------ r16688 | alberth | 2009-06-28 21:23:37 +0000 (Sun, 28 Jun 2009) | 1 line -Codechange: Some cleanup of intro screen and town directory. ------------------------------------------------------------------------ r16687 | alberth | 2009-06-28 20:09:40 +0000 (Sun, 28 Jun 2009) | 1 line -Codechange: Perform re-initialization of windows with nested widgets after a language change. ------------------------------------------------------------------------ r16686 | translators | 2009-06-28 17:45:07 +0000 (Sun, 28 Jun 2009) | 3 lines -Update from WebTranslator v3.0: german - 4 changes by planetmaker ------------------------------------------------------------------------ r16685 | translators | 2009-06-28 17:40:14 +0000 (Sun, 28 Jun 2009) | 3 lines -Update: WebTranslator2 update to 2009-06-28 17:40:12 korean - 3 fixed, 28 changed by leejaeuk5 (31) ------------------------------------------------------------------------ r16684 | alberth | 2009-06-28 15:16:57 +0000 (Sun, 28 Jun 2009) | 1 line -Codechange: Add maxdim function for Dimension struct. ------------------------------------------------------------------------ r16683 | rubidium | 2009-06-28 15:12:59 +0000 (Sun, 28 Jun 2009) | 2 lines -Codechange: move the cargo payment handling to a seperate class. Based on ideas of fonso/fonsinchen. ------------------------------------------------------------------------ r16682 | rubidium | 2009-06-28 14:36:25 +0000 (Sun, 28 Jun 2009) | 2 lines -Codechange: make (static) industry list used to trigger the industries' production compile unit static instead of passing it around as pointer ------------------------------------------------------------------------ r16681 | rubidium | 2009-06-28 14:33:10 +0000 (Sun, 28 Jun 2009) | 2 lines -Codechange: only resolve the company once for vehicle payment instead of each time a cargo packet is delivered ------------------------------------------------------------------------ r16680 | rubidium | 2009-06-28 14:29:58 +0000 (Sun, 28 Jun 2009) | 2 lines -Codechange: don't go through all the station unloading stuff when there is no vehicle at the station ------------------------------------------------------------------------ r16679 | frosch | 2009-06-27 21:36:04 +0000 (Sat, 27 Jun 2009) | 1 line -Codechange: Let GetCapacityOfArticulatedParts() return a CargoArray instead of a pointer to a static array. ------------------------------------------------------------------------ r16678 | frosch | 2009-06-27 21:06:58 +0000 (Sat, 27 Jun 2009) | 1 line -Codechange: Turn CargoArray into a class, so one does not have to deal with sizeof() wrt. typedef-ed arrays. ------------------------------------------------------------------------ r16677 | alberth | 2009-06-27 20:53:45 +0000 (Sat, 27 Jun 2009) | 1 line -Codechange: Dimension width and height are unsigned. ------------------------------------------------------------------------ r16676 | frosch | 2009-06-27 18:26:50 +0000 (Sat, 27 Jun 2009) | 1 line -Codechange: Rename AcceptedCargo to CargoArray and its instances to more meaningful names. ------------------------------------------------------------------------ r16675 | translators | 2009-06-27 17:45:10 +0000 (Sat, 27 Jun 2009) | 4 lines -Update from WebTranslator v3.0: german - 19 changes by planetmaker ukrainian - 21 changes by Madvin ------------------------------------------------------------------------ r16674 | translators | 2009-06-27 17:32:18 +0000 (Sat, 27 Jun 2009) | 5 lines -Update: WebTranslator2 update to 2009-06-27 17:32:13 estonian - 1 fixed by kristjans (1) slovak - 38 fixed by James (38) traditional_chinese - 9 fixed, 15 changed by josesun (24) ------------------------------------------------------------------------ r16673 | smatz | 2009-06-27 17:05:20 +0000 (Sat, 27 Jun 2009) | 1 line -Codechange: rename GetProducedCargo() to AddProducedCargo() and change its behaviour accordingly ------------------------------------------------------------------------ r16672 | alberth | 2009-06-27 11:45:05 +0000 (Sat, 27 Jun 2009) | 1 line -Codechange: Add functions to compute size of strings and sprites. ------------------------------------------------------------------------ r16671 | alberth | 2009-06-26 23:20:32 +0000 (Fri, 26 Jun 2009) | 1 line -Doc: Documenting Sprite structure. ------------------------------------------------------------------------ r16670 | alberth | 2009-06-26 21:25:25 +0000 (Fri, 26 Jun 2009) | 1 line -Codechange: Containers with equally sized children are useful to have. ------------------------------------------------------------------------ r16669 | frosch | 2009-06-26 20:03:16 +0000 (Fri, 26 Jun 2009) | 1 line -Cleanup (r1): Only animated tiles are... animated. ------------------------------------------------------------------------ r16668 | translators | 2009-06-26 17:45:11 +0000 (Fri, 26 Jun 2009) | 4 lines -Update from WebTranslator v3.0: dutch - 43 changes by Yexo ukrainian - 34 changes by Madvin ------------------------------------------------------------------------ r16667 | smatz | 2009-06-26 15:08:54 +0000 (Fri, 26 Jun 2009) | 1 line -Codechange: replace GetRandomTown() and GetRandomIndustry() by Town::GetRandom() and Industry::GetRandom() ------------------------------------------------------------------------ r16666 | smatz | 2009-06-26 14:02:27 +0000 (Fri, 26 Jun 2009) | 1 line -Codechange: replace GetHouseSpecs() by HouseSpec::Get(), hide _house_specs[] ------------------------------------------------------------------------ r16665 | smatz | 2009-06-26 13:46:23 +0000 (Fri, 26 Jun 2009) | 1 line -Codechange: replace GetTownByTile() by Town::GetByTile() ------------------------------------------------------------------------ r16664 | smatz | 2009-06-26 13:44:14 +0000 (Fri, 26 Jun 2009) | 1 line -Codechange: move house-related stuff from town.h and town_type.h to separate files ------------------------------------------------------------------------ r16663 | smatz | 2009-06-26 12:25:53 +0000 (Fri, 26 Jun 2009) | 1 line -Codechange: make removing of railway station tiles faster ------------------------------------------------------------------------ r16662 | smatz | 2009-06-26 10:45:20 +0000 (Fri, 26 Jun 2009) | 1 line -Codechange: replace GetRoadStopByTile() by RoadStop::GetByTile() ------------------------------------------------------------------------ r16661 | smatz | 2009-06-25 23:49:59 +0000 (Thu, 25 Jun 2009) | 1 line -Codechange: move definition of few very short functions to header files ------------------------------------------------------------------------ r16660 | smatz | 2009-06-25 20:08:59 +0000 (Thu, 25 Jun 2009) | 1 line -Codechange: get rid of more dummy tile_type_procs ------------------------------------------------------------------------ r16659 | smatz | 2009-06-25 19:23:09 +0000 (Thu, 25 Jun 2009) | 2 lines -Codechange: rename GetAcceptedCargo() to AddAcceptedCargo() and change its behaviour accordingly -Codechange: remove dummy GetAcceptedCargo_*() handlers ------------------------------------------------------------------------ r16658 | translators | 2009-06-25 17:45:18 +0000 (Thu, 25 Jun 2009) | 6 lines -Update from WebTranslator v3.0: dutch - 42 changes by Excel20 german - 26 changes by dihedral, mjreaper, planetmaker hungarian - 39 changes by alyr ukrainian - 47 changes by Madvin ------------------------------------------------------------------------ r16657 | translators | 2009-06-25 16:41:13 +0000 (Thu, 25 Jun 2009) | 4 lines -Update: WebTranslator2 update to 2009-06-25 16:41:10 finnish - 1 fixed by jpx_ (1) serbian - 110 fixed by etran (110) ------------------------------------------------------------------------ r16656 | smatz | 2009-06-25 16:07:23 +0000 (Thu, 25 Jun 2009) | 1 line -Fix (r16655): strange things happen ------------------------------------------------------------------------ r16655 | smatz | 2009-06-25 15:54:06 +0000 (Thu, 25 Jun 2009) | 1 line -Codechange: use IsRailwayStationTile() more ------------------------------------------------------------------------ r16654 | smatz | 2009-06-25 15:42:03 +0000 (Thu, 25 Jun 2009) | 1 line -Codechange: cache industries in station's coverage area instead of searching them everytime payment is made ------------------------------------------------------------------------ r16653 | smatz | 2009-06-25 00:06:06 +0000 (Thu, 25 Jun 2009) | 1 line -Fix (r16269): TOC() macro was broken ------------------------------------------------------------------------ r16652 | smatz | 2009-06-24 23:59:20 +0000 (Wed, 24 Jun 2009) | 2 lines -Codechange: use less strict, but faster check for quickly bailing out in FindTrainCollideEnum() (Bilbo) -Codechange: shuffle the code a bit ------------------------------------------------------------------------ r16651 | yexo | 2009-06-24 23:34:30 +0000 (Wed, 24 Jun 2009) | 1 line -Fix: When there is no AI version that can load data from the savegame, load the latest version of the same AI instead of a random AI. ------------------------------------------------------------------------ r16650 | yexo | 2009-06-24 23:24:01 +0000 (Wed, 24 Jun 2009) | 1 line -Fix (r16649): missing () ------------------------------------------------------------------------ r16649 | yexo | 2009-06-24 23:23:08 +0000 (Wed, 24 Jun 2009) | 1 line -Fix: When the exact AI version a game was saved with is no longer available and the latest version of the AI can't load data from that AI version, use the latest available version of the AI that can load the data instead of the first found version that can load the data. ------------------------------------------------------------------------ r16648 | yexo | 2009-06-24 22:38:47 +0000 (Wed, 24 Jun 2009) | 1 line -Codechange: move some more includes around ------------------------------------------------------------------------ r16647 | yexo | 2009-06-24 21:33:11 +0000 (Wed, 24 Jun 2009) | 1 line -Codechange: remove newgrf.h include from newgrf_engine.h to prevent unnecessary inclusion newgrf.h anyway ------------------------------------------------------------------------ r16646 | smatz | 2009-06-24 19:26:41 +0000 (Wed, 24 Jun 2009) | 1 line -Codechange: rename GetDepotByTile() to Depot::GetByTile() ------------------------------------------------------------------------ r16645 | translators | 2009-06-24 17:45:07 +0000 (Wed, 24 Jun 2009) | 3 lines -Update from WebTranslator v3.0: russian - 6 changes by Lone_Wolf ------------------------------------------------------------------------ r16644 | translators | 2009-06-24 17:43:13 +0000 (Wed, 24 Jun 2009) | 5 lines -Update: WebTranslator2 update to 2009-06-24 17:43:08 czech - 1 fixed by Hadez (1) hungarian - 1 fixed by IPG (1) indonesian - 1 fixed by adjayanto (1) ------------------------------------------------------------------------ r16643 | smatz | 2009-06-24 17:39:54 +0000 (Wed, 24 Jun 2009) | 1 line -Codechange: replace GetStationByTile() by Station::GetByTile() ------------------------------------------------------------------------ r16642 | smatz | 2009-06-23 23:42:37 +0000 (Tue, 23 Jun 2009) | 1 line -Codechange: use map size limits enum at one more place ------------------------------------------------------------------------ r16641 | smatz | 2009-06-23 23:31:43 +0000 (Tue, 23 Jun 2009) | 1 line -Codechange: reduce number of multiplications done in FindTrainCollideEnum() to minimum ------------------------------------------------------------------------ r16640 | smatz | 2009-06-23 21:44:48 +0000 (Tue, 23 Jun 2009) | 1 line -Codechange: move roadstop stuff to separate files ------------------------------------------------------------------------ r16639 | smatz | 2009-06-23 21:12:48 +0000 (Tue, 23 Jun 2009) | 1 line -Codechange: enumify RoadStop::status, move definition of short functions to header file ------------------------------------------------------------------------ r16637 | smatz | 2009-06-23 20:39:41 +0000 (Tue, 23 Jun 2009) | 1 line -Cleanup: remove unused _debug_station_level ------------------------------------------------------------------------ r16636 | smatz | 2009-06-23 20:32:51 +0000 (Tue, 23 Jun 2009) | 1 line -Codechange: no need to initialize already zeroed variables by zero in station and rs constructors, remove debug output ------------------------------------------------------------------------ r16635 | rubidium | 2009-06-23 20:29:59 +0000 (Tue, 23 Jun 2009) | 2 lines -Fix: a couple of MSVC 64 bits warnings ------------------------------------------------------------------------ r16634 | smatz | 2009-06-23 12:11:35 +0000 (Tue, 23 Jun 2009) | 1 line -Codechange: use Company::IsHumanID() instead of IsHumanCompany() ------------------------------------------------------------------------ r16633 | smatz | 2009-06-23 10:44:46 +0000 (Tue, 23 Jun 2009) | 1 line -Codechange: remove checks for consistency of newpool ------------------------------------------------------------------------ r16632 | smatz | 2009-06-23 09:52:26 +0000 (Tue, 23 Jun 2009) | 1 line -Codechange: rename Town::flags12 to Town::flags ------------------------------------------------------------------------ r16631 | smatz | 2009-06-23 09:46:29 +0000 (Tue, 23 Jun 2009) | 1 line -Fix (r1826)(r1881)(r9613): loading of some town data from old savegames was broken ------------------------------------------------------------------------ r16630 | glx | 2009-06-23 00:04:37 +0000 (Tue, 23 Jun 2009) | 1 line -Fix (r16629): forgot a continue ------------------------------------------------------------------------ r16629 | glx | 2009-06-22 23:57:33 +0000 (Mon, 22 Jun 2009) | 3 lines -Fix: depend hang on solaris -Fix: depend do not append delimiter string before deps for non empty files -Add: support for -s option (starting string delimiter) ------------------------------------------------------------------------ r16628 | smatz | 2009-06-22 23:15:27 +0000 (Mon, 22 Jun 2009) | 1 line -Codechange: remove one gcc2 hack ------------------------------------------------------------------------ r16627 | smatz | 2009-06-22 22:04:48 +0000 (Mon, 22 Jun 2009) | 1 line -Fix: warning about comparing signed and unsigned types ------------------------------------------------------------------------ r16626 | rubidium | 2009-06-22 20:38:10 +0000 (Mon, 22 Jun 2009) | 2 lines -Change: split the part of config.lib that generates the 'warning' CFLAGS into a function and use that function to set the right 'warning' CFLAGS for both the host and build compiler, i.e. also let GCC warn for strgen, depend and endian_check. ------------------------------------------------------------------------ r16625 | rubidium | 2009-06-22 20:35:14 +0000 (Mon, 22 Jun 2009) | 2 lines -Fix: unsigned vs signed warning in strgen ------------------------------------------------------------------------ r16624 | rubidium | 2009-06-22 20:33:15 +0000 (Mon, 22 Jun 2009) | 2 lines -Fix: depend was compiled with the same compiler as the OpenTTD binary, causing depend to silently fail during cross-compiles ------------------------------------------------------------------------ r16623 | rubidium | 2009-06-22 20:22:04 +0000 (Mon, 22 Jun 2009) | 2 lines -Change: remove CC_CFLAGS as we're not using a C compiler anywhere at all ------------------------------------------------------------------------ r16622 | rubidium | 2009-06-22 19:09:48 +0000 (Mon, 22 Jun 2009) | 2 lines -Fix: {CARGO} only consumes 1 argument ------------------------------------------------------------------------