------------------------------------------------------------------------ r16434 | rubidium | 2009-05-26 15:46:24 +0000 (Tue, 26 May 2009) | 2 lines -Cleanup: remove some dead code; primarily stuff that can't be reached like break after returns or break after functions that never return (i.e. NOT_REACHED) ------------------------------------------------------------------------ r16433 | yexo | 2009-05-26 13:29:01 +0000 (Tue, 26 May 2009) | 1 line -Codechange: Remove most of CmdSetAutoreplace and replace it with calls to CmdChangeCompanySetting ------------------------------------------------------------------------ r16432 | smatz | 2009-05-26 13:16:58 +0000 (Tue, 26 May 2009) | 1 line -Feature(tte): use 'scrollto x y' in console to scroll to tile with given coordinates ------------------------------------------------------------------------ r16431 | yexo | 2009-05-26 12:53:34 +0000 (Tue, 26 May 2009) | 1 line -Fix (16429): Company settings can also be changed in multiplayer games ------------------------------------------------------------------------ r16430 | smatz | 2009-05-26 11:57:52 +0000 (Tue, 26 May 2009) | 1 line -Fix: crash when a company is deleted while a dropdown with company names is open ------------------------------------------------------------------------ r16429 | yexo | 2009-05-26 11:40:14 +0000 (Tue, 26 May 2009) | 1 line -Change: Make the company settings behave like all others settings: the default set in the main menu / config file is now really the default for a new company, and changing the value in game will no longer change the default for new companies. ------------------------------------------------------------------------ r16428 | rubidium | 2009-05-26 11:19:04 +0000 (Tue, 26 May 2009) | 2 lines -Codechange: use the less bloated SimpleTinyEnumT instead of TinyEnumT if the stuff provided by TinyEnumT but not SimpleTinyEnumT is not used. ------------------------------------------------------------------------ r16427 | rubidium | 2009-05-26 08:53:16 +0000 (Tue, 26 May 2009) | 2 lines -Codechange: replace a few magic numbers with an existing constant and unduplicate a few lines. ------------------------------------------------------------------------ r16426 | rubidium | 2009-05-26 08:51:33 +0000 (Tue, 26 May 2009) | 2 lines -Fix [FS#2921] (r16390): articulated parts got the wrong image assigned ------------------------------------------------------------------------ r16425 | yexo | 2009-05-25 21:55:47 +0000 (Mon, 25 May 2009) | 1 line -Change [FS#2869]: Stop an AI when it takes too long to initialize or load ------------------------------------------------------------------------ r16424 | smatz | 2009-05-25 19:30:37 +0000 (Mon, 25 May 2009) | 1 line -Codechange: warn about casting-out 'const' only when using gcc4+, older versions give many useless false positives ------------------------------------------------------------------------ r16422 | rubidium | 2009-05-24 21:09:00 +0000 (Sun, 24 May 2009) | 2 lines -Codechange: use const_cast for removing const and warn when const is (accidentally?) removed using C-style casts. ------------------------------------------------------------------------ r16421 | rubidium | 2009-05-24 20:29:04 +0000 (Sun, 24 May 2009) | 2 lines -Codechange: do not unnecessarily remove constness or unnecessarily add it. ------------------------------------------------------------------------ r16420 | rubidium | 2009-05-24 17:49:08 +0000 (Sun, 24 May 2009) | 2 lines -Fix [FS#2919]: don't allow content download via the console when there's no zlib as it's done for the GUI already ------------------------------------------------------------------------ r16419 | rubidium | 2009-05-24 17:34:39 +0000 (Sun, 24 May 2009) | 2 lines -Fix [FS#2916]: MSYS has two distinct ways to write paths. When calling external binaries it resolves paths which causes comparisons between a resolved and unresolved path. So always use the resolved path instead of the unresolved one. ------------------------------------------------------------------------ r16418 | frosch | 2009-05-24 17:23:24 +0000 (Sun, 24 May 2009) | 1 line -Fix: Resolve the company name for 'subsidy awarded'-news when the news are triggered, so it stays valid when the company bankrupts or is taken over. ------------------------------------------------------------------------ r16417 | translators | 2009-05-24 17:18:45 +0000 (Sun, 24 May 2009) | 5 lines -Update: WebTranslator2 update to 2009-05-24 17:18:38 icelandic - 31 fixed, 14 changed by scrooge (45) indonesian - 17 fixed by adjayanto (17) serbian - 84 fixed by etran (84) ------------------------------------------------------------------------ r16416 | frosch | 2009-05-24 16:52:42 +0000 (Sun, 24 May 2009) | 1 line -Fix [FS#2912]: Rework deleting of news when referenced vehicles/stations/industries are deleted. ------------------------------------------------------------------------ r16415 | smatz | 2009-05-24 16:28:33 +0000 (Sun, 24 May 2009) | 1 line -Fix (r13008): some 64bit architectures require size_t to be aligned at 8-byte boundary, ensure it for MemBlock ------------------------------------------------------------------------ r16414 | frosch | 2009-05-24 12:50:58 +0000 (Sun, 24 May 2009) | 1 line -Change: Make it harder to ignore/close important error messages. Esp. do not close them automatically after some time. ------------------------------------------------------------------------ r16413 | alberth | 2009-05-24 12:49:27 +0000 (Sun, 24 May 2009) | 1 line -Codechange: Allow leading/trailing whitespace and comma in newgrf parameters instead of treating them as invalid. ------------------------------------------------------------------------ r16412 | frosch | 2009-05-24 12:05:27 +0000 (Sun, 24 May 2009) | 1 line -Cleanup: Shuffle vehicle pointers in AddArticulatedParts(), and remove two of them. ------------------------------------------------------------------------ r16411 | frosch | 2009-05-24 11:39:35 +0000 (Sun, 24 May 2009) | 1 line -Fix (r16390): Building articulated roadvehicles caused infinite loop due to v->Next() pointing to v itself. ------------------------------------------------------------------------ r16410 | rubidium | 2009-05-24 09:35:46 +0000 (Sun, 24 May 2009) | 2 lines -Fix (r16307): don't assume the extension starts with the first '.', but with the last '.'. This way depend doesn't fail if there's a dot in your path, e.g. 'gcc-4.4'. ------------------------------------------------------------------------ r16409 | rubidium | 2009-05-23 22:40:14 +0000 (Sat, 23 May 2009) | 2 lines -Change: don't add empty lines/duplicates of the previous command to the console's history ------------------------------------------------------------------------ r16408 | frosch | 2009-05-23 22:24:09 +0000 (Sat, 23 May 2009) | 1 line -Codechange: Silence a pointless newgrf debug message. ------------------------------------------------------------------------ r16407 | smatz | 2009-05-23 19:43:09 +0000 (Sat, 23 May 2009) | 1 line -Fix [FS#2913]: set CargoPacket::source to INVALID_STATION when source station is deleted ------------------------------------------------------------------------ r16406 | smatz | 2009-05-23 19:26:00 +0000 (Sat, 23 May 2009) | 1 line -Codechange: constify parameters of CheckSubsidised() ------------------------------------------------------------------------ r16405 | alberth | 2009-05-23 18:06:29 +0000 (Sat, 23 May 2009) | 1 line -Codechange: Move widget drawing code to functions to allow re-use. ------------------------------------------------------------------------ r16404 | rubidium | 2009-05-23 16:39:55 +0000 (Sat, 23 May 2009) | 3 lines -Fix [FS#2911] (r16378): the number of spritegroups got halved when the new pool was added, which mean there weren't enough spritegroups when you have more than about a dozen ECS vectors. -Change: increase the spritegroup pool's maximum size to something more than the number of real sprites that OpenTTD can handle; for example ECS has about 30 spritegroups per real sprite. With the 'old' limit that would mean 'only' about 4000 real sprites worth of spritegroups could be loaded. ------------------------------------------------------------------------ r16403 | smatz | 2009-05-23 15:46:00 +0000 (Sat, 23 May 2009) | 1 line -Codechange: move code related to subsidies to separate file ------------------------------------------------------------------------ r16402 | rubidium | 2009-05-23 15:25:52 +0000 (Sat, 23 May 2009) | 2 lines -Codechange: make Resolve a function of SpriteGroup ------------------------------------------------------------------------ r16401 | yexo | 2009-05-23 15:23:41 +0000 (Sat, 23 May 2009) | 1 line -Fix (r16400): forgot to commit the changes to source.list (thanks SmatZ) ------------------------------------------------------------------------ r16400 | yexo | 2009-05-23 14:54:55 +0000 (Sat, 23 May 2009) | 1 line -Add [NoAI]: add AISignList that can be used to get a list of valid signs. This makes AISign::GetMaxSignID obsolete. ------------------------------------------------------------------------ r16399 | frosch | 2009-05-23 13:42:02 +0000 (Sat, 23 May 2009) | 1 line -Fix (r4540): Don't treat pointer values as integer. ------------------------------------------------------------------------ r16398 | rubidium | 2009-05-23 12:56:30 +0000 (Sat, 23 May 2009) | 2 lines -Feature: make NewGRF callbacks work again; honouring the 'features' of 0.3.2.1, which was released only 5 years ago. ------------------------------------------------------------------------ r16397 | rubidium | 2009-05-23 12:27:42 +0000 (Sat, 23 May 2009) | 2 lines -Codechange: move GetVehicleOrder/GetLastVehicleOrder into Vehicle ------------------------------------------------------------------------ r16396 | rubidium | 2009-05-23 12:13:42 +0000 (Sat, 23 May 2009) | 2 lines -Codechange: split NewGRF spritegroup into multiple subclasses instead of using a big union ------------------------------------------------------------------------ r16395 | smatz | 2009-05-23 11:13:43 +0000 (Sat, 23 May 2009) | 1 line -Fix (r16379): max sign ID can be higher than total number of signs ------------------------------------------------------------------------ r16394 | rubidium | 2009-05-23 09:10:56 +0000 (Sat, 23 May 2009) | 2 lines -Codechange: move (NewGRF) cache variables into a separate struct so (some vehicle related) NewGRF cache 'desyncs' can be tested easier. ------------------------------------------------------------------------ r16393 | rubidium | 2009-05-22 22:55:41 +0000 (Fri, 22 May 2009) | 2 lines -Codechange: move VehicleRail to Train. ------------------------------------------------------------------------ r16392 | rubidium | 2009-05-22 22:33:05 +0000 (Fri, 22 May 2009) | 2 lines -Codechange: move some variables (the ones that aren't caches) from VehicleRail to Train ------------------------------------------------------------------------ r16391 | rubidium | 2009-05-22 22:22:46 +0000 (Fri, 22 May 2009) | 2 lines -Codechange: use Train instead of Vehicle where appropriate. ------------------------------------------------------------------------ r16390 | rubidium | 2009-05-22 20:22:20 +0000 (Fri, 22 May 2009) | 2 lines -Codechange: move u.road to RoadVehicle. ------------------------------------------------------------------------ r16389 | rubidium | 2009-05-22 20:18:45 +0000 (Fri, 22 May 2009) | 2 lines -Codechange: use RoadVehicle instead of Vehicle where appropriate ------------------------------------------------------------------------ r16388 | rubidium | 2009-05-22 20:07:26 +0000 (Fri, 22 May 2009) | 2 lines -Codechange: move u.air to Aircraft ------------------------------------------------------------------------ r16387 | rubidium | 2009-05-22 20:03:26 +0000 (Fri, 22 May 2009) | 2 lines -Codechange: use Aircraft instead of Vehicle where appropriate ------------------------------------------------------------------------ r16386 | frosch | 2009-05-22 19:47:26 +0000 (Fri, 22 May 2009) | 1 line -Codechange: Move ShowAdditionalText() to build_vehicle_gui and make it static. ------------------------------------------------------------------------ r16385 | rubidium | 2009-05-22 18:57:11 +0000 (Fri, 22 May 2009) | 2 lines -Codechange: move u.disaster to DisasterVehicle. ------------------------------------------------------------------------ r16384 | rubidium | 2009-05-22 18:56:25 +0000 (Fri, 22 May 2009) | 2 lines -Codechange: move u.effect to EffectVehicle ------------------------------------------------------------------------ r16383 | frosch | 2009-05-22 18:44:22 +0000 (Fri, 22 May 2009) | 1 line -Fix/Change: Disable multitile houses with non-zero population on additional tiles as they cause desyncs and because the specs do not allow that either. ------------------------------------------------------------------------ r16382 | rubidium | 2009-05-22 18:17:20 +0000 (Fri, 22 May 2009) | 2 lines -Codechange: make GetVehicleTrackdir a member function of Vehicle. ------------------------------------------------------------------------ r16381 | translators | 2009-05-22 17:38:53 +0000 (Fri, 22 May 2009) | 9 lines -Update: WebTranslator2 update to 2009-05-22 17:38:42 brazilian_portuguese - 2 fixed by tucalipe (2) estonian - 2 fixed by kristjans (2) french - 2 fixed by glx (2) indonesian - 20 fixed by rindu (20) romanian - 4 fixed by CrystyB (2), kkmic (2) serbian - 229 fixed by etran (229) spanish - 2 fixed by eusebio (2) ------------------------------------------------------------------------ r16380 | smatz | 2009-05-22 15:39:22 +0000 (Fri, 22 May 2009) | 1 line -Codechange: rename pool.hpp to pool_type.hpp ------------------------------------------------------------------------ r16379 | smatz | 2009-05-22 15:23:47 +0000 (Fri, 22 May 2009) | 1 line -Codechange: remove GetNumTowns(), GetNumIndustries() and GetActiveCompanyCount(), use PoolItem::GetNumItems() instead ------------------------------------------------------------------------ r16378 | smatz | 2009-05-22 15:13:50 +0000 (Fri, 22 May 2009) | 1 line -Codechange: replace OldPool with simpler Pool. Compilation time, binary size and run time (with asserts disabled) should be improved ------------------------------------------------------------------------ r16377 | smatz | 2009-05-22 14:23:36 +0000 (Fri, 22 May 2009) | 1 line -Codechange: unify FOR_ALL_* macros, use separate index variable instead of var->index ------------------------------------------------------------------------ r16376 | smatz | 2009-05-22 13:53:14 +0000 (Fri, 22 May 2009) | 1 line -Codechange: Vehicle::Tick() now returns false if the vehicle was deleted ------------------------------------------------------------------------ r16375 | smatz | 2009-05-22 13:13:55 +0000 (Fri, 22 May 2009) | 1 line -Codechange: don't be afraid of deleting NULL pointers ------------------------------------------------------------------------ r16374 | peter1138 | 2009-05-22 12:05:28 +0000 (Fri, 22 May 2009) | 2 lines -Fix (r11622): Valid UTF-8 sequences between 0x20 and 0xFF should be allowed as is instead of being treated as control codes. ------------------------------------------------------------------------ r16373 | smatz | 2009-05-21 22:43:25 +0000 (Thu, 21 May 2009) | 1 line -Codechange: use () instead of (void) for functions without parameters ------------------------------------------------------------------------ r16372 | alberth | 2009-05-21 18:12:28 +0000 (Thu, 21 May 2009) | 1 line -Codechange: Simplify size calculations with a few helper functions. ------------------------------------------------------------------------ r16371 | alberth | 2009-05-21 17:45:12 +0000 (Thu, 21 May 2009) | 1 line -Codechange (r16367): Properly align comments. ------------------------------------------------------------------------ r16370 | alberth | 2009-05-21 16:26:38 +0000 (Thu, 21 May 2009) | 1 line -Doc: Improvements to the nested widgets documentation, added explanation about computations, fixed typo in param description. ------------------------------------------------------------------------ r16369 | alberth | 2009-05-21 16:14:04 +0000 (Thu, 21 May 2009) | 1 line -Codechange: Renaming ComputeMinimalSize() to SetupSmallestSize(), and AssignMinimalPosition() to AssignSizePosition(), they do not compute minimal size anymore. ------------------------------------------------------------------------ r16368 | alberth | 2009-05-21 16:00:52 +0000 (Thu, 21 May 2009) | 1 line -Codechange: Only leaf widgets use min_x and min_y. ------------------------------------------------------------------------ r16367 | alberth | 2009-05-21 15:48:27 +0000 (Thu, 21 May 2009) | 1 line -Codechange: Do not use min_x and min_y for storing smallest size to allow initialization more than once. ------------------------------------------------------------------------ r16366 | frosch | 2009-05-21 13:05:48 +0000 (Thu, 21 May 2009) | 1 line -Fix: Use a valid StringID as fall-back when undefined generic newgrf strings of vehicles are requested. ------------------------------------------------------------------------ r16363 | peter1138 | 2009-05-21 07:29:50 +0000 (Thu, 21 May 2009) | 2 lines -Fix: The previously selected newgrf station type was still remembered after switching to a different game without newstations enabled, preventing stations from being built. ------------------------------------------------------------------------ r16362 | translators | 2009-05-20 17:30:30 +0000 (Wed, 20 May 2009) | 11 lines -Update: WebTranslator2 update to 2009-05-20 17:30:16 catalan - 2 fixed by arnaullv (2) czech - 2 fixed by Hadez (2) dutch - 2 fixed by habell (2) finnish - 2 fixed by jpx_ (2) german - 2 fixed by planetmaker (2) hungarian - 2 fixed by oklmernok (2) italian - 2 fixed by lorenzodv (2) japanese - 20 fixed by ickoonite (20) turkish - 2 fixed by Emin (2) ------------------------------------------------------------------------ r16361 | rubidium | 2009-05-19 21:25:20 +0000 (Tue, 19 May 2009) | 2 lines -Fix: pointer incremented with wrong count ------------------------------------------------------------------------ r16360 | rubidium | 2009-05-19 21:20:14 +0000 (Tue, 19 May 2009) | 2 lines -Codechange: don't use _network_playas as a 'second' _local_company, but only as a storage location for the company you want to join in MP. ------------------------------------------------------------------------ r16359 | smatz | 2009-05-19 19:26:03 +0000 (Tue, 19 May 2009) | 1 line -Codechange: don't abuse company 0 when determining 'cost to clear land' in the LandInfoWindow ------------------------------------------------------------------------ r16358 | glx | 2009-05-19 17:04:42 +0000 (Tue, 19 May 2009) | 1 line -Fix (r16343): strdup doesn't like NULL ------------------------------------------------------------------------ r16357 | smatz | 2009-05-19 12:47:47 +0000 (Tue, 19 May 2009) | 1 line -Codechange: delete invalid depots in TTD savegames caused by improper SVXConverter conversions ------------------------------------------------------------------------