------------------------------------------------------------------------ r12837 | belugas | 2008-04-22 14:40:09 +0000 (Tue, 22 Apr 2008) | 1 line -Codechange: Alignment of widget array ------------------------------------------------------------------------ r12836 | rubidium | 2008-04-21 23:04:05 +0000 (Mon, 21 Apr 2008) | 2 lines -Fix: SunOS non-dedicated server compilation. ------------------------------------------------------------------------ r12824 | peter1138 | 2008-04-21 20:50:58 +0000 (Mon, 21 Apr 2008) | 2 lines -Codechange: Standardise routines for drawing vehicle images, using correct types and less duplication. ------------------------------------------------------------------------ r12820 | frosch | 2008-04-21 17:04:17 +0000 (Mon, 21 Apr 2008) | 1 line -Documentation: Mark callbacks as 8 or 15 bit in 'newgrf_callbacks.h'. ------------------------------------------------------------------------ r12819 | rubidium | 2008-04-21 14:33:33 +0000 (Mon, 21 Apr 2008) | 2 lines -Codechange: handle more NewGRFs in the same way as TTDP does it, i.e. testing the low bits for 0xFF or 0 instead of all bits. ------------------------------------------------------------------------ r12818 | rubidium | 2008-04-21 13:45:03 +0000 (Mon, 21 Apr 2008) | 2 lines -Codechange: make callbacks 31 and 37 behave like they do in TTDP according to frosch's survey. ------------------------------------------------------------------------ r12817 | rubidium | 2008-04-21 11:29:01 +0000 (Mon, 21 Apr 2008) | 2 lines -Feature: the ability to play NewGRF sounds for industries and stations. ------------------------------------------------------------------------ r12816 | rubidium | 2008-04-21 09:27:47 +0000 (Mon, 21 Apr 2008) | 2 lines -Fix: the cargo count in the performance rating window could be wrong. ------------------------------------------------------------------------ r12815 | rubidium | 2008-04-21 09:20:42 +0000 (Mon, 21 Apr 2008) | 2 lines -Codechange: reshuffle some variables in the CargoPacket struct saving 4 of 36 bytes with a 32 bit compiler and 8 of 48 bytes on 64 bit compiler per cargo packets. There are generally more cargopackets in game than vehicles. ------------------------------------------------------------------------ r12814 | rubidium | 2008-04-21 08:35:27 +0000 (Mon, 21 Apr 2008) | 2 lines -Codechange: reshuffle some variables in the Vehicle struct saving 20 bytes with a 32 bit compiler and 32 bytes on 64 bit compiler per vehicle. ------------------------------------------------------------------------ r12813 | rubidium | 2008-04-21 07:57:51 +0000 (Mon, 21 Apr 2008) | 2 lines -Fix [FS#1943]: the 'last built railtype' got reset too often. ------------------------------------------------------------------------ r12810 | glx | 2008-04-20 21:49:57 +0000 (Sun, 20 Apr 2008) | 1 line -Codechange: style and useless casts in CmdSetAutoReplace() ------------------------------------------------------------------------ r12809 | peter1138 | 2008-04-20 21:38:20 +0000 (Sun, 20 Apr 2008) | 2 lines -Fix (r1704): Possible out of bounds array access. ------------------------------------------------------------------------ r12808 | glx | 2008-04-20 21:36:41 +0000 (Sun, 20 Apr 2008) | 2 lines -Fix: enforce autorenew values range in command -Fix: typo in english.txt ------------------------------------------------------------------------ r12805 | rubidium | 2008-04-20 11:40:33 +0000 (Sun, 20 Apr 2008) | 2 lines -Codechange: remove some bit magic related to the news display states. Patch by cirdan. ------------------------------------------------------------------------ r12804 | rubidium | 2008-04-20 11:12:07 +0000 (Sun, 20 Apr 2008) | 2 lines -Codechange: move the effect vehicle handling out of vehicle.cpp ------------------------------------------------------------------------ r12803 | rubidium | 2008-04-20 10:13:54 +0000 (Sun, 20 Apr 2008) | 2 lines -Cleanup: rename SpecialVehicle to EffectVehicle to have a uniform naming of the thing instead of using both names for the same thing. ------------------------------------------------------------------------ r12802 | rubidium | 2008-04-20 09:43:30 +0000 (Sun, 20 Apr 2008) | 2 lines -Fix (r12800): do not commit from the src directory when you want to commit source.list too. ------------------------------------------------------------------------ r12801 | rubidium | 2008-04-20 08:43:31 +0000 (Sun, 20 Apr 2008) | 2 lines -Codechange: remove the dependency of function.h in town_map.h ------------------------------------------------------------------------ r12800 | rubidium | 2008-04-20 08:22:59 +0000 (Sun, 20 Apr 2008) | 2 lines -Codechange: move the animated tile related functions out of texteff.cpp (it isn't a text effect after all). Also remove a few more functions from functions. ------------------------------------------------------------------------ r12799 | peter1138 | 2008-04-19 23:34:42 +0000 (Sat, 19 Apr 2008) | 2 lines -Fix (r12798): Empty for-loop warnings from gcc 4.3+ ------------------------------------------------------------------------ r12798 | peter1138 | 2008-04-19 23:19:12 +0000 (Sat, 19 Apr 2008) | 2 lines -Feature: Add some support for NewGRF station animation. (Thanks to mart3p for samples and fixes) ------------------------------------------------------------------------ r12797 | bjarni | 2008-04-19 22:51:52 +0000 (Sat, 19 Apr 2008) | 2 lines -Codechange: [autoreplace] moved wagon removal to a function of it's own ------------------------------------------------------------------------ r12796 | rubidium | 2008-04-19 21:51:05 +0000 (Sat, 19 Apr 2008) | 2 lines -Fix: the dedicated blitter did segfault too, like the null blitter did. ------------------------------------------------------------------------ r12795 | rubidium | 2008-04-19 21:23:42 +0000 (Sat, 19 Apr 2008) | 2 lines -Fix [FS#1938]: vehicles could break down during loading and keep loading. The intention of the break down code is not to break down when having zero speed, therefor break downs now do not happen when loading. ------------------------------------------------------------------------ r12794 | bjarni | 2008-04-19 19:01:57 +0000 (Sat, 19 Apr 2008) | 1 line -Doc: added missing doxygen comment in autoreplace_cmd.cpp ------------------------------------------------------------------------ r12793 | peter1138 | 2008-04-19 18:03:24 +0000 (Sat, 19 Apr 2008) | 2 lines -Codechange: Use enum values for station types instead of mysterious hex (ln) ------------------------------------------------------------------------ r12792 | bjarni | 2008-04-19 17:47:56 +0000 (Sat, 19 Apr 2008) | 3 lines -Codechange: [autoreplace] added a function to figure out if a replacement is needed and if so, to which EngineID It's designed to save a bit of CPU time, specially if the replacement isn't buildable (think autorenew of old vehicle) ------------------------------------------------------------------------ r12791 | bjarni | 2008-04-19 15:14:20 +0000 (Sat, 19 Apr 2008) | 3 lines -Codechange: [autoreplace] Added a flag parameter (listens for DC_EXEC and DC_QUERY_COST) and included more info when returning CommandCost This allowed cleaning up the code in MaybeReplaceVehicle() ------------------------------------------------------------------------ r12790 | rubidium | 2008-04-19 13:28:48 +0000 (Sat, 19 Apr 2008) | 2 lines -Codechange: code style fixes. Patch by Alberth. ------------------------------------------------------------------------ r12789 | rubidium | 2008-04-19 13:17:19 +0000 (Sat, 19 Apr 2008) | 2 lines -Codechange: rename AssignWindowViewport to InitializeWindowViewport because the viewport is now part of the window struct. Patch by Alberth. ------------------------------------------------------------------------ r12788 | rubidium | 2008-04-19 13:07:37 +0000 (Sat, 19 Apr 2008) | 2 lines -Codechange: unduplicate some vehicle GUI code. Patch by Alberth. ------------------------------------------------------------------------ r12787 | rubidium | 2008-04-19 13:05:05 +0000 (Sat, 19 Apr 2008) | 2 lines -Documentation: add/fix documentation of some functions. Patch by Alberth. ------------------------------------------------------------------------ r12786 | rubidium | 2008-04-19 13:04:29 +0000 (Sat, 19 Apr 2008) | 2 lines -Change: remove more function from functions.h. ------------------------------------------------------------------------ r12785 | rubidium | 2008-04-19 12:50:02 +0000 (Sat, 19 Apr 2008) | 2 lines -Codechange: put all news-type related constants in the same array. Patch by cirdan. ------------------------------------------------------------------------ r12784 | rubidium | 2008-04-19 10:18:38 +0000 (Sat, 19 Apr 2008) | 2 lines -Codechange: handle the asynchronious save 'handlers' in saveload.cpp instead of openttd.cpp. ------------------------------------------------------------------------ r12783 | rubidium | 2008-04-19 08:34:03 +0000 (Sat, 19 Apr 2008) | 2 lines -Codechange: do not statically allocate the 'temporary map3 array' in the oldloader. ------------------------------------------------------------------------ r12782 | rubidium | 2008-04-19 08:21:55 +0000 (Sat, 19 Apr 2008) | 2 lines -Codechange: remove some functions from functions.h and do not statically 'waste' memory when the old name array is not needed anymore. ------------------------------------------------------------------------ r12780 | rubidium | 2008-04-18 23:32:10 +0000 (Fri, 18 Apr 2008) | 2 lines -Fix: the null blitter did segfault. ------------------------------------------------------------------------ r12779 | rubidium | 2008-04-18 21:49:38 +0000 (Fri, 18 Apr 2008) | 2 lines -Codechange: remove a few constants from openttd.h. ------------------------------------------------------------------------ r12778 | smatz | 2008-04-18 21:38:36 +0000 (Fri, 18 Apr 2008) | 1 line -Codechange: add the NORETURN attribute to *allocError() functions ------------------------------------------------------------------------ r12777 | smatz | 2008-04-18 21:33:21 +0000 (Fri, 18 Apr 2008) | 1 line -Codechange: rename fatal() and error() in strgen, so it can always have the NORETURN attribute ------------------------------------------------------------------------ r12776 | egladil | 2008-04-18 21:21:25 +0000 (Fri, 18 Apr 2008) | 1 line -Fix: [OSX] In some rare cases when using an uncalibrated monitor the system colour space could not be retrieved. Show an error when this happens instead of just trying an assertion. ------------------------------------------------------------------------ r12773 | rubidium | 2008-04-18 19:26:52 +0000 (Fri, 18 Apr 2008) | 2 lines -Codechange: replace some magic numbers with enums. ------------------------------------------------------------------------ r12772 | rubidium | 2008-04-18 17:53:06 +0000 (Fri, 18 Apr 2008) | 2 lines -Codechange: some vehicle.cpp coding style. ------------------------------------------------------------------------ r12771 | rubidium | 2008-04-18 16:51:54 +0000 (Fri, 18 Apr 2008) | 2 lines -Codechange: remove more from variables.h. ------------------------------------------------------------------------ r12770 | glx | 2008-04-18 16:20:04 +0000 (Fri, 18 Apr 2008) | 1 line -Add: check for missing (forgotten) header files in the generate.vbs script. ------------------------------------------------------------------------ r12769 | rubidium | 2008-04-18 15:18:16 +0000 (Fri, 18 Apr 2008) | 2 lines -Codechange: some coding style cleanups. ------------------------------------------------------------------------ r12768 | rubidium | 2008-04-18 15:13:45 +0000 (Fri, 18 Apr 2008) | 2 lines -Codechange: move the statusbar GUI to it's own file. ------------------------------------------------------------------------ r12767 | rubidium | 2008-04-18 15:11:39 +0000 (Fri, 18 Apr 2008) | 2 lines -Codechange: merge all main toolbar related functions into a single file instead of scattering the functionality over several files. ------------------------------------------------------------------------ r12766 | rubidium | 2008-04-18 10:58:11 +0000 (Fri, 18 Apr 2008) | 2 lines -Add: sorting by road vehicle/train length. Based on a patch by Sir Bob. ------------------------------------------------------------------------ r12765 | rubidium | 2008-04-18 10:16:51 +0000 (Fri, 18 Apr 2008) | 2 lines -Codechange: move some stuff out of variables.h that required including other headers in variables.h. ------------------------------------------------------------------------ r12764 | rubidium | 2008-04-18 09:49:23 +0000 (Fri, 18 Apr 2008) | 2 lines -Add: check for missing (forgotten) header files in the generate script. ------------------------------------------------------------------------ r12763 | rubidium | 2008-04-18 09:40:00 +0000 (Fri, 18 Apr 2008) | 2 lines -Fix: some headers were missing/still included in the MSVC project files. ------------------------------------------------------------------------ r12762 | rubidium | 2008-04-18 04:54:09 +0000 (Fri, 18 Apr 2008) | 2 lines -Fix: tabs after the first non-tab character are generally not okay (or lines starting with a space and then tabs). ------------------------------------------------------------------------ r12761 | rubidium | 2008-04-18 04:37:06 +0000 (Fri, 18 Apr 2008) | 2 lines -Codechange: lots of minor whitespace coding style fixes around operators. ------------------------------------------------------------------------ r12760 | belugas | 2008-04-18 03:20:59 +0000 (Fri, 18 Apr 2008) | 1 line -Fix(r12759): Remove a now useless comment ------------------------------------------------------------------------ r12759 | belugas | 2008-04-18 03:17:22 +0000 (Fri, 18 Apr 2008) | 1 line -Fix(r12358): There is no need to mask callback result for pre-version7 since CBID_INDTILE_SHAPE_CHECK (cb2F) is really 15 bits. ------------------------------------------------------------------------ r12758 | belugas | 2008-04-18 01:35:17 +0000 (Fri, 18 Apr 2008) | 1 line -Fix(r4712, r12745): Use a bool when it's about boolean evaluation. a TileIndex is hardly a bool, of course of course. Thanks for good old MSVC warnings. ------------------------------------------------------------------------ r12757 | rubidium | 2008-04-17 21:21:01 +0000 (Thu, 17 Apr 2008) | 2 lines -Codechange: move all cheat related stuff from all over the place to a single location. ------------------------------------------------------------------------ r12756 | smatz | 2008-04-17 20:03:28 +0000 (Thu, 17 Apr 2008) | 1 line -Cleanup: variable scope and coding style in station* ------------------------------------------------------------------------ r12755 | glx | 2008-04-17 19:53:13 +0000 (Thu, 17 Apr 2008) | 1 line -Fix (r12706): aborting map generation was not properly handled ------------------------------------------------------------------------ r12754 | rubidium | 2008-04-17 19:10:30 +0000 (Thu, 17 Apr 2008) | 2 lines -Codechange: split depot.h into depot_map.h, depot_func.h and depot_base.h and remove quite a lot of unneeded (before this) includes of depot.h. ------------------------------------------------------------------------ r12753 | smatz | 2008-04-17 18:24:45 +0000 (Thu, 17 Apr 2008) | 1 line -Codechange: do not use IsDepotTypeTile() where simpler function can be used ------------------------------------------------------------------------ r12752 | rubidium | 2008-04-17 18:12:53 +0000 (Thu, 17 Apr 2008) | 2 lines -Codechange: replace some magic constants in player_gui.cpp. Patch by Yexo. ------------------------------------------------------------------------ r12751 | rubidium | 2008-04-17 11:47:22 +0000 (Thu, 17 Apr 2008) | 2 lines -Codechange: do what has been done in r11862 in a different way so it uses less memory. ------------------------------------------------------------------------ r12750 | rubidium | 2008-04-17 11:25:12 +0000 (Thu, 17 Apr 2008) | 2 lines -Fix (r12749): viewport for industry new messages was not shown properly. ------------------------------------------------------------------------ r12749 | rubidium | 2008-04-17 09:42:44 +0000 (Thu, 17 Apr 2008) | 2 lines -Codechange: store the viewport information in the windows that have a viewport instead of one global array with a viewport for each window, even when they do not use the viewport. ------------------------------------------------------------------------ r12747 | peter1138 | 2008-04-17 06:53:52 +0000 (Thu, 17 Apr 2008) | 2 lines -Codechange: Add varaction retrieval of station animation frame ------------------------------------------------------------------------ r12746 | peter1138 | 2008-04-17 06:52:56 +0000 (Thu, 17 Apr 2008) | 2 lines -Codechange: Add map storage for station animation frame ------------------------------------------------------------------------ r12745 | smatz | 2008-04-17 00:44:20 +0000 (Thu, 17 Apr 2008) | 1 line -Codechange: a bit of naming conventions, introduce Is*DepotTile() ------------------------------------------------------------------------ r12741 | rubidium | 2008-04-16 21:06:21 +0000 (Wed, 16 Apr 2008) | 2 lines -Codechange: do not allocate the viewport drawer each time on the stack, but only once and reuse this. ------------------------------------------------------------------------ r12740 | rubidium | 2008-04-16 20:39:35 +0000 (Wed, 16 Apr 2008) | 2 lines -Codechange: use a vector instead of allocating memory in a byte array for ChildScreenSpriteToDraw. ------------------------------------------------------------------------ r12739 | rubidium | 2008-04-16 20:01:04 +0000 (Wed, 16 Apr 2008) | 2 lines -Codechange: use a vector instead of allocating memory in a byte array for ParentSpriteToDraw. ------------------------------------------------------------------------ r12738 | smatz | 2008-04-16 19:36:30 +0000 (Wed, 16 Apr 2008) | 1 line -Fix (r12736): some sprites could be left unsorted ------------------------------------------------------------------------ r12737 | peter1138 | 2008-04-16 19:01:09 +0000 (Wed, 16 Apr 2008) | 2 lines -Codechange: Replace vector with a cut down class to allocate space as necessary. This avoids copying data around for vector's push_back() function. ------------------------------------------------------------------------ r12736 | rubidium | 2008-04-16 18:28:05 +0000 (Wed, 16 Apr 2008) | 2 lines -Codechange: a (small) touch of coding style in viewport.cpp. ------------------------------------------------------------------------ r12735 | rubidium | 2008-04-16 14:18:15 +0000 (Wed, 16 Apr 2008) | 2 lines -Codechange: use a vector instead of allocating memory in a byte array for TileSpriteToDraw. ------------------------------------------------------------------------ r12734 | rubidium | 2008-04-16 14:15:00 +0000 (Wed, 16 Apr 2008) | 2 lines -Codechange: use a vector instead of allocating memory in a big byte array for StringSpriteToDraw. ------------------------------------------------------------------------ r12733 | belugas | 2008-04-16 03:05:56 +0000 (Wed, 16 Apr 2008) | 1 line -Codechange: Merge two more Widgets arrays (town views ) into one. ------------------------------------------------------------------------ r12731 | smatz | 2008-04-15 23:07:06 +0000 (Tue, 15 Apr 2008) | 1 line -Fix (r12726): copying a 16bit array into 32bit wouldn't work ------------------------------------------------------------------------ r12726 | rubidium | 2008-04-15 22:27:28 +0000 (Tue, 15 Apr 2008) | 2 lines -Fix [FS#1877]: overflow causing strange building behaviour in towns. ------------------------------------------------------------------------