------------------------------------------------------------------------ r12772 | rubidium | 2008-04-18 17:53:06 +0000 (Fri, 18 Apr 2008) | 2 lines -Codechange: some vehicle.cpp coding style. ------------------------------------------------------------------------ r12771 | rubidium | 2008-04-18 16:51:54 +0000 (Fri, 18 Apr 2008) | 2 lines -Codechange: remove more from variables.h. ------------------------------------------------------------------------ r12770 | glx | 2008-04-18 16:20:04 +0000 (Fri, 18 Apr 2008) | 1 line -Add: check for missing (forgotten) header files in the generate.vbs script. ------------------------------------------------------------------------ r12769 | rubidium | 2008-04-18 15:18:16 +0000 (Fri, 18 Apr 2008) | 2 lines -Codechange: some coding style cleanups. ------------------------------------------------------------------------ r12768 | rubidium | 2008-04-18 15:13:45 +0000 (Fri, 18 Apr 2008) | 2 lines -Codechange: move the statusbar GUI to it's own file. ------------------------------------------------------------------------ r12767 | rubidium | 2008-04-18 15:11:39 +0000 (Fri, 18 Apr 2008) | 2 lines -Codechange: merge all main toolbar related functions into a single file instead of scattering the functionality over several files. ------------------------------------------------------------------------ r12766 | rubidium | 2008-04-18 10:58:11 +0000 (Fri, 18 Apr 2008) | 2 lines -Add: sorting by road vehicle/train length. Based on a patch by Sir Bob. ------------------------------------------------------------------------ r12765 | rubidium | 2008-04-18 10:16:51 +0000 (Fri, 18 Apr 2008) | 2 lines -Codechange: move some stuff out of variables.h that required including other headers in variables.h. ------------------------------------------------------------------------ r12764 | rubidium | 2008-04-18 09:49:23 +0000 (Fri, 18 Apr 2008) | 2 lines -Add: check for missing (forgotten) header files in the generate script. ------------------------------------------------------------------------ r12763 | rubidium | 2008-04-18 09:40:00 +0000 (Fri, 18 Apr 2008) | 2 lines -Fix: some headers were missing/still included in the MSVC project files. ------------------------------------------------------------------------ r12762 | rubidium | 2008-04-18 04:54:09 +0000 (Fri, 18 Apr 2008) | 2 lines -Fix: tabs after the first non-tab character are generally not okay (or lines starting with a space and then tabs). ------------------------------------------------------------------------ r12761 | rubidium | 2008-04-18 04:37:06 +0000 (Fri, 18 Apr 2008) | 2 lines -Codechange: lots of minor whitespace coding style fixes around operators. ------------------------------------------------------------------------ r12760 | belugas | 2008-04-18 03:20:59 +0000 (Fri, 18 Apr 2008) | 1 line -Fix(r12759): Remove a now useless comment ------------------------------------------------------------------------ r12759 | belugas | 2008-04-18 03:17:22 +0000 (Fri, 18 Apr 2008) | 1 line -Fix(r12358): There is no need to mask callback result for pre-version7 since CBID_INDTILE_SHAPE_CHECK (cb2F) is really 15 bits. ------------------------------------------------------------------------ r12758 | belugas | 2008-04-18 01:35:17 +0000 (Fri, 18 Apr 2008) | 1 line -Fix(r4712, r12745): Use a bool when it's about boolean evaluation. a TileIndex is hardly a bool, of course of course. Thanks for good old MSVC warnings. ------------------------------------------------------------------------ r12757 | rubidium | 2008-04-17 21:21:01 +0000 (Thu, 17 Apr 2008) | 2 lines -Codechange: move all cheat related stuff from all over the place to a single location. ------------------------------------------------------------------------ r12756 | smatz | 2008-04-17 20:03:28 +0000 (Thu, 17 Apr 2008) | 1 line -Cleanup: variable scope and coding style in station* ------------------------------------------------------------------------ r12755 | glx | 2008-04-17 19:53:13 +0000 (Thu, 17 Apr 2008) | 1 line -Fix (r12706): aborting map generation was not properly handled ------------------------------------------------------------------------ r12754 | rubidium | 2008-04-17 19:10:30 +0000 (Thu, 17 Apr 2008) | 2 lines -Codechange: split depot.h into depot_map.h, depot_func.h and depot_base.h and remove quite a lot of unneeded (before this) includes of depot.h. ------------------------------------------------------------------------ r12753 | smatz | 2008-04-17 18:24:45 +0000 (Thu, 17 Apr 2008) | 1 line -Codechange: do not use IsDepotTypeTile() where simpler function can be used ------------------------------------------------------------------------ r12752 | rubidium | 2008-04-17 18:12:53 +0000 (Thu, 17 Apr 2008) | 2 lines -Codechange: replace some magic constants in player_gui.cpp. Patch by Yexo. ------------------------------------------------------------------------ r12751 | rubidium | 2008-04-17 11:47:22 +0000 (Thu, 17 Apr 2008) | 2 lines -Codechange: do what has been done in r11862 in a different way so it uses less memory. ------------------------------------------------------------------------ r12750 | rubidium | 2008-04-17 11:25:12 +0000 (Thu, 17 Apr 2008) | 2 lines -Fix (r12749): viewport for industry new messages was not shown properly. ------------------------------------------------------------------------ r12749 | rubidium | 2008-04-17 09:42:44 +0000 (Thu, 17 Apr 2008) | 2 lines -Codechange: store the viewport information in the windows that have a viewport instead of one global array with a viewport for each window, even when they do not use the viewport. ------------------------------------------------------------------------ r12747 | peter1138 | 2008-04-17 06:53:52 +0000 (Thu, 17 Apr 2008) | 2 lines -Codechange: Add varaction retrieval of station animation frame ------------------------------------------------------------------------ r12746 | peter1138 | 2008-04-17 06:52:56 +0000 (Thu, 17 Apr 2008) | 2 lines -Codechange: Add map storage for station animation frame ------------------------------------------------------------------------ r12745 | smatz | 2008-04-17 00:44:20 +0000 (Thu, 17 Apr 2008) | 1 line -Codechange: a bit of naming conventions, introduce Is*DepotTile() ------------------------------------------------------------------------ r12741 | rubidium | 2008-04-16 21:06:21 +0000 (Wed, 16 Apr 2008) | 2 lines -Codechange: do not allocate the viewport drawer each time on the stack, but only once and reuse this. ------------------------------------------------------------------------ r12740 | rubidium | 2008-04-16 20:39:35 +0000 (Wed, 16 Apr 2008) | 2 lines -Codechange: use a vector instead of allocating memory in a byte array for ChildScreenSpriteToDraw. ------------------------------------------------------------------------ r12739 | rubidium | 2008-04-16 20:01:04 +0000 (Wed, 16 Apr 2008) | 2 lines -Codechange: use a vector instead of allocating memory in a byte array for ParentSpriteToDraw. ------------------------------------------------------------------------ r12738 | smatz | 2008-04-16 19:36:30 +0000 (Wed, 16 Apr 2008) | 1 line -Fix (r12736): some sprites could be left unsorted ------------------------------------------------------------------------ r12737 | peter1138 | 2008-04-16 19:01:09 +0000 (Wed, 16 Apr 2008) | 2 lines -Codechange: Replace vector with a cut down class to allocate space as necessary. This avoids copying data around for vector's push_back() function. ------------------------------------------------------------------------ r12736 | rubidium | 2008-04-16 18:28:05 +0000 (Wed, 16 Apr 2008) | 2 lines -Codechange: a (small) touch of coding style in viewport.cpp. ------------------------------------------------------------------------ r12735 | rubidium | 2008-04-16 14:18:15 +0000 (Wed, 16 Apr 2008) | 2 lines -Codechange: use a vector instead of allocating memory in a byte array for TileSpriteToDraw. ------------------------------------------------------------------------ r12734 | rubidium | 2008-04-16 14:15:00 +0000 (Wed, 16 Apr 2008) | 2 lines -Codechange: use a vector instead of allocating memory in a big byte array for StringSpriteToDraw. ------------------------------------------------------------------------ r12733 | belugas | 2008-04-16 03:05:56 +0000 (Wed, 16 Apr 2008) | 1 line -Codechange: Merge two more Widgets arrays (town views ) into one. ------------------------------------------------------------------------ r12731 | smatz | 2008-04-15 23:07:06 +0000 (Tue, 15 Apr 2008) | 1 line -Fix (r12726): copying a 16bit array into 32bit wouldn't work ------------------------------------------------------------------------ r12726 | rubidium | 2008-04-15 22:27:28 +0000 (Tue, 15 Apr 2008) | 2 lines -Fix [FS#1877]: overflow causing strange building behaviour in towns. ------------------------------------------------------------------------ r12717 | frosch | 2008-04-15 13:10:01 +0000 (Tue, 15 Apr 2008) | 1 line -Fix (r11107): Check the TILE_NOT_SLOPED flag of the _north_ tile of multi-tile houses to decide if autoslope is allowed. ------------------------------------------------------------------------ r12716 | frosch | 2008-04-15 12:25:35 +0000 (Tue, 15 Apr 2008) | 1 line -Fix: Do not compare StationIDs with DepotIDs or WaypointIDs. ------------------------------------------------------------------------ r12714 | rubidium | 2008-04-14 23:26:31 +0000 (Mon, 14 Apr 2008) | 2 lines -Fix [FS#1904]: do not move windows below the toolbar on resizes unless they would go behind the toolbar. ------------------------------------------------------------------------ r12713 | rubidium | 2008-04-14 21:49:13 +0000 (Mon, 14 Apr 2008) | 2 lines -Fix: misleading comment. Patch by Yexo. ------------------------------------------------------------------------ r12711 | glx | 2008-04-14 20:48:17 +0000 (Mon, 14 Apr 2008) | 1 line -Codechange: remove unneeded loops ------------------------------------------------------------------------ r12709 | rubidium | 2008-04-14 20:31:21 +0000 (Mon, 14 Apr 2008) | 2 lines -Feature: show the last joined server. Heavily based on a patch by Yexo. ------------------------------------------------------------------------ r12708 | glx | 2008-04-14 20:14:32 +0000 (Mon, 14 Apr 2008) | 1 line -Fix (FS#1914): increase default sound buffer size only for vista ------------------------------------------------------------------------ r12707 | rubidium | 2008-04-14 20:00:28 +0000 (Mon, 14 Apr 2008) | 2 lines -Fix: do not crash very hard on unrecognised savegames, just go back to the intro menu instead. ------------------------------------------------------------------------ r12706 | rubidium | 2008-04-14 19:54:33 +0000 (Mon, 14 Apr 2008) | 2 lines -Merge: the thread rewrite from NoAI. The rewrite makes the threading we have better extendable. ------------------------------------------------------------------------ r12705 | belugas | 2008-04-14 17:50:15 +0000 (Mon, 14 Apr 2008) | 1 line -Codechange: enumification of some more widgets ------------------------------------------------------------------------ r12704 | belugas | 2008-04-14 17:06:36 +0000 (Mon, 14 Apr 2008) | 1 line -Codechange: code style cleanup, mostly switch case alignment ------------------------------------------------------------------------ r12701 | rubidium | 2008-04-14 13:23:16 +0000 (Mon, 14 Apr 2008) | 2 lines -Codechange: do not explicitly number a widget enum because that causes a big diff when adding something. ------------------------------------------------------------------------ r12700 | maedhros | 2008-04-14 12:42:01 +0000 (Mon, 14 Apr 2008) | 1 line -Cleanup (r12699): Remove an unused string. ------------------------------------------------------------------------ r12699 | maedhros | 2008-04-14 12:40:09 +0000 (Mon, 14 Apr 2008) | 1 line -Codechange: Unify the order drawing code for orders and timetables. ------------------------------------------------------------------------ r12698 | rubidium | 2008-04-14 07:08:43 +0000 (Mon, 14 Apr 2008) | 2 lines -Codechange: skip orders to stations that do not have a train part anymore, just like is done for road vehicles and ships. ------------------------------------------------------------------------ r12697 | rubidium | 2008-04-13 22:25:18 +0000 (Sun, 13 Apr 2008) | 2 lines -Codechange: give signs_gui.cpp a touch of coding style. ------------------------------------------------------------------------ r12696 | rubidium | 2008-04-13 19:46:26 +0000 (Sun, 13 Apr 2008) | 2 lines -Fix: loading ancient savegames could result in invalid orders in order lists with all related problems. ------------------------------------------------------------------------ r12695 | rubidium | 2008-04-13 19:25:14 +0000 (Sun, 13 Apr 2008) | 2 lines -Codechange: only allocate window structs when needed. Based on a patch by Alberth. ------------------------------------------------------------------------ r12694 | rubidium | 2008-04-13 19:06:30 +0000 (Sun, 13 Apr 2008) | 2 lines -Fix: do not call the mouse over callback on already deleted windows. ------------------------------------------------------------------------ r12693 | rubidium | 2008-04-13 19:01:26 +0000 (Sun, 13 Apr 2008) | 2 lines -Documentation: add some documentation to some window related stuff. Based on a patch by Albert. ------------------------------------------------------------------------ r12692 | rubidium | 2008-04-13 18:59:32 +0000 (Sun, 13 Apr 2008) | 2 lines -Codechange: swap to functions to remove a function declaration. ------------------------------------------------------------------------ r12691 | glx | 2008-04-13 17:59:43 +0000 (Sun, 13 Apr 2008) | 1 line -Fix (r12459): all company related news displayed the 'company is in trouble' message ------------------------------------------------------------------------ r12690 | smatz | 2008-04-13 17:27:36 +0000 (Sun, 13 Apr 2008) | 1 line -Cleanup: remove unused table from tgp.cpp ------------------------------------------------------------------------ r12689 | rubidium | 2008-04-13 16:54:19 +0000 (Sun, 13 Apr 2008) | 2 lines -Feature: non-stop(or rather no non-stop) and via orders for road vehicles. ------------------------------------------------------------------------ r12688 | rubidium | 2008-04-13 16:50:55 +0000 (Sun, 13 Apr 2008) | 2 lines -Change: make default non-stop for depot/waypoint orders the same as for stations. ------------------------------------------------------------------------ r12687 | rubidium | 2008-04-13 16:48:28 +0000 (Sun, 13 Apr 2008) | 2 lines -Change: show when a vehicle is actually leaving the station instead of loading/unloading. ------------------------------------------------------------------------ r12686 | glx | 2008-04-13 15:07:36 +0000 (Sun, 13 Apr 2008) | 1 line -Fix: MSVC signed/unsigned warning ------------------------------------------------------------------------ r12685 | smatz | 2008-04-13 14:19:08 +0000 (Sun, 13 Apr 2008) | 1 line -Codechange: DebugDumpCommands() couldn't be inlined, define it as a macro instead ------------------------------------------------------------------------ r12684 | rubidium | 2008-04-13 11:35:57 +0000 (Sun, 13 Apr 2008) | 2 lines -Fix [FS#1891]: manually given service at depot order is not forgotten anymore when autoservice 'interferes'. ------------------------------------------------------------------------ r12683 | rubidium | 2008-04-13 11:15:48 +0000 (Sun, 13 Apr 2008) | 2 lines -Fix [FS#1906]: in some cases a news messages would not be shown. ------------------------------------------------------------------------ r12682 | rubidium | 2008-04-13 10:32:29 +0000 (Sun, 13 Apr 2008) | 2 lines -Fix [FS#1920]: removing road pieces from a town gave you twice the intended penalty. ------------------------------------------------------------------------ r12681 | rubidium | 2008-04-13 10:26:39 +0000 (Sun, 13 Apr 2008) | 2 lines -Fix [FS#1921]: aircraft stopping mid-air. ------------------------------------------------------------------------ r12679 | belugas | 2008-04-13 01:51:12 +0000 (Sun, 13 Apr 2008) | 1 line -Codechange : a little bit of widget enumification ------------------------------------------------------------------------ r12678 | rubidium | 2008-04-12 22:40:56 +0000 (Sat, 12 Apr 2008) | 2 lines -Fix [FS#1918]: when a road vehicle has a tram only stop multiple times in a row in it's orders, only the first one would be skipped. ------------------------------------------------------------------------ r12676 | peter1138 | 2008-04-12 22:19:34 +0000 (Sat, 12 Apr 2008) | 2 lines -Codechange: Reinstate colour selection buses, absent since r6455. ------------------------------------------------------------------------ r12675 | peter1138 | 2008-04-12 22:12:27 +0000 (Sat, 12 Apr 2008) | 2 lines -Codechange: Add support for custom drawing of drop down list items. ------------------------------------------------------------------------ r12674 | peter1138 | 2008-04-12 22:11:21 +0000 (Sat, 12 Apr 2008) | 2 lines -Fix [FS#1902]: Colour remaps on station sprites only worked for company colours. ------------------------------------------------------------------------ r12672 | peter1138 | 2008-04-12 20:32:18 +0000 (Sat, 12 Apr 2008) | 2 lines -Codechange: Add support for variably-sized drop down list items. ------------------------------------------------------------------------ r12671 | smatz | 2008-04-12 20:15:57 +0000 (Sat, 12 Apr 2008) | 1 line -Fix (r12644): orders window of competitors' vehicles was missing a resizebox ------------------------------------------------------------------------ r12670 | rubidium | 2008-04-12 13:07:25 +0000 (Sat, 12 Apr 2008) | 2 lines -Add: unconditional/always order 'jump/skip' variable. ------------------------------------------------------------------------ r12669 | rubidium | 2008-04-12 12:51:16 +0000 (Sat, 12 Apr 2008) | 2 lines -Fix (r12667): crash when a vehicle has never been to a station and the load percentage conditional variable is evaluated. ------------------------------------------------------------------------ r12668 | rubidium | 2008-04-12 12:19:53 +0000 (Sat, 12 Apr 2008) | 2 lines -Fix (12667): swapping of variables went wrong. ------------------------------------------------------------------------ r12667 | rubidium | 2008-04-12 11:58:19 +0000 (Sat, 12 Apr 2008) | 2 lines -Feature: conditional 'skip/jump' orders. ------------------------------------------------------------------------ r12666 | rubidium | 2008-04-12 11:15:25 +0000 (Sat, 12 Apr 2008) | 2 lines -Fix: the time table GUI did not show some data in the correct manner. ------------------------------------------------------------------------ r12665 | rubidium | 2008-04-12 10:00:52 +0000 (Sat, 12 Apr 2008) | 2 lines -Codechange: make the internal speed <-> display speed conversions available to a bigger part of the code. ------------------------------------------------------------------------ r12664 | rubidium | 2008-04-12 09:59:58 +0000 (Sat, 12 Apr 2008) | 2 lines -Codechange: do not force the 'color' pointer to be non-NULL when trying to get the load percentage. ------------------------------------------------------------------------ r12663 | rubidium | 2008-04-11 21:19:03 +0000 (Fri, 11 Apr 2008) | 2 lines -Codechange: move the definition from 'order_d' to a more appropriate place and do not misuse it for the time table GUI. ------------------------------------------------------------------------ r12662 | belugas | 2008-04-11 18:00:51 +0000 (Fri, 11 Apr 2008) | 3 lines -Codechange: Comment-code style application ------------------------------------------------------------------------