------------------------------------------------------------------------ r12594 | smatz | 2008-04-06 16:49:02 +0000 (Sun, 06 Apr 2008) | 1 line -Codechange: move large functions from driver.h to driver.cpp to reduce binary size and compile time ------------------------------------------------------------------------ r12593 | rubidium | 2008-04-06 15:09:45 +0000 (Sun, 06 Apr 2008) | 2 lines -Codechange: hide Order's flags in most of the code. ------------------------------------------------------------------------ r12592 | rubidium | 2008-04-06 14:50:47 +0000 (Sun, 06 Apr 2008) | 2 lines -Fix (r12580): aircraft's go-to-depot handling is a mess, which assumes destination to be a station even when it did not set a destination yet. ------------------------------------------------------------------------ r12591 | smatz | 2008-04-06 14:50:37 +0000 (Sun, 06 Apr 2008) | 1 line -Codechange: move CommandCost accessors to header file, 8kB of binary size saved ------------------------------------------------------------------------ r12588 | rubidium | 2008-04-06 07:48:51 +0000 (Sun, 06 Apr 2008) | 2 lines -Codechange: do not access the destination of an order directly. ------------------------------------------------------------------------ r12587 | rubidium | 2008-04-06 07:22:26 +0000 (Sun, 06 Apr 2008) | 2 lines -Codechange: unduplicate some code in the Unpack*Order functions and move the 'normal' case Pack/Unpack to Order. ------------------------------------------------------------------------ r12586 | rubidium | 2008-04-06 07:07:21 +0000 (Sun, 06 Apr 2008) | 2 lines -Codechange: do not access an order's refit variables directly. ------------------------------------------------------------------------ r12585 | rubidium | 2008-04-05 23:46:01 +0000 (Sat, 05 Apr 2008) | 2 lines -Fix (r12584): assumption that assertions were enabled during compilation/testing was flawed. ------------------------------------------------------------------------ r12584 | rubidium | 2008-04-05 23:36:54 +0000 (Sat, 05 Apr 2008) | 2 lines -Codechange: do not access the order type directly. ------------------------------------------------------------------------ r12583 | rubidium | 2008-04-05 21:45:05 +0000 (Sat, 05 Apr 2008) | 2 lines -Codechange: make AssignOrder a class function of order. ------------------------------------------------------------------------ r12582 | rubidium | 2008-04-05 20:57:01 +0000 (Sat, 05 Apr 2008) | 2 lines -Codechange: move some (needlessly) static inlined functions from order_base.h to order_cmd.cpp. ------------------------------------------------------------------------ r12581 | rubidium | 2008-04-05 19:51:51 +0000 (Sat, 05 Apr 2008) | 2 lines -Fix (r12580): trains would not stop correctly on intermediate stations when non-stop was not enabled. ------------------------------------------------------------------------ r12580 | rubidium | 2008-04-05 15:30:15 +0000 (Sat, 05 Apr 2008) | 2 lines -Codechange: merge some logical related to non-stop orders. ------------------------------------------------------------------------ r12579 | smatz | 2008-04-05 12:30:48 +0000 (Sat, 05 Apr 2008) | 1 line -Change: reset cursor when the Plant trees GUI is opened ------------------------------------------------------------------------ r12578 | rubidium | 2008-04-05 12:01:34 +0000 (Sat, 05 Apr 2008) | 2 lines -Codechange: merge the aircrafts ProcessOrder too into the 'unified' ProcessOrder. ------------------------------------------------------------------------ r12577 | smatz | 2008-04-05 11:35:32 +0000 (Sat, 05 Apr 2008) | 1 line -Fix (r11547): the convert signal button disallowed signal dragging when the signal GUI was closed ------------------------------------------------------------------------ r12576 | smatz | 2008-04-05 11:27:50 +0000 (Sat, 05 Apr 2008) | 1 line -Feature(tte) [FS#337]: highlight vehicle chain when dragging in the group and depot GUI if appropriate ------------------------------------------------------------------------ r12575 | rubidium | 2008-04-05 10:55:50 +0000 (Sat, 05 Apr 2008) | 2 lines -Codechange: unduplicate Process*Orders for trains, ships and road vehicles. ------------------------------------------------------------------------ r12574 | rubidium | 2008-04-04 21:09:28 +0000 (Fri, 04 Apr 2008) | 2 lines -Fix: binding to a specific IP could cause OpenTTD to not register properly with the masterserver if one has multiple external interfaces. ------------------------------------------------------------------------ r12573 | smatz | 2008-04-04 20:34:09 +0000 (Fri, 04 Apr 2008) | 1 line -Codechange: use defined constants instead of numbers in math_func.hpp ------------------------------------------------------------------------ r12572 | smatz | 2008-04-04 20:03:49 +0000 (Fri, 04 Apr 2008) | 1 line -Fix (r12192): min() has 32bit arguments, clamping of 64bit values didn't work ------------------------------------------------------------------------ r12571 | rubidium | 2008-04-04 19:10:45 +0000 (Fri, 04 Apr 2008) | 2 lines -Fix: MorphOS misses INT16_MAX/INT16_MIN. ------------------------------------------------------------------------ r12570 | smatz | 2008-04-04 18:55:24 +0000 (Fri, 04 Apr 2008) | 1 line -Cleanup: further variable scope in road_gui.cpp ------------------------------------------------------------------------ r12569 | smatz | 2008-04-04 18:41:16 +0000 (Fri, 04 Apr 2008) | 1 line -Cleanup: variable scope and coding style in road*.cpp ------------------------------------------------------------------------ r12567 | rubidium | 2008-04-04 17:49:42 +0000 (Fri, 04 Apr 2008) | 2 lines -Codechange: follow up of r12566, remove the palette from trunk. ------------------------------------------------------------------------ r12565 | smatz | 2008-04-04 17:27:38 +0000 (Fri, 04 Apr 2008) | 1 line -Cleanup: variable scope in misc\*.cpp ------------------------------------------------------------------------ r12564 | smatz | 2008-04-04 16:52:29 +0000 (Fri, 04 Apr 2008) | 1 line -Fix: towns couldn't terraform when inflation rised terraform prices enough ------------------------------------------------------------------------ r12563 | smatz | 2008-04-04 16:32:27 +0000 (Fri, 04 Apr 2008) | 1 line -Cleanup: variable scope and a bit of coding style in landscape.cpp ------------------------------------------------------------------------ r12562 | smatz | 2008-04-04 15:48:15 +0000 (Fri, 04 Apr 2008) | 1 line -Cleanup: variable scope in terraform_cmd.cpp ------------------------------------------------------------------------ r12561 | smatz | 2008-04-04 15:10:54 +0000 (Fri, 04 Apr 2008) | 1 line -Fix: do not affect town rating change by the order in which we examine stations ------------------------------------------------------------------------ r12560 | smatz | 2008-04-04 14:53:06 +0000 (Fri, 04 Apr 2008) | 1 line -Cleanup: town_cmd.cpp and header files - variable scope and a bit of coding style ------------------------------------------------------------------------ r12558 | belugas | 2008-04-04 02:24:44 +0000 (Fri, 04 Apr 2008) | 1 line -Feature: subsidy window can now be resized. ------------------------------------------------------------------------ r12557 | smatz | 2008-04-04 00:06:51 +0000 (Fri, 04 Apr 2008) | 1 line -Cleanup: use MAX_PATH at two more places ------------------------------------------------------------------------ r12556 | smatz | 2008-04-03 23:52:43 +0000 (Thu, 03 Apr 2008) | 1 line -Fix (r6001): remove fences with fields when loading old savegames, looks better ------------------------------------------------------------------------ r12553 | smatz | 2008-04-03 22:31:57 +0000 (Thu, 03 Apr 2008) | 1 line -Fix (r11547): redraw the signal GUI when the signal drag density changes in the patch settings and vice versa ------------------------------------------------------------------------ r12550 | smatz | 2008-04-03 21:54:31 +0000 (Thu, 03 Apr 2008) | 1 line -Change: the signal GUI is now persistent - has the same data when it is reopened ------------------------------------------------------------------------ r12549 | smatz | 2008-04-03 21:01:01 +0000 (Thu, 03 Apr 2008) | 2 lines -Fix [FS#1900](r11547): respect type of selected signal when building more signals using the GUI -Fix: do not check patch settings but check if the Signal GUI window is open instead ------------------------------------------------------------------------ r12548 | smatz | 2008-04-03 20:00:07 +0000 (Thu, 03 Apr 2008) | 1 line -Cleanup: remove strings removed in r12547 from all language files ------------------------------------------------------------------------ r12547 | smatz | 2008-04-03 19:55:40 +0000 (Thu, 03 Apr 2008) | 1 line -Feature: invisibility options to make objects invisible instead of transparent ------------------------------------------------------------------------ r12546 | glx | 2008-04-03 16:16:52 +0000 (Thu, 03 Apr 2008) | 1 line -Fix: completely remove cases from Brazilian Portuguese translation ------------------------------------------------------------------------ r12545 | frosch | 2008-04-03 14:21:17 +0000 (Thu, 03 Apr 2008) | 1 line -Cleanup: Replace some tables of magic values with already existing functions. ------------------------------------------------------------------------ r12543 | miham | 2008-04-03 07:20:32 +0000 (Thu, 03 Apr 2008) | 16 lines -Update: WebTranslator2 update to 2008-04-03 08:42:55 brazilian_portuguese - 18 fixed by fukumori (18) bulgarian - 17 fixed by thetitan (17) catalan - 11 fixed by arnaullv (11) dutch - 19 fixed by habell (19) french - 11 fixed by glx (11) hungarian - 5 fixed by miham (5) icelandic - 24 fixed, 2 changed by scrooge (26) italian - 11 fixed, 1 changed by lorenzodv (12) korean - 17 fixed, 3 changed by leejaeuk5 (20) slovak - 18 fixed by lengyel (18) slovenian - 19 fixed by Necrolyte (19) swedish - 33 fixed by daishan (33) turkish - 18 fixed by jnmbk (18) ukrainian - 17 fixed by mad (17) ------------------------------------------------------------------------ r12542 | matthijs | 2008-04-02 16:20:30 +0000 (Wed, 02 Apr 2008) | 2 lines -Fix [Makefile]: Don't install scenarios into the current user's homedir when running 'make install', that is silly. Simply always install scenarios system wide instead. ------------------------------------------------------------------------ r12541 | frosch | 2008-04-02 14:13:15 +0000 (Wed, 02 Apr 2008) | 1 line -Codechange: Declare Slope enum as bit set, and remove some (then) unneeded casts. ------------------------------------------------------------------------ r12540 | frosch | 2008-04-02 13:57:25 +0000 (Wed, 02 Apr 2008) | 1 line -Codechange: Enumify some values in original pathfinder and remove an unused variable. ------------------------------------------------------------------------ r12537 | smatz | 2008-04-02 00:13:44 +0000 (Wed, 02 Apr 2008) | 1 line -Cleanup: comment newgrf_config.h a bit ------------------------------------------------------------------------ r12536 | rubidium | 2008-04-01 21:12:51 +0000 (Tue, 01 Apr 2008) | 2 lines -Codechange: some stack allocations were too large for NDS, so use the SmallStackSafeStackAlloc wrapper. Allocate on the stack by default and on the heap for NDS (or other devices that have a very small stack). ------------------------------------------------------------------------ r12535 | belugas | 2008-04-01 17:21:24 +0000 (Tue, 01 Apr 2008) | 2 lines -Fix: A little typo and 4 omissions on bridge sprites. ------------------------------------------------------------------------ r12534 | skidd13 | 2008-04-01 16:27:01 +0000 (Tue, 01 Apr 2008) | 2 lines -Feature: Add a new type of town road layouts - random for each town ------------------------------------------------------------------------ r12533 | frosch | 2008-04-01 15:03:59 +0000 (Tue, 01 Apr 2008) | 1 line -Cleanup: Remove some wizardry from default ai by using existings enums and helper functions. ------------------------------------------------------------------------ r12532 | frosch | 2008-04-01 14:47:57 +0000 (Tue, 01 Apr 2008) | 1 line -Cleanup: Replace two tables of magic values with already existing functions. ------------------------------------------------------------------------ r12531 | frosch | 2008-04-01 14:03:20 +0000 (Tue, 01 Apr 2008) | 1 line -Codechange: Rename some variables for consistency. ------------------------------------------------------------------------ r12516 | skidd13 | 2008-03-31 16:07:50 +0000 (Mon, 31 Mar 2008) | 2 lines -Revert r2583: Removed mersenne PRNG cause it is not used and won't be used in the future ------------------------------------------------------------------------ r12513 | skidd13 | 2008-03-31 15:10:24 +0000 (Mon, 31 Mar 2008) | 2 lines -Codechange: rename OriginalTileRandomiser something more descriptive ------------------------------------------------------------------------ r12501 | rubidium | 2008-03-31 07:25:49 +0000 (Mon, 31 Mar 2008) | 2 lines -Codechange: split signs.h. ------------------------------------------------------------------------ r12499 | rubidium | 2008-03-31 07:11:18 +0000 (Mon, 31 Mar 2008) | 2 lines -Codechange: some coding style tweaks for network_internal.h. ------------------------------------------------------------------------ r12498 | rubidium | 2008-03-31 07:03:35 +0000 (Mon, 31 Mar 2008) | 2 lines -Codechange: bring a little 'order' to openttd.cpp's includes and do not 'define' VARDEF for files that do not have them anymore. ------------------------------------------------------------------------ r12495 | rubidium | 2008-03-31 06:42:26 +0000 (Mon, 31 Mar 2008) | 2 lines -Codechange: reduce the dependency on newgrf_station.h (especially because newgrf_station.h includes a lot of stuff). ------------------------------------------------------------------------ r12490 | rubidium | 2008-03-31 00:17:39 +0000 (Mon, 31 Mar 2008) | 2 lines -Codechange: rename engine.h to engine_func.h and remove unneeded inclusions of engine.h and/or replace them with engine_type.h. ------------------------------------------------------------------------ r12489 | rubidium | 2008-03-31 00:06:17 +0000 (Mon, 31 Mar 2008) | 2 lines -Codechange: split station.h into station_base.h and station_func.h. ------------------------------------------------------------------------ r12488 | rubidium | 2008-03-30 23:24:18 +0000 (Sun, 30 Mar 2008) | 2 lines -Codechange: split order.h into order_base.h and order_func.h. ------------------------------------------------------------------------