------------------------------------------------------------------------ r11546 | belugas | 2007-12-01 14:04:16 +0000 (Sat, 01 Dec 2007) | 2 lines -Fix[FS#1496]: If ever the air/heli port is suddenly not available while the "chopper" is descending, just go back into flying. The code should have been better written, but in respect of newgrf_port branch, i prefer minimalist intervention ------------------------------------------------------------------------ r11545 | belugas | 2007-12-01 02:59:22 +0000 (Sat, 01 Dec 2007) | 1 line -Revert(r11543): The result is not what was expected. Looks like more work might be needed ------------------------------------------------------------------------ r11544 | glx | 2007-12-01 02:47:10 +0000 (Sat, 01 Dec 2007) | 1 line -Fix [FS#1501]: revert r11453 as it translated cargo when it should not ------------------------------------------------------------------------ r11543 | belugas | 2007-12-01 01:31:05 +0000 (Sat, 01 Dec 2007) | 2 lines -Codechange: Give a more adequate message when trying to place an industry required to be built over a house on any other type of tiles. In reference to FS#1492, and other "bugs" like that one ------------------------------------------------------------------------ r11542 | bjarni | 2007-11-30 14:49:13 +0000 (Fri, 30 Nov 2007) | 2 lines -Fix r11540: [OSX] presumed 10.3 style strings when using GetCurrentLocale nomatter what OSX the target was ------------------------------------------------------------------------ r11541 | bjarni | 2007-11-30 14:42:16 +0000 (Fri, 30 Nov 2007) | 3 lines -Fix: [OSX] detect statvfs at runtime (based on OSX version) instead of compile time This should prevent a crash on OSX 10.3 with the precompiled binaries (in the load/save windows) ------------------------------------------------------------------------ r11540 | bjarni | 2007-11-30 13:26:24 +0000 (Fri, 30 Nov 2007) | 2 lines -Fix: [OSX] Don't try to compile the quartz video driver on OSX 10.3. It will fail ------------------------------------------------------------------------ r11539 | skidd13 | 2007-11-29 18:27:39 +0000 (Thu, 29 Nov 2007) | 2 lines -Feature: Make the bridge selection window resizable ------------------------------------------------------------------------ r11538 | skidd13 | 2007-11-28 21:59:06 +0000 (Wed, 28 Nov 2007) | 2 lines -Codechange: Rewrite GetNthSetBit in a more uncontroversial way and add its documentation ------------------------------------------------------------------------ r11537 | rubidium | 2007-11-28 15:42:52 +0000 (Wed, 28 Nov 2007) | 2 lines -Codechange: make it much harder to 'accidentally' add savegame conversion code after the window and cache initializations. ------------------------------------------------------------------------ r11536 | belugas | 2007-11-28 00:41:20 +0000 (Wed, 28 Nov 2007) | 1 line -Codechange: Align some elements of the _tree_layout_sprite table a little better looking for the eye ------------------------------------------------------------------------ r11535 | miham | 2007-11-27 19:22:08 +0000 (Tue, 27 Nov 2007) | 3 lines -Update: WebTranslator2 update to 2007-11-27 20:21:42 ukrainian - 1 fixed by mad (1) ------------------------------------------------------------------------ r11534 | belugas | 2007-11-27 17:13:49 +0000 (Tue, 27 Nov 2007) | 5 lines -Feature(newgrf): Implement property 23h for Industries. This will add a cost to the removal of an industry using the cheat magic bulldozer. Note that the removal of regular or newgrf industries without specified removal cost will have no cost applied to. This is a difference from original spec, where a default base cost is added. ------------------------------------------------------------------------ r11533 | belugas | 2007-11-27 16:02:13 +0000 (Tue, 27 Nov 2007) | 4 lines -Codechange: Rename some unclear clear_x prices member names. While at it, remove one unused entry on the clear_price_table array. It is based on ground type, and the unused one was referencing a non existing one. ------------------------------------------------------------------------ r11532 | belugas | 2007-11-27 04:16:08 +0000 (Tue, 27 Nov 2007) | 2 lines -Feature[newgrf]: Add decrement(0x0D) / increment(0x0E) production operations from result of production callback cb29/35. Only var 0x93 will be affected by these operations ------------------------------------------------------------------------ r11531 | rubidium | 2007-11-26 23:28:29 +0000 (Mon, 26 Nov 2007) | 2 lines -Fix [FS#1459]: version determination did stall (read: never finish) when both svn and git were not installed. ------------------------------------------------------------------------ r11530 | smatz | 2007-11-26 22:56:30 +0000 (Mon, 26 Nov 2007) | 1 line -Codechange: do not update Tpool->first_free_index for PoolItems allocated on stack ------------------------------------------------------------------------ r11529 | miham | 2007-11-26 20:14:20 +0000 (Mon, 26 Nov 2007) | 10 lines -Update: WebTranslator2 update to 2007-11-26 21:13:37 brazilian_portuguese - 1 fixed by fukumori (1) catalan - 1 fixed, 2 changed by arnaullv (3) dutch - 1 fixed by habell (1) french - 1 fixed, 1 changed by glx (2) italian - 1 fixed by lorenzodv (1) lithuanian - 4 fixed by Domas (4) slovak - 1 fixed, 1 changed by lengyel (2) ukrainian - 5 fixed by mad (5) ------------------------------------------------------------------------ r11528 | maedhros | 2007-11-26 19:23:53 +0000 (Mon, 26 Nov 2007) | 2 lines -Fix (r11500): With smooth economy enabled, industries that should only decrease production would always increase it when more than 60% was transported. ------------------------------------------------------------------------ r11527 | skidd13 | 2007-11-26 17:50:22 +0000 (Mon, 26 Nov 2007) | 2 lines -Codechange: Split the bitmath functions of to their own files ------------------------------------------------------------------------ r11526 | skidd13 | 2007-11-26 16:01:29 +0000 (Mon, 26 Nov 2007) | 2 lines -Codechange: Rename the function delta fitting to the naming style ------------------------------------------------------------------------ r11525 | rubidium | 2007-11-25 20:20:16 +0000 (Sun, 25 Nov 2007) | 2 lines -Fix: do not do all kinds of 'updates' for town, waypoint, station and other signs when you haven't converted the map to the 'current' format as that means you are going to read data in the 'old' format when you assume that it is in the 'current' format. ------------------------------------------------------------------------ r11524 | rubidium | 2007-11-25 19:45:09 +0000 (Sun, 25 Nov 2007) | 2 lines -Fix [FS#1485]: assertion when tram reversed at a station. ------------------------------------------------------------------------ r11523 | skidd13 | 2007-11-25 15:35:25 +0000 (Sun, 25 Nov 2007) | 3 lines -Codechange: Move the CHANCE macros to core/random_func.cpp cause they depend on Random() -Codechange: Convert the CHANCE macros to functions and rename them fitting to the naming style ------------------------------------------------------------------------ r11522 | skidd13 | 2007-11-25 15:17:16 +0000 (Sun, 25 Nov 2007) | 2 lines -Fix: The scrollbar of the network gui could run out of bounds ------------------------------------------------------------------------ r11521 | egladil | 2007-11-25 14:43:16 +0000 (Sun, 25 Nov 2007) | 1 line -Codechange: [OSX] Check what the running os version is in a cleaner way. ------------------------------------------------------------------------ r11520 | egladil | 2007-11-25 12:58:32 +0000 (Sun, 25 Nov 2007) | 1 line -Fix: [OSX] The cocoa video driver let the mouse cursor escape the window when using rmb scrolling. Thanks ln- for pointing this out and providing a fix. ------------------------------------------------------------------------ r11519 | smatz | 2007-11-25 11:36:45 +0000 (Sun, 25 Nov 2007) | 1 line -Codechange: enumerization and cleanup of NetworkLobbyWindow in network_gui.cpp ------------------------------------------------------------------------ r11518 | smatz | 2007-11-25 00:41:31 +0000 (Sun, 25 Nov 2007) | 1 line -Codechange: enforce (by assert) unused parameters of widgets to be zero. Better readability of DrawWindowWidgets(), too ------------------------------------------------------------------------ r11517 | smatz | 2007-11-24 21:49:49 +0000 (Sat, 24 Nov 2007) | 1 line -Codechange: better cleanup of NetworkStartServerWindow in network_gui.cpp ------------------------------------------------------------------------ r11516 | smatz | 2007-11-24 21:41:59 +0000 (Sat, 24 Nov 2007) | 1 line -Codechange: cleanup of NetworkGameWindow in network_gui.cpp ------------------------------------------------------------------------