------------------------------------------------------------------------ r11527 | skidd13 | 2007-11-26 17:50:22 +0000 (Mon, 26 Nov 2007) | 2 lines -Codechange: Split the bitmath functions of to their own files ------------------------------------------------------------------------ r11526 | skidd13 | 2007-11-26 16:01:29 +0000 (Mon, 26 Nov 2007) | 2 lines -Codechange: Rename the function delta fitting to the naming style ------------------------------------------------------------------------ r11525 | rubidium | 2007-11-25 20:20:16 +0000 (Sun, 25 Nov 2007) | 2 lines -Fix: do not do all kinds of 'updates' for town, waypoint, station and other signs when you haven't converted the map to the 'current' format as that means you are going to read data in the 'old' format when you assume that it is in the 'current' format. ------------------------------------------------------------------------ r11524 | rubidium | 2007-11-25 19:45:09 +0000 (Sun, 25 Nov 2007) | 2 lines -Fix [FS#1485]: assertion when tram reversed at a station. ------------------------------------------------------------------------ r11523 | skidd13 | 2007-11-25 15:35:25 +0000 (Sun, 25 Nov 2007) | 3 lines -Codechange: Move the CHANCE macros to core/random_func.cpp cause they depend on Random() -Codechange: Convert the CHANCE macros to functions and rename them fitting to the naming style ------------------------------------------------------------------------ r11522 | skidd13 | 2007-11-25 15:17:16 +0000 (Sun, 25 Nov 2007) | 2 lines -Fix: The scrollbar of the network gui could run out of bounds ------------------------------------------------------------------------ r11521 | egladil | 2007-11-25 14:43:16 +0000 (Sun, 25 Nov 2007) | 1 line -Codechange: [OSX] Check what the running os version is in a cleaner way. ------------------------------------------------------------------------ r11520 | egladil | 2007-11-25 12:58:32 +0000 (Sun, 25 Nov 2007) | 1 line -Fix: [OSX] The cocoa video driver let the mouse cursor escape the window when using rmb scrolling. Thanks ln- for pointing this out and providing a fix. ------------------------------------------------------------------------ r11519 | smatz | 2007-11-25 11:36:45 +0000 (Sun, 25 Nov 2007) | 1 line -Codechange: enumerization and cleanup of NetworkLobbyWindow in network_gui.cpp ------------------------------------------------------------------------ r11518 | smatz | 2007-11-25 00:41:31 +0000 (Sun, 25 Nov 2007) | 1 line -Codechange: enforce (by assert) unused parameters of widgets to be zero. Better readability of DrawWindowWidgets(), too ------------------------------------------------------------------------ r11517 | smatz | 2007-11-24 21:49:49 +0000 (Sat, 24 Nov 2007) | 1 line -Codechange: better cleanup of NetworkStartServerWindow in network_gui.cpp ------------------------------------------------------------------------ r11516 | smatz | 2007-11-24 21:41:59 +0000 (Sat, 24 Nov 2007) | 1 line -Codechange: cleanup of NetworkGameWindow in network_gui.cpp ------------------------------------------------------------------------ r11515 | smatz | 2007-11-24 18:09:02 +0000 (Sat, 24 Nov 2007) | 1 line -Codechange: cleanup of NetworkStartServerWindow in network_gui.cpp ------------------------------------------------------------------------ r11514 | rubidium | 2007-11-24 14:03:47 +0000 (Sat, 24 Nov 2007) | 2 lines -Change: implement the automatic multiplier handler for NewGRF industries. ------------------------------------------------------------------------ r11513 | smatz | 2007-11-24 13:50:29 +0000 (Sat, 24 Nov 2007) | 1 line -Codechange: enumerize some depot GUI actions ------------------------------------------------------------------------ r11512 | rubidium | 2007-11-24 13:00:32 +0000 (Sat, 24 Nov 2007) | 2 lines -Change: make the subsidy window able to resize to something smaller than 640x127 (especially the 640 part) when the screen is really too small. ------------------------------------------------------------------------ r11511 | rubidium | 2007-11-24 12:36:52 +0000 (Sat, 24 Nov 2007) | 2 lines -Revert parts of r11505: forgot that CTRL might be used for other features, like adjacent stations or signals. ------------------------------------------------------------------------ r11510 | skidd13 | 2007-11-24 10:38:43 +0000 (Sat, 24 Nov 2007) | 2 lines -Codechange: merge the IS_*INSIDE* functions and rename them fitting to the naming style ------------------------------------------------------------------------ r11509 | rubidium | 2007-11-24 10:19:56 +0000 (Sat, 24 Nov 2007) | 2 lines -Fix: off-by-one error in some sprite numbers; increase sprite number counter before loading the next sprite instead of after doing so. ------------------------------------------------------------------------ r11508 | egladil | 2007-11-24 09:55:17 +0000 (Sat, 24 Nov 2007) | 1 line -Cleanup: Removed unused headers from the cocoa video driver. ------------------------------------------------------------------------ r11507 | rubidium | 2007-11-24 09:27:20 +0000 (Sat, 24 Nov 2007) | 2 lines -Fix [FS#1463]: signs totally illegible when transparant signs is turned on and zoomed out more than one level. ------------------------------------------------------------------------ r11506 | rubidium | 2007-11-24 09:14:58 +0000 (Sat, 24 Nov 2007) | 2 lines -Fix [FS#1471]: selling vehicles could cause the window of others to scroll to that location. ------------------------------------------------------------------------ r11505 | rubidium | 2007-11-24 08:56:29 +0000 (Sat, 24 Nov 2007) | 2 lines -Fix/Feature: make CTRL work on all road/rail construction options that 'work' with the 'Bulldozer' button instead of only a few. ------------------------------------------------------------------------ r11504 | rubidium | 2007-11-24 08:45:04 +0000 (Sat, 24 Nov 2007) | 2 lines -Fix [FS#1467]: removing docks/ship depots could result in non-canal water where canals should have been build. ------------------------------------------------------------------------ r11502 | glx | 2007-11-23 16:50:54 +0000 (Fri, 23 Nov 2007) | 2 lines -Fix (r11144): don't do standard production change if callbacks 29/35 failed -Fix (r11144): disable smooth economy for industries using callbacks 29/35 ------------------------------------------------------------------------ r11501 | egladil | 2007-11-23 13:45:59 +0000 (Fri, 23 Nov 2007) | 1 line -Fix: [OSX] This remedies a problem with right click scrolling that was introduced in r11492. ------------------------------------------------------------------------ r11500 | belugas | 2007-11-23 12:12:07 +0000 (Fri, 23 Nov 2007) | 1 line -Codechange: Smooth economy fine-tuning, making industries more responsive. Patch by Sirkoz. ------------------------------------------------------------------------ r11499 | glx | 2007-11-23 04:17:41 +0000 (Fri, 23 Nov 2007) | 1 line -Fix (r11144): mul/div factor were wrong (off by two) ------------------------------------------------------------------------ r11498 | egladil | 2007-11-23 02:44:05 +0000 (Fri, 23 Nov 2007) | 1 line -Add [FS#1411]: [OSX] Added support for using Quartz instead of Quickdraw in windowed mode on OS X 10.4 and higher. Based on a patch by blackis. ------------------------------------------------------------------------ r11495 | rubidium | 2007-11-22 22:54:49 +0000 (Thu, 22 Nov 2007) | 2 lines -Fix (r11493): some compilers fail to show warnings when they should. ------------------------------------------------------------------------ r11494 | glx | 2007-11-22 22:37:06 +0000 (Thu, 22 Nov 2007) | 2 lines -Fix [FS#1461] (r11450): cargo translation table was now loaded too late ;) ------------------------------------------------------------------------ r11493 | rubidium | 2007-11-22 22:34:30 +0000 (Thu, 22 Nov 2007) | 2 lines -Fix [FS#1472]: game crashing on savegame load because it tried to render some part of the window before the savegame conversion was done. ------------------------------------------------------------------------ r11492 | egladil | 2007-11-22 21:48:17 +0000 (Thu, 22 Nov 2007) | 1 line -Codechange: [OSX] Split the cocoa video driver into several files. The reason for this is that the fullscreen and windowed mode api are separate from each other in OS X and thus the driver actual is two drivers in one. This split is to make the code more readable and to prepare for replacing the Quickdraw windowed mode code which uses apis deprecated as of OS X 10.5 (and maybe earlier). ------------------------------------------------------------------------ r11491 | miham | 2007-11-22 19:55:54 +0000 (Thu, 22 Nov 2007) | 16 lines -Update: WebTranslator2 update to 2007-11-22 20:55:02 brazilian_portuguese - 5 fixed by tucalipe (5) catalan - 5 fixed by arnaullv (5) czech - 5 fixed by Hadez (5) danish - 6 fixed, 3 changed by MiR (9) dutch - 5 fixed by habell (5) french - 5 fixed by glx (5) italian - 2 fixed by lorenzodv (2) japanese - 5 fixed by ickoonite (5) korean - 58 fixed by leejaeuk5 (58) slovak - 5 fixed, 86 changed by lengyel (91) slovenian - 5 fixed by Necrolyte (5) spanish - 5 fixed by eusebio (5) swedish - 5 fixed by daishan (5) turkish - 5 fixed by jnmbk (5) ------------------------------------------------------------------------ r11490 | skidd13 | 2007-11-22 18:01:51 +0000 (Thu, 22 Nov 2007) | 3 lines -Codechange: Split the math functions to their own header -Codechange: Replace the rest of the math macros with functions ------------------------------------------------------------------------ r11489 | skidd13 | 2007-11-21 19:18:34 +0000 (Wed, 21 Nov 2007) | 2 lines -Fix r11488: Somehow the code was added multiple times ------------------------------------------------------------------------ r11488 | skidd13 | 2007-11-21 19:13:38 +0000 (Wed, 21 Nov 2007) | 4 lines -Codechange: Spilt the random functions out to seperate file -Codechange: Make the mersenne twister more readable -Codechange: Unify the seeding process of random ------------------------------------------------------------------------ r11487 | smatz | 2007-11-21 13:50:36 +0000 (Wed, 21 Nov 2007) | 1 line -Fix (r11435): move the list of vehicles a bit higher in the player GUI ------------------------------------------------------------------------ r11486 | glx | 2007-11-21 13:46:29 +0000 (Wed, 21 Nov 2007) | 1 line -Fix [FS#1457]: industry count was wrong in smallmap ------------------------------------------------------------------------ r11485 | skidd13 | 2007-11-20 14:11:19 +0000 (Tue, 20 Nov 2007) | 2 lines -Codechange: Remove the doubled function ToggleBitT and rename the remaining to fit with the naming style ------------------------------------------------------------------------ r11484 | skidd13 | 2007-11-20 13:35:54 +0000 (Tue, 20 Nov 2007) | 2 lines -Codechange: Remove the doubled function SetBitT and rename the remaining to fit with the naming style ------------------------------------------------------------------------ r11483 | skidd13 | 2007-11-20 12:57:24 +0000 (Tue, 20 Nov 2007) | 2 lines -Codechange: Replace codeparts with functions that do the same to increase readability ------------------------------------------------------------------------ r11482 | skidd13 | 2007-11-19 21:32:20 +0000 (Mon, 19 Nov 2007) | 2 lines -Codechange: Remove the doubled function ClrBitT and rename the remaining to fit with the naming style ------------------------------------------------------------------------ r11481 | skidd13 | 2007-11-19 21:02:30 +0000 (Mon, 19 Nov 2007) | 2 lines -Codechange: Rename the HASBIT function to fit with the naming style ------------------------------------------------------------------------ r11480 | skidd13 | 2007-11-19 20:40:14 +0000 (Mon, 19 Nov 2007) | 3 lines -Codechange: Rename the function ALIGN fitting to the naming style This fixes also FS#1450 ------------------------------------------------------------------------ r11479 | skidd13 | 2007-11-19 20:18:27 +0000 (Mon, 19 Nov 2007) | 3 lines -Codechange: Move the BIGMUL functions to the file of their usage -Codechange: Rename the BIGMUL functions to the fitting naming style ------------------------------------------------------------------------ r11478 | rubidium | 2007-11-19 19:54:23 +0000 (Mon, 19 Nov 2007) | 2 lines -Fix: two small layout issues with the vehicle grouping GUI. ------------------------------------------------------------------------